• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers
Exit
0

Enable to connect to mssql to test failover

New Here ,
Sep 29, 2022 Sep 29, 2022

Copy link to clipboard

Copied

I have a db connection( xxxdev2) on a UAT server.

I am trying to setup a duplicate db( xxxdev2b) opn my local server to test db failover if the primary server goes down.

For some reason, I connot get the connection working in the coldfusion Datasource section.

I can login in to the server using sql studio, but I get the following error on the datsopurce page of CF.

 

"Connection verification failed for data source: xxxdev2b
java.sql.SQLNonTransientConnectionException: [Macromedia][SQLServer JDBC Driver]Error establishing socket to host and port: LAPTOP-Rick:1433. Reason: Connection refused: connect"

Views

209

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Sep 30, 2022 Sep 30, 2022

Copy link to clipboard

Copied

When you use a hostname or machine name, the connection will use your machine's "real" IP address. Instead, use localhost or 127.0.0.1 for your connection.

 

Dave Watts, Eidolon LLC 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Sep 30, 2022 Sep 30, 2022

Copy link to clipboard

Copied

Thank you for the response. I tried both those ideas previously, and niether worked. JUst for fun I tried it again and same result, still not connecting.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Sep 30, 2022 Sep 30, 2022

Copy link to clipboard

Copied

In that case, you have a different problem! If you set up MS SQL Server locally, it probably won't accept connections over TCP/IP, so you'll have to enable that in the SQL Server Configuration Manager.

 

https://learn.microsoft.com/en-us/sql/relational-databases/sql-server-configuration-manager?view=sql...

 

Dave Watts, Eidolon LLC

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Oct 03, 2022 Oct 03, 2022

Copy link to clipboard

Copied

LATEST

Someone previously solved the same problem using the tip Dave has suggested: https://community.adobe.com/t5/coldfusion-discussions/error-establishing-socket-to-host-reason-conne... 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Resources
Documentation