• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers
Exit
0

Error Running Report

Explorer ,
Nov 17, 2022 Nov 17, 2022

Copy link to clipboard

Copied

Hello I'm trying to run a report cfr and I keep getting this error:

Error at line 4 char 226: net.sf.jasperreports.engine.xml.JasperDesignFactory

Is there soemthing I need to install? I'm using CF 2021 and SQL. Format the report is using is a pdf.

Thanks

Views

654

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Nov 17, 2022 Nov 17, 2022

Copy link to clipboard

Copied

Hi,

 

We have a fix for this issue. Please contact us at cf.install@adobe.com.

 

Thanks,

Vikram

 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Nov 17, 2022 Nov 17, 2022

Copy link to clipboard

Copied

Hi,

 

We have a fix for this issue. Please contact us at cf.install@adobe.com.

 

Thanks,

Vikram

 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Nov 17, 2022 Nov 17, 2022

Copy link to clipboard

Copied

Note that this problem was discussed elsewhere here:

 

https://community.adobe.com/t5/coldfusion-discussions/error-trying-to-create-a-cfreport-using-cf2021...

 

See that, for possible solutions including something I offered just today, before wanting to point you to it. Hopefully we'll here from someone else (there or here) if they may have still more updated news.

 

While we await that, and if the suggestions there don't help (look at more than the old "correct" answer), tell us here, what cf 2021 update are you on? 


/Charlie (troubleshooter, carehart.org)

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Nov 17, 2022 Nov 17, 2022

Copy link to clipboard

Copied

Ah, I was writing my reply (well, researching it) while Vikram was replying.

 

Vikram, what bug number is this fix you have? Thx. 


/Charlie (troubleshooter, carehart.org)

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Nov 17, 2022 Nov 17, 2022

Copy link to clipboard

Copied

Hi Charlie,

 

The bug ID is CF-4212391 and we have added a note that says the fix is removed from update 5 in the release note.

 

https://tracker.adobe.com/#/view/CF-4212391

 

Release note:

https://helpx.adobe.com/in/coldfusion/kb/coldfusion-2021-update-5.html

 

Thanks,

Vikram

 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Nov 17, 2022 Nov 17, 2022

Copy link to clipboard

Copied

Thanks, Vikram. I suspected it was that bug but wanted to hear it from you. And if you would please check out that other forum post I pointed to (that WAS about that bug)? I noted there how this bug was pulled.

 

And taunnt, you'll see I offered in the bug report the fix file. But as I asked in both places, it would be helpful to hear from Adobe. Both had no response for months. In particular, is the fix offered in the bug report still the right one? 

 

Vikram, please do answer in either of those two places, rather than here, as many others will see those and not this. 🙂 Those here have now been pointed to those. Thx. 


/Charlie (troubleshooter, carehart.org)

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Nov 17, 2022 Nov 17, 2022

Copy link to clipboard

Copied

Yep it was the bug. The fix did the trick.

Thanks

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Nov 17, 2022 Nov 17, 2022

Copy link to clipboard

Copied

Glad to hear, and thanks for the update. To be clear, do you mean you used the one I pointed to in that tracker ticket? Or one that Adobe gave you today instead? Thx. 


/Charlie (troubleshooter, carehart.org)

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Nov 17, 2022 Nov 17, 2022

Copy link to clipboard

Copied

LATEST

The one from Adobe.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Resources
Documentation