• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers

How do I install CF2021 in linux and configure CF2021 to use Apache?

Participant ,
Feb 03, 2022 Feb 03, 2022

Copy link to clipboard


TLDR: I cannot access the CF2021 using the built-in webserver and via Apache.


scenario: I need to install/configure CF2021 in a remote host (RHEL7 with Apache 2.4.*) that's console only. It currently has CF2016 but I've removed (via wsconfig -uninstall)the apache connectors for this version.




I followed this guide: https://helpx.adobe.com/au/coldfusion/installing/understanding-coldfusion-server-profiles.html and the instructions provided in the installation file (ColdFusion_2021_GUI_WWEJ_linux64.bin)


After installation, I ran "sudo coldfusion start"


More info:


1. I needed to run the installer as root otherwise it won't run.


2. During installation, I selected "Server installation" (not WAR/EAR options since I have a feeling I need Tomcat/Websphere for this option).


3. I installed CF2021 on the default folder that was presented to me. In my case this folder is "/opt/ColdFusion2021"


4. When I ran "sudo coldfusion start", a log file called "coldfusion-out.log" should've been created. I cannot find this file in the logs folder and when using the find command on CF root folder.


5. I browse "http://my-remote-ip:8500" in Firefox and all I get is a blank page.


6. I ran "ps aux | grep -i java" to confirm coldfusion is running.


7. This is my fourth time installing CF2021 (I've just deleted the /opt/ColdFusion2021 when I want to reinstall).


8. On my 2nd/3rd try, I tried using wsconfig (using the instructions on this page: https://helpx.adobe.com/coldfusion/configuring-administering/web-server-management.html) but I cannot access CF2021 via Apache (As I said above, CF2016 was previously installed and there are Apache directives/config already in place so I can access CFIDE via Apache. I just modified these lines to use CF root folder for CF2021)






Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
no replies

Have something to add?

Join the conversation