• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers
Exit
0

IIS/ cfm page / 404 Issue

Participant ,
Jul 19, 2018 Jul 19, 2018

Copy link to clipboard

Copied

I have a virtual website running off of IIS (looks like version 8.5,) and ColdFusion 11.

When I access a page as http://something.example.org/ which uses a ColdFusion template (index.cfm), the page correctly displays. However, when I request http://something.example.org/index.cfm it results in a 404.

All .cfm pages result in a 404

Other virtual websites on the same server behave correctly, returning successfully for both http://other.example.org and http://other.example.org/index.cfm

Since I just set up this new website, I'm wondering if there is an additional setting I'm just missing that prevents this error from occurring?

Pages with non .cfm extensions, like .htm & .pdf display properly.

TOPICS
Connector

Views

3.0K

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Jul 19, 2018 Jul 19, 2018

Copy link to clipboard

Copied

There is a conflict between your ISAPI Filter settings, your handler mappings, and your jakarta virtual directory. Usually, this can best be addressed by uninstalling and reinstalling the connector.

Dave Watts, Fig Leaf Software

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Jul 19, 2018 Jul 19, 2018

Copy link to clipboard

Copied

Dave,

I see the Jakarta directory under the Default Web Site directory. Is this the jakarta virtual directory? Is this the only Jakarta virtual directory?

  1. How do I uninstall it?
  2. How do I reinstall the connector?
  3. Is jakarta the connector?

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Jul 19, 2018 Jul 19, 2018

Copy link to clipboard

Copied

Each site should have its own jakarta virtual directory. You shouldn't have to do anything to it. Uninstall and reinstall the connector using the Web Server Configuration Tool.

ColdFusion Help | Connect to web servers

Dave Watts, Fig Leaf Software

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Jul 19, 2018 Jul 19, 2018

Copy link to clipboard

Copied

Sorry. So I don't currently have a Jakarta directory in my site. So I should just install it, as there is nothing to uninstall. correct?

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Jul 19, 2018 Jul 19, 2018

Copy link to clipboard

Copied

Hi,

If you have followed the lockdown in your server, please check for the /jakarta directory, if it is set to DENY. If, yes then it will not work, you have to allow it.

To check this in IIS, open the IIS>Request Filtering>URL.

Also, please check Dave's suggestion.

Thanks,

Priyank

Thanks,
Priyank Shrivastava

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Jul 20, 2018 Jul 20, 2018

Copy link to clipboard

Copied

How do I install the connector using the Web Server Configuration Tool.?

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Jul 20, 2018 Jul 20, 2018

Copy link to clipboard

Copied

When you first installed CF Server 11, immediately after installation you run wsconfig.exe to set up your connectors to IIS.  You just need to run wsconfig.exe, remove the current connector, and reinstall the connector to IIS.

HTH,

^ _ ^

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Jul 20, 2018 Jul 20, 2018

Copy link to clipboard

Copied

Weezer: I suspect you will find that you simple need to add a Jakarta virtual directory to each site that is currently “not working”, pointing it to the same folder that is pointed to by the one in the default site.

 

Here’s what’s happening, and it’s not new to CF2016 but to 10 and above: typically people will tell CF during installation to configure “all sites” (or after that runs they could run the web server config tool, and tell IT to do that). Well, that configures IIS at the server level to have handler mappings and isapi filters for CF. And it then (and ONLY THEN) adds a Jakarta virtual directory to WHATEVER SITES EXIST AT THAT TIME, pointing that vd to the same folder as the isapi filters and handler mappings it put in at the server level.

 

The problem is that that at some later point, people add a new site to IIS, and find it “doesn’t work”. And if you look in the isapi filters and handler mappings, you will see that it DOES have them, and they ARE the same as that at the server level (assuming you configured things to have IIS point to CF for “all sites”).

 

So what’s the problem? The problem is that while IIS DOES indeed cause new sites to inherit the server-level settings (for things like that, ISAPI Filters and handler mappings), IIS does not and CANNOT automatically add a new virtual directory to a new site. So it’s simply on YOU to do that. Then problem solved.

 

Or, as others have said, you could instead use the wsconfig tool to REMOVE the connector (for “all sites”) and simply add it back. It will do all the same that it did at first installation, but now it will add the Jakarta vd to all sites NOW existing. Just remember: in the future, you simply need to add that vd to any new sites (and you can script that to be done, with various means, if needed).

 

Finally, if with al the above things still do NOT work in just adding the VD, there could be some underlying IIS config file settings (like in the web.config of a newly added site) that may be leftover from an older version of CF. IIS would import those, and THEY could cause a conflict and make things “not work”. In that case, usually you only need to remove those conflicting old settings from the web.config, and save the file, and confirm that now IIS shows the site to be using the same ISAPI filters and handler mappings as the server level.

 

Let us know how that goes.


/Charlie (troubleshooter, carehart.org)

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Jul 02, 2024 Jul 02, 2024

Copy link to clipboard

Copied

This is not true (what Priyank said in 2015).  I have IIS set to deny and it works. 

 

[Moderator update: see the author's next comment revising this one.] 

 

There are filtering rules set to deny the download of *.dlls.  I have /jarkarta set to deny.  If you try to directly access the Jakarta directory and any of the files, you will get a 404 error which is by design.  However, IIS seems to work fine.

 

One item of note, we have the root of our website set to allow anonymous so that we can redirect users to a different area of the website if they do not have an account.  If you have the permission set on the Jakarta folder set to "Deny Anonymous," then you may have issues depending on your security requirements as it will only work with authenticated/authorized users.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Jul 02, 2024 Jul 02, 2024

Copy link to clipboard

Copied

I need to amend my answer and I cannot edit what I wrote.  I looked back over the configuration of my IIS server and found that I did need to set the "/jakarta/isapi_redirect.dll" URL to "Always Allow."

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Jul 02, 2024 Jul 02, 2024

Copy link to clipboard

Copied

LATEST

Thanks for the clarification. FWIW, as a moderator I was able to modify your previous comment to point readers to your subsequent comment. 🙂 


/Charlie (troubleshooter, carehart.org)

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Jul 22, 2018 Jul 22, 2018

Copy link to clipboard

Copied

Thank you to everyone who responded to this question.

This is a real all-star team of CF gurus.

Every answer was the correct answer.

Thank you, everyone!

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Resources
Documentation