• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers
Exit
0

Not able to connect to sqlserver database instance

New Here ,
Jun 19, 2023 Jun 19, 2023

Copy link to clipboard

Copied

I am trying to connection a database instance which is gcp , i have the correct credentials but I am getting error on CF admin dsn , I can connect this db instance using sqlserver studio using the login credentials(ip, db username , db password) but not able to connect it from cf admin which is also in gcp.

 image_2023_06_19T11_33_47_260Z.png

Connection verification failed for data source: testDB
java.sql.SQLInvalidAuthorizationSpecException: [Macromedia][SQLServer JDBC Driver][SQLServer]Login failed for user 'sqlserver'.
The root cause was that: java.sql.SQLInvalidAuthorizationSpecException: [Macromedia][SQLServer JDBC Driver][SQLServer]Login failed for user 'sqlserver'.

TOPICS
Connector , Database access , Server administration

Views

125

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Jun 19, 2023 Jun 19, 2023

Copy link to clipboard

Copied

What is your ColdFusion version and update level?

What datasource settings do you use, comparable to mine below (remember to use * characters for the password)

BKBK_0-1687205316572.png

 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Jun 21, 2023 Jun 21, 2023

Copy link to clipboard

Copied

LATEST

This is a pretty common problem with Microsoft SQL Server. It accepts two different forms of authentication: Windows Authentication by default and native SQL logins optionally. You can't disable Windows Authentication, but you do have to enable native SQL logins in all the cases I remember. I suspect that this is also how it works in GCP as long as you're not using Cloud SQL. Here's instructions from Microsoft on the different authentication options in SQL Server. You want "mixed-mode" to use native SQL logins.

 

https://learn.microsoft.com/en-us/sql/relational-databases/security/choose-an-authentication-mode?vi...

 

Dave Watts, Eidolon LLC

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Resources
Documentation