• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers
Exit
0

Unable to create a DSN to sql server.

New Here ,
Sep 29, 2021 Sep 29, 2021

Copy link to clipboard

Copied

Hello I am using coldfusion 2021 community and sqlserver 2014 on a windows 10 machine. I have not been able to create a DSN, receiving different errors the latest error being  Connection verification failed for data source: food_09292021
java.sql.SQLException: [Macromedia][SQLServer JDBC Driver]Kerberos Authentication is not supported by this SQLServer. The driver attempted Kerberos authentication because the AuthenticationMethod connect option was "auto" and no username/password was specified.

Thank you in advance for your help

Views

642

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Sep 30, 2021 Sep 30, 2021

Copy link to clipboard

Copied

Hi,

 

Enable SQL authentication in your SQL server and create username and password. Use the same credentials to create the DB connection in ColdFusion.

 

Thanks,
Priyank Shrivastava

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Sep 30, 2021 Sep 30, 2021

Copy link to clipboard

Copied

Having a look at the picture in the following Stackoverflow answer might help: https://stackoverflow.com/questions/42420529/coldfusion-is-not-connecting-datasource-with-sql-server... 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Feb 14, 2022 Feb 14, 2022

Copy link to clipboard

Copied

The issue is that the progress/datadirect JDBC driver which CF implements had a change in behavior (in the version of the driver which took effect in CF2021), and now "ntlm" is no longer one of the "auto" options for authentication.

 

Btu good news: you can get this password-less ("trusted") connection working by implementing a connectionstring (in the CF Admin DSN "advanced settings") with a value of: 

 

AuthenticationMethod=ntlm


/Charlie (troubleshooter, carehart.org)

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Feb 15, 2022 Feb 15, 2022

Copy link to clipboard

Copied

LATEST

Charlie's suggestion should work (judging by the results of googling "Kerberos Authentication is not supported by this SQLServer").  In fact, here is a similar forum thread.

 

However, in the unlikely event that it doesn't, then try adding the SQL Server domain to the connection string. That is, something like this (bkbkDomain is my domain name; use yours instead):

 

domain=bkbkDomain;AuthenticationMethod=ntlm

 

 If you don't know your SQL Server domain, the following query might help:

 

SELECT DEFAULT_DOMAIN()

 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Resources
Documentation