• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers
Exit
0

Updating Coldfusion 2016 update 7 to Update 17 - Help

Explorer ,
Apr 08, 2021 Apr 08, 2021

Copy link to clipboard

Copied

Hi,

I've been tasked with updating Coldfusion 2016 currently at Update-7 to the latest (17), Can i directly go from 7 to 17 or is there any issues if I do so? Where can I find details regarding dependencies and instructions. Since I took over this from someone who left, this is my first attempt at an upgrade 🙂

My current version is 2016,0,07,311392. (Linux Redhat Enterprise)

(Tomcat version : 8.5.32.0, Java version 1.8.0_192)

 

Please let me know.

 

Thanks

Sajan

Views

259

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Apr 08, 2021 Apr 08, 2021

Copy link to clipboard

Copied

Sajan, the answer is a conditional yes or no. In the case of the specific jump you are referring to, technically the answer is no (for most people, as I will explain). 

 

First, to be clear, yes, all CF updates are cumulative. NORMALLY, one could indeed skip to the latest they want. But in the case of CF2016 (and 2018), there are two conditions that change that circumstance, and there are in fact two updates between your update 7 and update 16 that you will need to consider implementing first, and almost certainly will need to.

 

And second, note that the top of the technote that you want to apply will explain this when necessary (though the wording is not always as obvious as it can be)  If you look at the top of the technote for CF2016 u17, you see it explaining points:

  • you should consider doing update 11 first, if you want to use the CF Admin UI to download updates beyond that (like 17).
  • Then you also need to understand that in skipping update 14, there is still an important REQUIREMENT (that comes FROM that update) where you must run the CF web server connector (wsconfig) to "upgrade" any current web server connectors you have (in your case on Linux, from Apache to CF). If you do not, your web sites will seem broken.


To be clear, it's not that you need to FIRST update to 14, just that if you do it or skip it, you need to do a step that was required AS OF that update. Again, the technote points you to the technote for update 14, where Adobe then shared more details.

 

Some people never have to use the wsconfig tool, so that need to do the "upgrade" can really throw them. There's both a command line and a gui way to do that wsconfig upgrade, including one command-line approach to upgrade ALL connectors.

 

Even then, note that for some folks it's NOT enough to JUST upgrade the connector. Another "security" facet of that required upgrade (which is caused by Tomcat, that CF runs on, rather than by a choice of Adobe's) is that you may need to modify an "address" attribute for the AJP connector element in the server.xml file for your CF instance. And you may need to add yet another attribute. Again, the technote talks about these, and the need to then restart CF. I also cover al that in a blog post with still more info.

 

Finally, note again that all the above applies also to those updating CF2018 (referring to different update numbers, of course, but the SAME issues).

 

If not for those issues, again normally you COULD otherwise just go to the latest available update. These are very unusual issues, but for many they cannot be ignored.

 

Let us know how it goes.


/Charlie (troubleshooter, carehart.org)

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Apr 08, 2021 Apr 08, 2021

Copy link to clipboard

Copied

Thanks a lot for the detailed reply, will update with the results soon.

-Sajan

 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Jun 24, 2021 Jun 24, 2021

Copy link to clipboard

Copied

Hello Charlie,

 

Thanks for all your responses regarding ColdFusion questions in your forums, a great help to all.

 

Finally I got the courage to do the upgrade and moving towards upgrading CF 2016 Update 17. I have a couple of more questions if you have some time to answer.

 

1. I have upgraded my dev server (currently at Update-9) to Update 13 via the Admin Console. I noticed that the banner in Admin console says "I have a 30day trial period.." We had enterprise licenses and not sure why I see that,  When I checked your responses in one of the sites, you have mentioned that "Customers running ColdFusion 9 or earlier are not eligible for upgrade pricing" does this mean we have to get new licenses to proceed further, since we are at Upd-9 ?

 

2. Our database is getting upgraded to Oracle 19c - Is CF 2016 Update 17 compatible? What I was told is we would need the Oracle JDBC driver so it can continue to work. Is this information true or we are forced to upgrade to CF 2021?

 

Thanks in advance

Sajan

 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Jun 25, 2021 Jun 25, 2021

Copy link to clipboard

Copied

I'm not Charlie but I'll give you some answers for now.

 

1. CF 9 is not CF 2016 Update 9, so you shouldn't have a problem there. Just reenter your license number if you need to, and that message should go away. You shouldn't even have to do that, but here we are.

 

2. You can always use any third-party "pure JDBC" driver with any recent version of CF. There's no guarantee that older versions of CF will include their own driver from DataDirect or wherever, but if you use Oracle's own pure JDBC driver that won't affect you. Note that (a) I don't know if CF 2016 Update 17's bundled DataDirect database driver has been certified as compatible with Oracle 19c, and (b) I don't know whether it would work even if it wasn't certified as compatible. But again, if you use Oracle's own driver this problem goes away. You'll have to choose "other" in the DB configuration form, and there are online instructions from Adobe on how to set the class name etc.

 

Dave Watts, Eidolon LLC

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Jun 28, 2021 Jun 28, 2021

Copy link to clipboard

Copied

Thanks a lot for you response Dave!

 

Good to know the version difference, did not see the subtle way the versions are called. Trying to find the prior license information to get rid of the 30 day trial period.

 

One of the posts read about running the wsconfig utility to update the connectors, located the file in 

/opt/coldfusion2016/cfusion/runtime/bin - but when I executed it, nothing happened / no gui appeared (per the link : https://www.carehart.org/blog/client/index.cfm/2019/11/13/when_how_update_cf_web_connector). I'm right now at update-13 and wanted to move on. With Update 14, there seems to be additional steps for the connnectors to be updated too. Stuck at this point. Any help is greatly appreciated if you can!

 

Thanks again,

Sajan

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Jun 29, 2021 Jun 29, 2021

Copy link to clipboard

Copied

The wsconfig utility itself (wsconfig.jar) has shells and batch files to run it. Make sure you run the right one (presumably wsconfig.sh?). Also, since you're on Linux, I'd recommend you dispense with the GUI altogether. There's a switch for doing that, and I'm not sure how well the GUI is going to open from the shell if you don't do that. Also, if there's an error message you'll get a chance to see it.

 

Dave Watts, Eidolon LLC

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Jun 29, 2021 Jun 29, 2021

Copy link to clipboard

Copied

 

I was able to get the wsconfig run and was able to update the Apache connector, (wsconfig.log - logfile showed the  Apache start.. end with success, no errors). Verified the server.xml file and worker.prop[erties file - AJP secret looks correct with those. But after that I'm getting a 503 Service unavailable error when we launch our application/site. Trying to figure what to do next.

 

Thanks

Sajan

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Jun 29, 2021 Jun 29, 2021

Copy link to clipboard

Copied

Could be that Tomcat is running with IPv4 and Apache is running with IPv6. Take a look here for potential help:

 

https://helpx.adobe.com/coldfusion/kb/coldfusion-2016-update-14.html

 

Dave Watts, Eidolon LLC

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Jun 29, 2021 Jun 29, 2021

Copy link to clipboard

Copied

Dave,

 

I added the attribute address="::1" to the AJP connector and restarted CF2016 Update-14 - Now the site pages are up and running fine.

 

Thanks

Sajan

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Jun 29, 2021 Jun 29, 2021

Copy link to clipboard

Copied

LATEST

You're welcome!

 

Dave Watts, Eidolon LLC

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Resources
Documentation