• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers
Exit
0

Windows could not start the coldfusion 2016 application server on local computer

Explorer ,
Jan 28, 2018 Jan 28, 2018

Copy link to clipboard

Copied

I have been running a Developer version of CF 2016 on a Windows 10 system for about 4 months with no issues at all.  Today I allowed Windows to perform a major update to Windows 10.  Upon completion, I could no longer start the Cold Fusion Application Server.  This is the message I received: Windows could not start the Cold Fusion 2016 application server on local computer.  I rebooted the computer to no avail, reinstalled Cold Fusion to no avail. The install failed at the point that it need to start the server.

Any help is greatly appreciated.

Thanks

TOPICS
Getting started

Views

6.2K

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Community Expert , Jan 29, 2018 Jan 29, 2018

I've seen this problem before, a long time ago. I suspect you need to reduce the amount of RAM you're committing to CF at startup. There are two memory settings in the jvm.config file: one for total memory and one for initial memory. Since you can't start CF to get to the CF Administrator, you'll need to edit this file manually. It will be in c:\coldfusion2016\cfusion\runtime\bin by default, I believe. There will be two settings: -xms and -xmx. You will probably need to reduce -xms to something

...

Votes

Translate

Translate
Adobe Employee ,
Jan 28, 2018 Jan 28, 2018

Copy link to clipboard

Copied

Hi,

I can check this at our end, meanwhile, can you please share the windows update build.

Also, try to start it from the command line and share the output.

Launch the command prompt as Run as Admin> Navigate to the ColdFusion2016\cfusion\bin folder and type the command "cfstart". Share the output from the command prompt.

Thanks,

Priyank Shrivastava

Thanks,
Priyank Shrivastava

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Jan 29, 2018 Jan 29, 2018

Copy link to clipboard

Copied

Good Morning.

The update build: Feature update to Windows 10, version 1709

An attempt for a manual start failed with this message: Could not reserve enough space for 1048576KB object heap

Thanks

John Rocaforte

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Jan 29, 2018 Jan 29, 2018

Copy link to clipboard

Copied

I've seen this problem before, a long time ago. I suspect you need to reduce the amount of RAM you're committing to CF at startup. There are two memory settings in the jvm.config file: one for total memory and one for initial memory. Since you can't start CF to get to the CF Administrator, you'll need to edit this file manually. It will be in c:\coldfusion2016\cfusion\runtime\bin by default, I believe. There will be two settings: -xms and -xmx. You will probably need to reduce -xms to something below the size of the object heap shown in your previous response.

Dave Watts, CTO, Fig Leaf Software.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Jan 29, 2018 Jan 29, 2018

Copy link to clipboard

Copied

It would be just c:\coldfusion2016\cfusion\bin (not runtime\bin, like it was in CF9 and earlier, so an understandable recollection for Dave).

And John, you may want to look at Task Manager and see both how much memory there is on the box and free at a point in time (on the performance tab), and then look at the details or processes tab to see what processes are using the most memory.


But isn't it interesting that that's the error you get, when you seem to feel that all that changed was a Window update? Hard to imagine a direct connection between that and running out of memory.

I'll throw out something you may not have considered: maybe the CF heap size WAS changed before the Windows update, but someone had not restarted CF between those two events. That may be why it only took effect on the box restart.


/Charlie (troubleshooter, carehart.org)

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Jan 29, 2018 Jan 29, 2018

Copy link to clipboard

Copied

I've had this problem after Windows updates before. Sometimes, Windows updates change how Windows can allocate memory, and Windows won't be able to allocate the previously-specified minimum heap size.

Dave Watts, CTO, Fig Leaf Software

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Jan 30, 2018 Jan 30, 2018

Copy link to clipboard

Copied

LATEST

I think that it was heap size. A manual restart using sfstart.bat throws an error message indicating insufficient memory. As a tempory fix, I moved the server to a different box.

Thanks

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Jan 30, 2018 Jan 30, 2018

Copy link to clipboard

Copied

I think that it was heap size. A manual restart using sfstart.bat throws an error message indicating insufficient memory. As a tempory fix, I moved the server to a different box.

Thanks

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Resources
Documentation