Highlighted

405 - HTTP verb error

Engaged ,
Apr 27, 2016

Copy link to clipboard

Copied

Hi everyone. I am testing some simple code on this page: Untitled Document  to do an online order with Stripe.com, but I keep getting this error message when I click Submit:

405 - HTTP verb used to access this page is not allowed.

The page you are looking for cannot be displayed because an invalid method (HTTP verb) was used to attempt access.

Does anyone know what to do to get this to work? Do I need to update something in the CF11 administrator pages or do I need to update something in our IIS server?

Andy

Views

1.6K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

405 - HTTP verb error

Engaged ,
Apr 27, 2016

Copy link to clipboard

Copied

Hi everyone. I am testing some simple code on this page: Untitled Document  to do an online order with Stripe.com, but I keep getting this error message when I click Submit:

405 - HTTP verb used to access this page is not allowed.

The page you are looking for cannot be displayed because an invalid method (HTTP verb) was used to attempt access.

Does anyone know what to do to get this to work? Do I need to update something in the CF11 administrator pages or do I need to update something in our IIS server?

Andy

Views

1.6K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Apr 27, 2016 0
LEGEND ,
Apr 27, 2016

Copy link to clipboard

Copied

I know next to nothing about IIS, but did a quick Google search:  405 - HTTP verb used to access this page is not allowed. : The Official Microsoft IIS Forums

HTH,

^_^

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Apr 27, 2016 0
Engaged ,
Apr 27, 2016

Copy link to clipboard

Copied

WolfShade,

       I saw this too, but I got stuck because when I click on the Default Web Site or even our own site, there is no option for permissions to click on, so I didn't know where to go from there. I'm not sure if these directions are on an older version of iis or what.

Andy

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Apr 27, 2016 0
LEGEND ,
Apr 27, 2016

Copy link to clipboard

Copied

jamie61880 wrote:

.. because when I click on the Default Web Site or even our own site, there is no option for permissions to click on ..

Sorry for being pedantic:  Did you single-left click, or single-right click?  Instructions specifically stated right-click to get properties.  The instructions are for IIS 7.5.  Which version of IIS are you using?

V/r,

^_^

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Apr 27, 2016 0
Engaged ,
Apr 27, 2016

Copy link to clipboard

Copied

Yes, I did right click, but Properties is not in the list of options to choose from. We do have IIS 8.5, so maybe that is why the instructions are out of date.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Apr 27, 2016 0
LEGEND ,
Apr 27, 2016

Copy link to clipboard

Copied

Could be.  Check the tools at the top of the window (ie, "File / Edit / etc") to see if properties is available, there.

HTH,

^_^

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Apr 27, 2016 0