Highlighted

After installing API Manager on it's own server, I am unable to login

Explorer ,
Feb 06, 2018

Copy link to clipboard

Copied

I have installed and uninstalled 3 times to no avail. I know I am using the correct user/pass but when I click "login" it just sits. No error message, no "incorrect password" message or anything of the sort. It just doesn't do anything.

I have followed everything I could find on how to install and it doesn't seem too complicated, but something isn't working and my googling isn't finding anyone else with this issue. It's possible that it's not working because I do not have CF installed in this VM, but my plan was to keep the API manager on it's own server. I haven't seen anything that says it needs to be on the same VM, but I don't know what else it could be.

I am running Windows Server 2016.

Hi,

Browser(IE) within the server has security enabled. Thus, it has issues with login into the portal because of Javascript.

Thanks,

Priyank

Views

126

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

After installing API Manager on it's own server, I am unable to login

Explorer ,
Feb 06, 2018

Copy link to clipboard

Copied

I have installed and uninstalled 3 times to no avail. I know I am using the correct user/pass but when I click "login" it just sits. No error message, no "incorrect password" message or anything of the sort. It just doesn't do anything.

I have followed everything I could find on how to install and it doesn't seem too complicated, but something isn't working and my googling isn't finding anyone else with this issue. It's possible that it's not working because I do not have CF installed in this VM, but my plan was to keep the API manager on it's own server. I haven't seen anything that says it needs to be on the same VM, but I don't know what else it could be.

I am running Windows Server 2016.

Hi,

Browser(IE) within the server has security enabled. Thus, it has issues with login into the portal because of Javascript.

Thanks,

Priyank

Views

127

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Feb 06, 2018 0
Adobe Employee ,
Feb 06, 2018

Copy link to clipboard

Copied

Hi,

Can you please go to this location C:\ColdFusion2016APIManager\conf and open the password.properties and add a new password under adminpassword= and restart API Manager.

Try to login again.

Thanks,

Priyank Shrivastava

Thanks,
Priyank Shrivastava

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 06, 2018 0
Explorer ,
Feb 06, 2018

Copy link to clipboard

Copied

I had tried this on an earlier attempt to no avail, but since you suggested it I tried it again. I'm getting the same behavior, though. It doesn't do anything after clicking the button.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 06, 2018 0
Explorer ,
Feb 06, 2018

Copy link to clipboard

Copied

Also, I did not install it in the default directory. I set up a folder at D:\APIManager to install into. I don't think this should make a difference, but since you specified the folder location I thought I should include it.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 06, 2018 0
Adobe Employee ,
Feb 06, 2018

Copy link to clipboard

Copied

Could you please try with a different browser other than IE.

Thanks,

Priyank

Thanks,
Priyank Shrivastava

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 06, 2018 0
LEGEND ,
Feb 06, 2018

Copy link to clipboard

Copied

Just out of curiosity, use Developer Tools (F12 in IE or FF) and click "Login" to see if there are any error messages that appear in Console or Network tabs.

V/r,

^ _ ^

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 06, 2018 0
Explorer ,
Feb 06, 2018

Copy link to clipboard

Copied

That's what did it. I am able to log in using Chrome instead of IE, though the docs do say that any modern browser including IE will work.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 06, 2018 0
Explorer ,
Feb 06, 2018

Copy link to clipboard

Copied

I tried looking at the console. No error messages or warnings. It just doesn't do anything.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 06, 2018 0
Adobe Employee ,
Feb 06, 2018

Copy link to clipboard

Copied

Hi,

Browser(IE) within the server has security enabled. Thus, it has issues with login into the portal because of Javascript.

Thanks,

Priyank

Thanks,
Priyank Shrivastava

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 06, 2018 0