Can't connect to database

Contributor ,
Aug 24, 2015 Aug 24, 2015

Copy link to clipboard

Copied

Using CF 11 on Windows 10 with MS SQL Server 2014

When I try to connect to my database, I get the error

The root cause was that: java.sql.SQLInvalidAuthorizationSpecException: [Macromedia][SQLServer JDBC Driver][SQLServer]Login failed for user 'admin'.

I have opened TCP/IP and Port 1433.

The settings in the CF connection panel are the same as I had before with Win 7, CF 10 and SQL Server 2008R2.

Can anyone give me a clue as to what else I need to do?

Doug

TOPICS
Database access

Views

559

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Guide ,
Nov 29, 2015 Nov 29, 2015

Copy link to clipboard

Copied

Were you ever able to resolve this?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Contributor ,
Nov 29, 2015 Nov 29, 2015

Copy link to clipboard

Copied

Have you installed update 7? Click the link below and follow the instructions in Installation.

ColdFusion 11 Update 7

Hope this gets you working.

Doug

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Guide ,
Nov 30, 2015 Nov 30, 2015

Copy link to clipboard

Copied

Um, Doug, I was replying to your original post, to see if you still needed assistance.  Did you ever get it working?

-Carl V.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Contributor ,
Nov 30, 2015 Nov 30, 2015

Copy link to clipboard

Copied

Sorry I'm not at my computer and I can't remember how I fixed it. I think it was something to do with the Security Login Settings for the database in SQL Server.

Doug

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Guide ,
Dec 01, 2015 Dec 01, 2015

Copy link to clipboard

Copied

LATEST

OK. I'll mark this question as answered.

-Carl V

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines