Can't make HTTPS call to sub domain on ColdFusion 10 Standard

New Here ,
Sep 11, 2014 Sep 11, 2014

Copy link to clipboard



I'd like to start by saying I didn't have this issue on CF9 Standard but recently updated to CF10 and now have the issue.

I have a site and several sub domains running on IIS and CF10. They are all set up as separate sites but share a wildcard SSL certificate for *


I'm doing cfhttp calls between the sites. They work fine over http but over https, I get the all too common 'I/O Exception: peer not authenticated' error.

Charset [empty string]

ErrorDetail I/O Exception: peer not authenticated

Filecontent Connection Failure

Header  [empty string]

Mimetype    Unable to determine MIME type of file.

Responseheader    struct [empty]

Statuscode  Connection Failure. Status code unavailable.

Text    YES

So I figured I needed to install the SSL certificate. I've installed the certificate in the correct key store and verified it's there using keytool -list and restarted. I even tried uninstalling and reinstalling it using the CertMan admin plugin but still get the error.

I know there are other work arounds for this problem with Enterprise but as I'm running standard I can't use them.

Does anyone have any suggestions? I'm pretty much stumped without https.









Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
no replies

Have something to add?

Join the conversation