Highlighted

cannot upload file greater than 2 GB using cffileupload

Explorer ,
Sep 22, 2016

Copy link to clipboard

Copied

I am able to upload 1 GB file.

However, when I upload 2.2 GB file, it get struck at 99% progress. I don't get any error.

I am running ColdFusion 11 on a Windows Server 2012 R2 machine.

1. In ColdFusion code, I set the file limit to 3.2 GB.

main cfm page:

<cffileupload

   url="uploadFilesProcess.cfm?par1=#STORAGEDIRECTORY#"

   progressbar="true"

   BGCOLOR="##FFFFFF"

   width=500

   height=250

   maxuploadsize=3200

   title = "File Upload" />

uploadFilesProcess.cfm:

<cfset param1 = url['par1'] />

<cffile action="uploadAll" destination="#param1#" nameconflict="overwrite" />

2. In ColdFusion server setting, I set the following:

Max number of POST request para: 3200

Max size of post data: 3200 MB

Request Throttle Threshold: 4 MB

Request Throttle Memory: 3200 MB

3. In Windows IIS filter setting, I set the max allowed content length (Bytes) to 3200000000.

Adobe Community Professional
Correct answer by BKBK | Adobe Community Professional

It also appears that 2 GB is an upload limit for most browsers. Try Chrome or Opera.

Views

723

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

cannot upload file greater than 2 GB using cffileupload

Explorer ,
Sep 22, 2016

Copy link to clipboard

Copied

I am able to upload 1 GB file.

However, when I upload 2.2 GB file, it get struck at 99% progress. I don't get any error.

I am running ColdFusion 11 on a Windows Server 2012 R2 machine.

1. In ColdFusion code, I set the file limit to 3.2 GB.

main cfm page:

<cffileupload

   url="uploadFilesProcess.cfm?par1=#STORAGEDIRECTORY#"

   progressbar="true"

   BGCOLOR="##FFFFFF"

   width=500

   height=250

   maxuploadsize=3200

   title = "File Upload" />

uploadFilesProcess.cfm:

<cfset param1 = url['par1'] />

<cffile action="uploadAll" destination="#param1#" nameconflict="overwrite" />

2. In ColdFusion server setting, I set the following:

Max number of POST request para: 3200

Max size of post data: 3200 MB

Request Throttle Threshold: 4 MB

Request Throttle Memory: 3200 MB

3. In Windows IIS filter setting, I set the max allowed content length (Bytes) to 3200000000.

Adobe Community Professional
Correct answer by BKBK | Adobe Community Professional

It also appears that 2 GB is an upload limit for most browsers. Try Chrome or Opera.

Views

724

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Sep 22, 2016 0
LEGEND ,
Sep 22, 2016

Copy link to clipboard

Copied

Hi, dzhaos,

The limit could be hardware (ie, if the webserver only has 6Gig of RAM, trying to upload a 2.2Gig file might be an issue because much of the RAM is being used by the server, itself, and CF and the webserver.)

Check the CF documentation to see if the maxuploadsize attribute should be in quotes (ie, "3200" instead of just 3200) and what that number refers to (bytes, megabytes, etc.)

The max number of POST isn't related to file size; it's a maximum number of FORM elements that can be submit at once.  Default is 100 for security reasons.

HTH,

^_^

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 22, 2016 0
Explorer ,
Sep 22, 2016

Copy link to clipboard

Copied

Thanks for the reply.

The server is a VM with 12 GB RAM. I monitored the memory usage during upload process and it never exceed 50%.

Normally 36% RAM is used and during the peak of the upload, 50% of RAM is used.

When upload is struck at 99%, the memory usage is at 36%.

I double checked the maxuploadsize parameter; it is in Megabytes and should be in quote.

David

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 22, 2016 0
Adobe Community Professional ,
Sep 22, 2016

Copy link to clipboard

Copied

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 22, 2016 0
Explorer ,
Sep 22, 2016

Copy link to clipboard

Copied

thanks for replying.

I still cannot upload the 2.2 GB file.

This is what I have:

1.In C:\inetpub\wwwroot\web.config, this is what I have:

<?xml version="1.0" encoding="UTF-8"?>

<configuration>

    <system.webServer>

        <defaultDocument>

            <files>

                <add value="main.cfm" />

            </files>

        </defaultDocument>

        <security>

            <requestFiltering>

                <requestLimits maxAllowedContentLength="3200000000" />

            </requestFiltering>

        </security>

        <directoryBrowse enabled="true" />

    </system.webServer>

    <system.web>

        <authentication mode="Windows" />

    </system.web>

</configuration>

2.In Windows IIS web server filter setting, I set the max allowed content length (Bytes) to 3200000000.

3. C:\Windows\System32\inetsrv\config\applicationHost.config, this is what I have"

   </hiddenSegments>

        <requestLimits maxAllowedContentLength="3300000000" />

   </requestFiltering>

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 22, 2016 0
Adobe Community Professional ,
Sep 22, 2016

Copy link to clipboard

Copied

It also appears that 2 GB is an upload limit for most browsers. Try Chrome or Opera.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 22, 2016 0
LEGEND ,
Sep 23, 2016

Copy link to clipboard

Copied

dzhaos​,

After having read what BKBK​ provided, I did some looking around (I was amazed that there even _was_ a limit.)

According to this MSDN blog, IE6-8 originally were set for 2g limit; they have since changed IE8 to accept 4g files.  But, the blog also mentions that HTML5 FileAPI can split the file into chunks, making even larger uploads possible.

V/r,

^_^

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 23, 2016 0
Explorer ,
Sep 23, 2016

Copy link to clipboard

Copied

thanks for the help

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 23, 2016 0
dzhaos LATEST
Explorer ,
Sep 23, 2016

Copy link to clipboard

Copied

thanks for the help

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 23, 2016 0