CF 10 errors show Error 500 instead of normal error message

Enthusiast ,
Sep 02, 2013

Copy link to clipboard

Copied

Hi,

Strangely, our CF 10 server has started to show "500 - Internal server error" whenever a CF error occurs, instead of the normal error message. The error is logged, but the front end shows the error 500 and nothing else. Normally, we'd see the error message and stack trace etc.

How would I troubleshoot that?

EDIT: This is a CF10 on IIS 8 Windows 2012 server, with update 11.

Regards,

Mark

Message was edited by: tribule

TOPICS
Server administration

Views

21.9K

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

1 Correct Answer

Explorer , Sep 05, 2013
David-Smith Explorer , Sep 05, 2013
If you previously had no issue, i.e., you would see the ColdFusion error message and stack trace, not the generic IIS screen, and then all of the sudden the generic IIS 500 error started showing, my guess would be that your web.config got overwritten either by a global change or some other local change.  I'm not sure how you had it set up before, but if you want to completely bypass the standard IIS 500 error msg and use your own built-in ColdFusion error (or simply see the ColdFusion "grey box"...

Likes

Translate

Translate
Jump to answer Jump to answer
Adobe Employee ,
Sep 03, 2013

Copy link to clipboard

Copied

Hello tribule,

Thank you for your post. The error 500 is a generic error thrown by IIS. IIS received the request; however, an internal error occurred during the processing of the request. The root cause of this error depends on which module handles the request and what was happening in the worker process when this error occurred.

One possibility is, IIS was not able to access the web.config file for the Web site or application. Please check the permissions.

The handlers might be causing the issue. Please remove the connector. Make sure you launch wsconfig with Run as Administrator while remove/adding connector. Check in the IIS manager for handlers, cgi restriction for connector dll entry (isapi_redirect.dll) and remove them manually if exist. Then only recreate the connector.

Also, please tune your application by applying the steps mentioned at http://blogs.coldfusion.com/post.cfm/tuning-coldfusion-10-iis-connector-configuration

Hope it helps.

Regards,

Anit Kumar

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
tribule AUTHOR
Enthusiast ,
Sep 05, 2013

Copy link to clipboard

Copied

Anit, in IIS8 there is an ISAPI Filters section. For our site it lists "tomcat" and a path to C:\ColdFusion10\cfusion\wsconfig\1\isapi_redirect.dll but there is no delete button. How do we delete the filter in order to recreate the connector?

Unless we have a <cfheader name="Connection" value="Close"> in our application, the 404 error page will not work. This was a bug that update 11 should have fixed.

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Explorer ,
Sep 05, 2013

Copy link to clipboard

Copied

If you previously had no issue, i.e., you would see the ColdFusion error message and stack trace, not the generic IIS screen, and then all of the sudden the generic IIS 500 error started showing, my guess would be that your web.config got overwritten either by a global change or some other local change.  I'm not sure how you had it set up before, but if you want to completely bypass the standard IIS 500 error msg and use your own built-in ColdFusion error (or simply see the ColdFusion "grey box") then you need to have this line <httpErrors existingResponse="PassThrough" /> somewhere in your web.config, like this:

<?xml version="1.0" encoding="UTF-8"?>

<configuration>

  <system.webServer>

    <httpErrors existingResponse="PassThrough" />

  </system.webServer>

</configuration>

There is a whole thread on this topic over here:  http://forums.adobe.com/message/5388861

This goes for 404 as well as 500 handling.  Not sure how IIS 8 differs from 7.5 but I would think these concepts are similar.  Hopefully I'm understanding your problem correctly.  I dealt with all this when switching from CF9 on IIS 6 to CF10 on IIS 7.5.

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
tribule AUTHOR
Enthusiast ,
Sep 05, 2013

Copy link to clipboard

Copied

Hi David, thanks for that, that was the issue. With the passthrough in place i now see the error.

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Explorer ,
Sep 05, 2013

Copy link to clipboard

Copied

No problem.  Unforunately, the reply from Anit_Kumar (staff) is a canned response and was not bound to shed any light on your situation.  I have seen the exact same canned reponse to similar issues on this forum.

Ranting starting in 3...2...1...

I get that "staff" are trying to appear proactive by posting these responses because theoretically any response is better than none, but if they aren't really reading and trying to understand your problem, and suggesting things like "Please remove the connector" to solve an easy problem like this, it  might actually take you down a road leading to more problems and time wasted.  Sorry to sound so negative about it, but I hate seeing cheap efforts like that from Adobe or anyone claiming to be staff (different story if it was just another "user").  Each case should be treated as unique, and at the very least point people to other threads where these issues have been discussed before.  Okay, I'll get off my soap box now.

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
LEGEND ,
Sep 05, 2013

Copy link to clipboard

Copied

I get that "staff" are trying to appear proactive by posting these responses because theoretically any response is better than none, but if they aren't really reading and trying to understand your problem, and suggesting things like "Please remove the connector" to solve an easy problem like this, it  might actually take you down a road leading to more problems and time wasted.  Sorry to sound so negative about it, but I hate seeing cheap efforts like that from Adobe or anyone claiming to be staff (different story if it was just another "user").  Each case should be treated as unique, and at the very least point people to other threads where these issues have been discussed before.  Okay, I'll get off my soap box now.

David, I could not agree more. Anit: please don't provide answers from your first-level support script or whatever it is you're getting you're asnswers from.  If you don't actually yourself know and understand the issue (having read it thoroughly, and not simply looking for keywords to match aganst your script), then please don't answer. If you personally have experienced the issue, or can take the time to research it and test/prove an answer, then by all means do answer it.

Cheers.

--

Adam

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
LEGEND ,
Sep 05, 2013

Copy link to clipboard

Copied

I get that "staff" are trying to appear proactive by posting these responses because theoretically any response is better than none, but if they aren't really reading and trying to understand your problem, and suggesting things like "Please remove the connector" to solve an easy problem like this, it  might actually take you down a road leading to more problems and time wasted.  Sorry to sound so negative about it, but I hate seeing cheap efforts like that from Adobe or anyone claiming to be staff (different story if it was just another "user").  Each case should be treated as unique, and at the very least point people to other threads where these issues have been discussed before.  Okay, I'll get off my soap box now.

David, I could not agree more. Anit: please don't provide answers from your first-level support script or whatever it is you're getting you're asnswers from.  If you don't actually yourself know and understand the issue (having read it thoroughly, and not simply looking for keywords to match aganst your script), then please don't answer. If you personally have experienced the issue, or can take the time to research it and test/prove an answer, then by all means do answer it.

Cheers.

--

Adam

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Adobe Employee ,
Sep 25, 2013

Copy link to clipboard

Copied

Adam and David,

                              Do understand that the staff from Adobe who are posting on the forums have been helpful on quite a few forum posts. Sure, on a few posts they may not have suggested the best possible solution or someone else from the community may have a better solution. But isn't that the whole point of a forum discussion where each one who thinks can address the problem being described pitches in? Being the professional forum that this is and how passionate each one of us are in trying to solve problems being discussed, let us not create a situation where we drive away the very people willing to contribute. Be it contribution from Adobe or otherwise.

The staff from Adobe are spending time and effort to ensure that there is no unanswered post. And in this spirit, they may have made a post when they have not fully understood the issue being faced. This needs some correction and I will pass this as a feedback to the team involved. But knowing the team personally, I know they will quickly learn and correct themselves.

I will instruct the team from Adobe to continue contributing to the posts. While I appreciate all the efforts from you to contribute to the forum, let us avoid making the forum hostile and encourage contribution from everyone associated. I look forward to your support in this regard.

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
LEGEND ,
Sep 25, 2013

Copy link to clipboard

Copied

Firstly: I appreciate Adobe's efforts in trying to help out on these forums.

But I disagree with what you say, Rakshith. We're better off NOT having answers from your guys if they are just answering from a script or via some other mechanism whilst not actually knowing themselves what the answer is.

People will take their answers in good faith, and possibly waste their time following through with the bad advice. I have been victim of this in the past when I knew less about CFML, and it is bloody annoying. I hasten to add I would (and have) said the same thing to non-Adobe people here who also "guess" at answers. I'm not just singling your guys out.

If your guys know the answers, by all means they should answer. If they do not... they should escalate it to someone who does.

I actually think a question is better off unanswered than having an answer which is just going to waste people's time. That said, obviously we should aim to get all questions answered with useful and accurate answers.

Well, that said, I say "we"... I have quit these forums in derision about how they are managed (not this issue, a different one), so I'm not part of that "we" any more. I only replied to this as I got a notification and you were addressing me personally.

All the best.

--

Adam

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Explorer ,
Sep 25, 2013

Copy link to clipboard

Copied

Bravo!

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Explorer ,
Nov 18, 2013

Copy link to clipboard

Copied

If you have the web config issue working, then try this. I had the exact same issue and I found this solution posted by a good samaritan:

In the CF Administrator, go to the "Settings" section. You'll see "Settings" in the left menu near the top.

If there is a checkmark in the area labeled "Enable HTTP status codes", remove it. Go to the bottom of the page and click on "Submit Changes."

When I did this, my errors including line numbers appeared again.

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
profit11 LATEST
New Here ,
Aug 09, 2015

Copy link to clipboard

Copied

brilliant! thank you! worked for me on:

Version  11,0,05,293506 

Tomcat Version  7.0.54.0 

Edition  Enterprise   

Operating System  Windows Server 2012   

OS Version  6.2   

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more