Highlighted

CF 10 IIS connector error

Explorer ,
Apr 07, 2015

Copy link to clipboard

Copied

I have two CF10 instances on a server. After applying hotfix 15 the second instance will not start. There are 4 sites, 3 in one instance and the fourth in another. I configured 3 connectors via the wsconfig tool in cfusion and the fourth via wsconfig tool from the second instance.

A command line start shows this error...any ideas?

SEVERE: Failed to initialize connector [Connector[AJP/1.3-8013]]
org.apache.catalina.LifecycleException: Failed to initialize component [Connecto
r[AJP/1.3-8013]]
        at org.apache.catalina.util.LifecycleBase.init(LifecycleBase.java:106)
        at org.apache.catalina.core.StandardService.initInternal(StandardService
.java:559)
        at org.apache.catalina.util.LifecycleBase.init(LifecycleBase.java:102)
        at org.apache.catalina.core.StandardServer.initInternal(StandardServer.j
ava:813)
        at org.apache.catalina.util.LifecycleBase.init(LifecycleBase.java:102)
        at com.adobe.coldfusion.launcher.Launcher.run(Launcher.java:293)
        at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
        at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
        at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
        at java.lang.reflect.Method.invoke(Unknown Source)
        at com.adobe.coldfusion.bootstrap.Bootstrap.init(Bootstrap.java:86)
        at com.adobe.coldfusion.bootstrap.Bootstrap.main(Bootstrap.java:161)
Caused by: java.lang.NoSuchMethodError: org.apache.coyote.ProtocolHandler.isAprR
equired()Z
        at org.apache.catalina.connector.Connector.initInternal(Connector.java:9
70)
        at org.apache.catalina.util.LifecycleBase.init(LifecycleBase.java:102)
        ... 11 more

Apr 07, 2015 1:27:13 PM org.apache.catalina.core.StandardService initInternal

worker.properties file

worker.list=internal_prod

  

worker.cfusion.type=ajp13

worker.cfusion.host=localhost

worker.cfusion.port=8013

worker.cfusion.max_reuse_connections=250

Views

244

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

CF 10 IIS connector error

Explorer ,
Apr 07, 2015

Copy link to clipboard

Copied

I have two CF10 instances on a server. After applying hotfix 15 the second instance will not start. There are 4 sites, 3 in one instance and the fourth in another. I configured 3 connectors via the wsconfig tool in cfusion and the fourth via wsconfig tool from the second instance.

A command line start shows this error...any ideas?

SEVERE: Failed to initialize connector [Connector[AJP/1.3-8013]]
org.apache.catalina.LifecycleException: Failed to initialize component [Connecto
r[AJP/1.3-8013]]
        at org.apache.catalina.util.LifecycleBase.init(LifecycleBase.java:106)
        at org.apache.catalina.core.StandardService.initInternal(StandardService
.java:559)
        at org.apache.catalina.util.LifecycleBase.init(LifecycleBase.java:102)
        at org.apache.catalina.core.StandardServer.initInternal(StandardServer.j
ava:813)
        at org.apache.catalina.util.LifecycleBase.init(LifecycleBase.java:102)
        at com.adobe.coldfusion.launcher.Launcher.run(Launcher.java:293)
        at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
        at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
        at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
        at java.lang.reflect.Method.invoke(Unknown Source)
        at com.adobe.coldfusion.bootstrap.Bootstrap.init(Bootstrap.java:86)
        at com.adobe.coldfusion.bootstrap.Bootstrap.main(Bootstrap.java:161)
Caused by: java.lang.NoSuchMethodError: org.apache.coyote.ProtocolHandler.isAprR
equired()Z
        at org.apache.catalina.connector.Connector.initInternal(Connector.java:9
70)
        at org.apache.catalina.util.LifecycleBase.init(LifecycleBase.java:102)
        ... 11 more

Apr 07, 2015 1:27:13 PM org.apache.catalina.core.StandardService initInternal

worker.properties file

worker.list=internal_prod

  

worker.cfusion.type=ajp13

worker.cfusion.host=localhost

worker.cfusion.port=8013

worker.cfusion.max_reuse_connections=250

Views

245

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Apr 07, 2015 0
Explorer ,
Apr 08, 2015

Copy link to clipboard

Copied

Somehow the second instance was hosed so I created a new one. I was able to create the connector on the new instance no problem.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Apr 08, 2015 0