Highlighted

CF 11 Add New Data Source Form Broken

Community Beginner ,
Jun 26, 2018

Copy link to clipboard

Copied

I went into the CFIDE in CF11 to add a new SQL data source and ran into an issue. So, I type in the Data Source Name, select the MS SQL driver, hit the Add button and the form refreshes to blank fields and no data source is created. I know it's supposed to take you to a detail page where you can enter in login info, etc, but it never does. It's almost like the form submits itself back to the page but no processing ever occurs. Things I've tried:

  • Restarting CF.
  • Multiple different browsers.
  • Different computers.
  • Ensured ad blockers were disabled.
  • Ensured CF 11 was up to date.
  • Tried to select different drivers from the dropdown select box just to make sure.

The server is CF 11 Dev Edition. I'm not aware of any restrictions on the dev edition that would prevent me from adding a data source. I have 3 active data sources currently and had no problem setting them up.

Any ideas? I've wasted 4 hours trying to figure this out already.

Thank in advance

Correct answer by planeBrad | Community Beginner

Dave. I figured this out. It was a little embarrassing, but your answer got me thinking about any changes that might cause an issue. Over a year ago I added a URL re-write rule for index pages. The form for data sources just so happens to submit to /CFIDE/administrator/datasources/index.cfm which got caught up in the re-write. So, I had to edit the rule to ignore CFIDE. Now the form works correctly.

Thanks for your help.

Views

205

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

CF 11 Add New Data Source Form Broken

Community Beginner ,
Jun 26, 2018

Copy link to clipboard

Copied

I went into the CFIDE in CF11 to add a new SQL data source and ran into an issue. So, I type in the Data Source Name, select the MS SQL driver, hit the Add button and the form refreshes to blank fields and no data source is created. I know it's supposed to take you to a detail page where you can enter in login info, etc, but it never does. It's almost like the form submits itself back to the page but no processing ever occurs. Things I've tried:

  • Restarting CF.
  • Multiple different browsers.
  • Different computers.
  • Ensured ad blockers were disabled.
  • Ensured CF 11 was up to date.
  • Tried to select different drivers from the dropdown select box just to make sure.

The server is CF 11 Dev Edition. I'm not aware of any restrictions on the dev edition that would prevent me from adding a data source. I have 3 active data sources currently and had no problem setting them up.

Any ideas? I've wasted 4 hours trying to figure this out already.

Thank in advance

Correct answer by planeBrad | Community Beginner

Dave. I figured this out. It was a little embarrassing, but your answer got me thinking about any changes that might cause an issue. Over a year ago I added a URL re-write rule for index pages. The form for data sources just so happens to submit to /CFIDE/administrator/datasources/index.cfm which got caught up in the re-write. So, I had to edit the rule to ignore CFIDE. Now the form works correctly.

Thanks for your help.

Views

206

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Jun 26, 2018 0
Adobe Community Professional ,
Jun 26, 2018

Copy link to clipboard

Copied

This might be a dumb question, but do any other changes work in the CF Administrator?

Are you accessing CF Administrator through IIS, or directly through the built-in web server? I'd recommend the latter for a variety of reasons, if you can do that.

Dave Watts, Fig Leaf Software

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 26, 2018 0
Community Beginner ,
Jun 26, 2018

Copy link to clipboard

Copied

I went into Security > Allowed IP Addresses and added an address through that form just to make sure all forms are not broken. So, it's not a CFIDE-wide form issue.

I am using IIS, but have been doing so with the CF 11 installation for years.

Thanks for the feedback.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 26, 2018 0
Community Beginner ,
Jun 26, 2018

Copy link to clipboard

Copied

Dave. I figured this out. It was a little embarrassing, but your answer got me thinking about any changes that might cause an issue. Over a year ago I added a URL re-write rule for index pages. The form for data sources just so happens to submit to /CFIDE/administrator/datasources/index.cfm which got caught up in the re-write. So, I had to edit the rule to ignore CFIDE. Now the form works correctly.

Thanks for your help.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 26, 2018 0
Adobe Community Professional ,
Jun 26, 2018

Copy link to clipboard

Copied

I'm happy to help, even if I didn't know the answer!

Dave Watts, Fig Leaf Software

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 26, 2018 0