Highlighted

CF 11 can not finding .css, .htm or .jpg files.

New Here ,
Jul 17, 2014

Copy link to clipboard

Copied

Installed CF 11 on Windows 7.  Installed it using built-in server the first time and later using Apache server.  I get the same results regardless of server installed.

The CFM page loads and displays text and will load <cfinclude> files.  However a 404 error results when trying to load an .htm file.  Also, in my .cfm index file, all CSS and Images are ignored (images show place holder box and Alt info but no image).

I attempted the above via DreamWeaver 8 and also by directly entering the URL into the browser.  I have tested this with both Safari and FireFox.  The examples below had their URLs entered directly (no DW involved).

The test pages I reference display perfectly in CF 9 but not in CF 11 (had same issue in CF10).  I thought this was a TomCat problem at first.  That is why I installed Apache.

CF_11_Using_Apache_Server.png

The above is the CF 11 page (same results if built-in server or Apache).

CF_9.png

This is the CF 9 page using built-in server.

This is the source for both instances (same exact file - not retyped)...

<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">

<html xmlns="http://www.w3.org/1999/xhtml">

<head>

<meta http-equiv="Content-Type" content="text/html; charset=iso-8859-1" />

<title>Untitled Document</title>

</head>

<body>

<img src="ContactHistory_400w.jpg" width="400" height="286" />

</body>

</html>

Notice: no ColdFusion code in the file.   Does anyone have a solution?  Thank you.

Views

258

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

CF 11 can not finding .css, .htm or .jpg files.

New Here ,
Jul 17, 2014

Copy link to clipboard

Copied

Installed CF 11 on Windows 7.  Installed it using built-in server the first time and later using Apache server.  I get the same results regardless of server installed.

The CFM page loads and displays text and will load <cfinclude> files.  However a 404 error results when trying to load an .htm file.  Also, in my .cfm index file, all CSS and Images are ignored (images show place holder box and Alt info but no image).

I attempted the above via DreamWeaver 8 and also by directly entering the URL into the browser.  I have tested this with both Safari and FireFox.  The examples below had their URLs entered directly (no DW involved).

The test pages I reference display perfectly in CF 9 but not in CF 11 (had same issue in CF10).  I thought this was a TomCat problem at first.  That is why I installed Apache.

CF_11_Using_Apache_Server.png

The above is the CF 11 page (same results if built-in server or Apache).

CF_9.png

This is the CF 9 page using built-in server.

This is the source for both instances (same exact file - not retyped)...

<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">

<html xmlns="http://www.w3.org/1999/xhtml">

<head>

<meta http-equiv="Content-Type" content="text/html; charset=iso-8859-1" />

<title>Untitled Document</title>

</head>

<body>

<img src="ContactHistory_400w.jpg" width="400" height="286" />

</body>

</html>

Notice: no ColdFusion code in the file.   Does anyone have a solution?  Thank you.

Views

259

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Jul 17, 2014 0
BKBK LATEST
Adobe Community Professional ,
Jul 18, 2014

Copy link to clipboard

Copied

This may be caused by remnants of an old installation still on your machine. Delete all parts of a previous Coldfusion installation. At least, go to Windows Services and disable them. Restart Windows.

Run the Web Server Configuration Tool. Configure for Apache.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jul 18, 2014 0