Highlighted

cf 11 install location

Explorer ,
Dec 17, 2014

Copy link to clipboard

Copied

Hi,

I am trying to locate information on where Cold Fusion 11 should be installed.

Currently, CF 9 is installed on the C drive where IIS is and there are no issues.

I have replaced CF 9 with CF 11, but I have installed CF 11 on the D drive and having issues.

Should CF 11 be installed at the default location on the C drive?

Thanks,

Mike

I noticed in the web.confif file for the website the following:

Webconfig.JPG

I would think the wsconfig tool would change the entries.

Also below is the complete information in the web.config file:

Complete webconfig file.JPG

Views

2.3K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

cf 11 install location

Explorer ,
Dec 17, 2014

Copy link to clipboard

Copied

Hi,

I am trying to locate information on where Cold Fusion 11 should be installed.

Currently, CF 9 is installed on the C drive where IIS is and there are no issues.

I have replaced CF 9 with CF 11, but I have installed CF 11 on the D drive and having issues.

Should CF 11 be installed at the default location on the C drive?

Thanks,

Mike

I noticed in the web.confif file for the website the following:

Webconfig.JPG

I would think the wsconfig tool would change the entries.

Also below is the complete information in the web.config file:

Complete webconfig file.JPG

Views

2.3K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Dec 17, 2014 0
Advocate ,
Dec 17, 2014

Copy link to clipboard

Copied

Coldfusion can be installed where ever you like (within reason). The issue you are having is probably related some something a lot different.

What are the issues you are having? Did you uninstall CF9 or just install CF11. Is it possible still are both running together?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Dec 17, 2014 0
Explorer ,
Dec 17, 2014

Copy link to clipboard

Copied

CF 9 has been uninstalled.

With CF 11 when the page initially loads the image appears. But when the page is refreshed the image disappears (there is a red x in place of the image).

I have applied all the latest updates for CF 11.

Mike

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Dec 17, 2014 0
Adobe Employee ,
Dec 17, 2014

Copy link to clipboard

Copied

Sounds like a connector issue. Can you recreate the connector (launching the tool as Administrator) and test the site?

Regards,

Anit Kumar

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Dec 17, 2014 0
Explorer ,
Dec 17, 2014

Copy link to clipboard

Copied

After the updates, I executed the Web Server Configuration (As Administrator) and the issue still exists.

Mike

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Dec 17, 2014 0
Advocate ,
Dec 17, 2014

Copy link to clipboard

Copied

Is this not the same as the issue you were having here?

Cold Fusion 11 refresh page image does not appear

HAve you done the things recommended in that thread?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Dec 17, 2014 0
Explorer ,
Dec 17, 2014

Copy link to clipboard

Copied

I have been talking with the server admin and the option for adding Failed Request Tracing Rule is not available in IIS.

Currently, running IIS 7.

Mike

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Dec 17, 2014 0
Adobe Employee ,
Dec 17, 2014

Copy link to clipboard

Copied

Mike,

Failed Request Tracing Rule is available in IIS7. You just need to enable it. See here http://technet.microsoft.com/en-us/library/cc725786(v=ws.10).aspx


Regards,

Anit Kumar

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Dec 17, 2014 0
Advocate ,
Dec 17, 2014

Copy link to clipboard

Copied

As mentioned it is available. In the post I made in that other thread I mentioned "If its not there then you will need to run the server management and add it to the IIS role on the server." You will need to get your server admin to do this.

Your best bet will be to get that on there and trace the 500 error.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Dec 17, 2014 0
Explorer ,
Dec 17, 2014

Copy link to clipboard

Copied

I had to install options for the Health and Diagnostics section in IIS for the Failed Request Tracing to appear in the Actions pane.

When I enter the following in the command window (Replacing the site with the URL, int with 50 and string with 404

appcmd configure trace " site " /enablesite /directory: string /maxLogFiles: int

The received is the following:

'appcmd' is not recognized as an internal or external command, operable program or batch file.

Mike

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Dec 17, 2014 0
Advocate ,
Dec 17, 2014

Copy link to clipboard

Copied

Try following the instructions I posted here Re: Cold Fusion 11 refresh page image does not appear

It uses the GUI built into IIS and might help you a bit more.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Dec 17, 2014 0
Explorer ,
Dec 17, 2014

Copy link to clipboard

Copied

The Failed Request Tracing Rules icon does not appear in IIS.

Mike

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Dec 17, 2014 0
Adobe Employee ,
Dec 17, 2014

Copy link to clipboard

Copied

Try IISRESET, in command prompt (run as admin) and refresh IIS Manager after that.

Regards,

Anit Kumar

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Dec 17, 2014 0
Explorer ,
Dec 17, 2014

Copy link to clipboard

Copied

I had the server rebooted and then the Failed Request Tracing Rules icon appeared in IIS.

I setup the trace and below are the results:

Security Denied by ISAPI Restrictions

ImageNameC:\JRun4\lib\wsconfig\1\jrun_iis6_wildcard.dll

NOTE: This directory does not exist on the server

Module Set Response error Status                                    IsapiModule

ModuleNameIsapiModule
Notification128
HttpStatus404
HttpReasonNot Found
HttpSubStatus2
ErrorCode2147943660
ConfigExceptionInfo
NotificationEXECUTE_REQUEST_HANDLER
ErrorCodeThis program is blocked by group policy. For more information, contact your system administrator. (0x800704ec)

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Dec 17, 2014 0
Most Valuable Participant ,
Dec 17, 2014

Copy link to clipboard

Copied

That looks like holdover garbage from your CF9 installation.  That should have been flushed out when IIS was removed and reinstalled.  Since it hasn't been, you're going to have to manually find this and delete it.  It's in either that site's handler mappings or in the main IIS handler mappings.

-Carl V.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Dec 17, 2014 0
Advocate ,
Dec 18, 2014

Copy link to clipboard

Copied

This looks like the DLLs left over from your previous CF9 installation.

If you look in the IIS Management Console under ISAPI and CGI restrictions (This is in the root of IIS, not your virtual site) do you see any "Macromedia Server Extensions" references DLLs from the old CF9 install?

If so it will probably be worth removing them. The only one you should have in there for a CF11 install is "tomcat_All" which points to a isapi_redirect.dll. If you don't see this either I would re-run the Web Server Configuration Tool (As Administrator) as this should restore it or worse case you could try adding manually. The default is shown here:

Untitled.png

If you have followed the lock-down guide at all you will need to make sure you have applied the correct permission to these folders too.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Dec 18, 2014 0
Explorer ,
Dec 18, 2014

Copy link to clipboard

Copied

In the ISAPI and CGI Restrictions in IIS, I see the following:

D:\ColdFusion9\runtime\lib\wsconfig\2\jrun_ii6_wildcard.dll

The entry does not have a description.

Also, there is an entry in the ISAPI and CGI Restrictions for tomcat_All.

Should the entry for the ColdFusion9 be deleted?

Mike


Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Dec 18, 2014 0
Adobe Employee ,
Dec 18, 2014

Copy link to clipboard

Copied

  1. Remove the connector.
  2. Refresh IIS and delete handlers for cfm, cfml, cfr, cfswf, cfc (look both at Server and website level).
  3. Try IISRESET, in command prompt (run as admin) and restart IIS Manager after that.
  4. Recreate the connector

Regards,

Anit Kumar

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Dec 18, 2014 0
Advocate ,
Dec 18, 2014

Copy link to clipboard

Copied

Remove this DLL from IIS. Then try removing and then re creating the Web Server Connector

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Dec 18, 2014 0
Explorer ,
Dec 18, 2014

Copy link to clipboard

Copied

Connector has been removed.

The identified handlers have been deleted.

Cannot find the IISRESET.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Dec 18, 2014 0
Adobe Employee ,
Dec 18, 2014

Copy link to clipboard

Copied

IISRESET has to be typed in command prompt (run as admin). This command is to restart IIS. You can restart IIS from IIS manager or from windows services as well.

Regards,

Anit Kumar

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Dec 18, 2014 0
Explorer ,
Dec 18, 2014

Copy link to clipboard

Copied

IIS has been restarted.

I removed and re created the Web Server Connector.

Now when executing the web page, getting a 404 error.

Noticed in the ISAPI and CGI Restrictions the entry for tomcat_All is missing. I added the tomcat_All.

Still getting a 404 message.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Dec 18, 2014 0
Adobe Employee ,
Dec 18, 2014

Copy link to clipboard

Copied

What is the url and what is the output. Please share the screenshot.

Regards,

Anit Kumar

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Dec 18, 2014 0
Advocate ,
Dec 18, 2014

Copy link to clipboard

Copied

You usually get a 404  because the handlers are not set-up correctly for the website. For example if you add a new virtual directory without running the web connector. Recreating the Web connector should recreate the tomcat_All DLL. As you said it wasn't there it probably wont have done the other parts correctly.

Remove the web connector, restart IIS and then add it back, make sure you add it to all the sites you have there. You should see the command prompt window showing it being added.

If this is still not working then under the virtual directory of your site, go into handler mappings and use the "Revert to Parent" option on the right hand side. You can do this for the ISAPI filters too.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Dec 18, 2014 0
Explorer ,
Dec 18, 2014

Copy link to clipboard

Copied

I manually deleted the entry from the ISAPI and CGI Restrictions.

I restarted IIS.

I manually added the entry from the ISAPI and CGI Restrictions.

When I executed the web connector, there were no messages in the command window.

Also, there is no "Revert to Parent". Only "Revert to Inherted".

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Dec 18, 2014 0
Adobe Employee ,
Dec 18, 2014

Copy link to clipboard

Copied

After manually deleting the mappings, you need not to recreate the connector manually. Please delete the manual entries, you have added.

Run the wsconfig tool with admin rights and then only create the connector. The tool is sufficient enough to add the necessary mappings.

Regards,

Anit Kumar

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Dec 18, 2014 0
Advocate ,
Dec 18, 2014

Copy link to clipboard

Copied

Revert to inherited is he one I meant, sorry. Are you running the connector as administrator?

The web connector should do all the work, you shouldn't have to add anything manually. If they are not appearing after running it, there must be a permissions error.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Dec 18, 2014 0
Explorer ,
Dec 18, 2014

Copy link to clipboard

Copied

I manually deleted the mapping.

I executed the wsconfig tool with admin rights. There were no options to only create the connector.

The tomcat_All did not appear in the ISAPI and CGI Restrictions and there were no messages in the command window.

Mike

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Dec 18, 2014 0