Highlighted

CF 11 Invalid Password for Administrator

Explorer ,
Apr 02, 2015

Copy link to clipboard

Copied


I am trying to install CF 11 on a  windows 2008 R2 Standard SP 1 server (This is a new server that does not have any websites on it yet). The initial install has no errors and ask if you want to finish the install by going to the administrator. I click ok. It goes to https://hostname/CFIDE/administrator/enter.cfm

The webpage it goes to is titled "Configuration and Settings Migration Wizard" "

ColdFusion has been successfully installed. This wizard will
guide you through the remaining server configuration steps and, if applicable,
migrate settings from a previous version of ColdFusion.

To guarantee the security of your server, please enter your
ColdFusion Administrator password. "

I type in my password and it says it is invalid... I KNOW it is correct. I have uninstalled CF twice now with the same results. The page looks a bit odd though. The box is blue and the text is black. Making it hard to read. The test also looks to be pushed down a bit (Like an image would go there, but there isn't anything there other than the space) and there is another space on the left side as well.

I have used IE and Chrome. Same problem.

I checked to make sure JavaScript was enabled and it was...

I have read about having it be a "trusted site". I did that. Didn't work.

I read "

Assume your website web.config file added additional mime types for file extensions .less and .ttf.

  • <staticContent>
  • <mimeMap fileExtension=".less" mimeType="text/plain" />
  •         <mimeMap fileExtension=".ttf" mimeType="text/plain" />
  • </staticContent>

"

I don't know where the web.config file is... So I don't know if this is a problem or not. Can someone tell me where I can find this. I searched in the ColdFusion11 Folder and didn't find it.

I have never had this much trouble installing CF before.

Can anyone help?

Thank you in advance.

Message was edited by: Dawn Green

For the first option, launch IIS and expand your Sites. Then right click on that particular site and select "explore". This will open your webroot for that particular website. Check for the existence of web.config and rename it.

For the second one, take a back of your server.xml and then replace the above segment (posted by you), by the below segment.

<!-- internal webserver start internal webserver end -->

    <Connector port="8500" protocol="HTTP/1.1"
               connectionTimeout="20000"
               redirectPort="8447" />
   

    <!-- A "Connector" using the shared thread pool-->
    <!--
    <Connector executor="tomcatThreadPool"
               port="8500" protocol="HTTP/1.1"
               connectionTimeout="20000"
               redirectPort="8447" />
    -->

Note:- Changes made to web.config would need IIS restart and changes made to server.xml would require ColdFusion Application Server restart.

Regards,

Anit Kumar

Views

1.9K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

CF 11 Invalid Password for Administrator

Explorer ,
Apr 02, 2015

Copy link to clipboard

Copied


I am trying to install CF 11 on a  windows 2008 R2 Standard SP 1 server (This is a new server that does not have any websites on it yet). The initial install has no errors and ask if you want to finish the install by going to the administrator. I click ok. It goes to https://hostname/CFIDE/administrator/enter.cfm

The webpage it goes to is titled "Configuration and Settings Migration Wizard" "

ColdFusion has been successfully installed. This wizard will
guide you through the remaining server configuration steps and, if applicable,
migrate settings from a previous version of ColdFusion.

To guarantee the security of your server, please enter your
ColdFusion Administrator password. "

I type in my password and it says it is invalid... I KNOW it is correct. I have uninstalled CF twice now with the same results. The page looks a bit odd though. The box is blue and the text is black. Making it hard to read. The test also looks to be pushed down a bit (Like an image would go there, but there isn't anything there other than the space) and there is another space on the left side as well.

I have used IE and Chrome. Same problem.

I checked to make sure JavaScript was enabled and it was...

I have read about having it be a "trusted site". I did that. Didn't work.

I read "

Assume your website web.config file added additional mime types for file extensions .less and .ttf.

  • <staticContent>
  • <mimeMap fileExtension=".less" mimeType="text/plain" />
  •         <mimeMap fileExtension=".ttf" mimeType="text/plain" />
  • </staticContent>

"

I don't know where the web.config file is... So I don't know if this is a problem or not. Can someone tell me where I can find this. I searched in the ColdFusion11 Folder and didn't find it.

I have never had this much trouble installing CF before.

Can anyone help?

Thank you in advance.

Message was edited by: Dawn Green

For the first option, launch IIS and expand your Sites. Then right click on that particular site and select "explore". This will open your webroot for that particular website. Check for the existence of web.config and rename it.

For the second one, take a back of your server.xml and then replace the above segment (posted by you), by the below segment.

<!-- internal webserver start internal webserver end -->

    <Connector port="8500" protocol="HTTP/1.1"
               connectionTimeout="20000"
               redirectPort="8447" />
   

    <!-- A "Connector" using the shared thread pool-->
    <!--
    <Connector executor="tomcatThreadPool"
               port="8500" protocol="HTTP/1.1"
               connectionTimeout="20000"
               redirectPort="8447" />
    -->

Note:- Changes made to web.config would need IIS restart and changes made to server.xml would require ColdFusion Application Server restart.

Regards,

Anit Kumar

Views

1.9K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Apr 02, 2015 0
New Here ,
Apr 06, 2015

Copy link to clipboard

Copied

I just dealt with this recently as well.  When you installed, did you specify the IP Address range for Administrator access?  If so, and you did not specify 127.0.0.1 for the local address, you'll need to complete the process from a browser in the ip address range you specified, in my case it was 192.168.20.* so I went to my broswer not on the localhost, and typed the url http://serveraddress/CFIDE/enter.cfm

I hope that helps.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Apr 06, 2015 0
Explorer ,
Apr 07, 2015

Copy link to clipboard

Copied

I chose the secure server profile the first time I installed. I have since uninstalled and reinstalled with the plain server configuration which does not allow you to enter an ip address. However with this being said, I have tried all kinds of combinations of ip address all returning with the same result. Invalid Password, Try again...

I have also disabled Symantec to see if that had anything to do with it. No luck there either. I have tried IE, Chrome, & FireFox browsers. No Luck.

Did your administrator log in page appear odd? Mine is a navy blue with black text. No graphics on it. Did yours look like that?

Thank you for your help. Keep giving me suggestions, please.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Apr 07, 2015 0
Advocate ,
Apr 07, 2015

Copy link to clipboard

Copied

This might be due to the mimeType extension in the web.config.

Can you give this a go:

  • Navigate to the webroot of your site.
  • Take a backup of web.config and open it with text editor (notepad etc)
  • Comment the entry for mimeType extension of ".air" like <!--<mimeMap fileExtension=".air" mimeType="application/vnd.adobe.air-application-installer-package+zip" />-->
  • Save the file and restart IIS.
  • Launch CF Admin and try to login.

You can find the web.config in the root of your site. If you are using IIS and the default website it will usually be in "C:\inetpub\wwwroot", otherwise if you have a separate virtual site setup it will be where ever the root of that is.

Note this is a different MimeType to the one you mentioned in your post.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Apr 07, 2015 0
Explorer ,
Apr 07, 2015

Copy link to clipboard

Copied

When I go to C:inetpub/wwwroot I do not see a web.config file. I have a folder aspnet_client, iisstart.htm, thumbs.db, welcome.png. Any other suggestions on where I might find it?

Thank you for your help and any suggestions.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Apr 07, 2015 0
Advocate ,
Apr 07, 2015

Copy link to clipboard

Copied

Do you have any other web sites setup in IIS?

Here are some things Anit has suggested in the past too:

Here are possible workarounds, you may try:-

        Note:- Enabling internal/built port would require a ColdFusion Application Server restart.The possible reason of this behavior is the CFID and CFTOKEN getting changed from the request start to request end. To find the cause, you can try running Charles Tool and follow the below steps:-

  1. First of all stop all http request.
  2. Close all browsers.
  3. Install Charles proxy.
  4. Start Charles proxy.
  5. Requests few times for http request (The CF Admin URL) to record its in-depth in Charles session/file.
  6. Then save those Charles session/file and review them for error/mistake in component and interface.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Apr 07, 2015 0
Explorer ,
Apr 07, 2015

Copy link to clipboard

Copied

This is a brand new server. It has not had any websites on it.

If I go to server manager/ roles/ webserver (iis). The Internet Information Services (IIS) Manager comes up. On the left of the IIS Manager window I have

Start Page

     Name of my server

     Application Pools

     Sites folder

          Default web site

               aspnet_client folder

               CFIDE folder

               Jakarta folder

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Apr 07, 2015 0
Explorer ,
Apr 07, 2015

Copy link to clipboard

Copied

I have tried alternate browsers. I tried IE, Chrome, & FireFox.

I have tried numerous combinations of the administrator address to log in. None worked. Including what you suggested.

What is the passwordreset.bat? I am not sure what you mean by that.

I have tried to access the server from several different locations including locally and nothing is working.

When you say enable internal/built port, what do you mean? How do you enable it?

I have not installed Charles Proxy.

Anit_Kumar gave me instructions for changing  adminconfig.xml and I am able to get into the admin now. However, it doesn't look right. The images are missing and I did not have to log in to go there. I just don't know what to do from here. Do I change my password, then try and log in? Or do I need to do something else?

I am very grateful for any and all ideas.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Apr 07, 2015 0
Explorer ,
Apr 07, 2015

Copy link to clipboard

Copied

adminlogin.jpg

This is what the admin login page looks like. Is this what it is supposed to look like?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Apr 07, 2015 0
Adobe Employee ,
Apr 07, 2015

Copy link to clipboard

Copied

Can you share your adminconfig.xml at \ColdFusion11\cfusion\lib\ ?

Regards,

Anit Kumar

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Apr 07, 2015 0
Explorer ,
Apr 07, 2015

Copy link to clipboard

Copied

Here is the adminconfig.xml

<?xml version="1.0" encoding="UTF-8"?>

<setupconfig>

    <runsetupwizard>true</runsetupwizard>

    <runmigrationwizard>false</runmigrationwizard>

    <runmxmigrationwizard>false</runmxmigrationwizard>

    <runsecureprofile>false</runsecureprofile>

    <migratecf10>false</migratecf10>

    <migratecf9>false</migratecf9>

    <setupoptions>

        <sampleapps>false</sampleapps>

        <odbc>true</odbc>

        <enablerds>false</enablerds>

    </setupoptions>

</setupconfig>

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Apr 07, 2015 0
Adobe Employee ,
Apr 07, 2015

Copy link to clipboard

Copied

Take a backup of your adminconfig.xml at \ColdFusion11\cfusion\lib\ and replace it with the text below.

<?xml version="1.0" encoding="UTF-8"?>

<setupconfig>

    <runsetupwizard>false</runsetupwizard>

    <runmigrationwizard>false</runmigrationwizard>

    <runmxmigrationwizard>false</runmxmigrationwizard>

    <runsecureprofile>false</runsecureprofile>

    <migratecf10>false</migratecf10>

    <migratecf9>false</migratecf9>

    <setupoptions>

        <sampleapps>false</sampleapps>

        <odbc>true</odbc>

        <enablerds>false</enablerds>

    </setupoptions>

</setupconfig>

Restart CF11 Application Service and access your CF Admin.

Regards,

Anit Kumar

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Apr 07, 2015 0
Explorer ,
Apr 07, 2015

Copy link to clipboard

Copied

I changed the file you suggested. I AM able to get into the administrator. However it didn't ask me to log in, it just went directly to the administrator. It also look odd. Like images are missing...

What should I do now?

This is further than I have gotten so far.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Apr 07, 2015 0
Adobe Employee ,
Apr 07, 2015

Copy link to clipboard

Copied

Under the CF Admin, go to Security > Administrator and select "". Setup a new password. Once you log out, you should be able to login with the new password only.

Regards,

Anit Kumar

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Apr 07, 2015 0
Explorer ,
Apr 07, 2015

Copy link to clipboard

Copied

SIGH.... I changed the password and set it to single password only. Saved it. It said it was saved. Logged out. Tried to log in with the new password, it Didn't work. It says Invalid Password. Please try again.

This log in page looks different than the one I had originally. It has a textbox for user name which is greyed out and can't be changed, with 'admin' entered in it.  What do you suggest now?

Here is what the admin looks like now.

admin image.jpg

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Apr 07, 2015 0
Adobe Employee ,
Apr 07, 2015

Copy link to clipboard

Copied

The page looks different and the images are missing, due to incorrect connector configuration. Could you please remove the connector and recreate it.

Remember, the Connector tool should be launched with Administrator privileges.

Regards,

Anit Kumar

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Apr 07, 2015 0
Explorer ,
Apr 07, 2015

Copy link to clipboard

Copied

Ok, This is what was originally showing.

Image1.jpg

I clicked it and then clicked the remove button. It was removed.

Then I restarted ColdFusion. I'm not sure I needed to, but I did. So I went back to the configuration tool and clicked the "Add" button. This is what it looks like.


Image2.jpg

Should I change anything or just click OK? The AppServer Cluster dropdown box has nothing in it.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Apr 07, 2015 0
Adobe Employee ,
Apr 07, 2015

Copy link to clipboard

Copied

Yes, All looks good. Go ahead

Regards,

Anit Kumar

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Apr 07, 2015 0
Explorer ,
Apr 07, 2015

Copy link to clipboard

Copied

I did add the connector. I then restarted ColdFusion and I can NOT log back into the administrator.

Anything else?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Apr 07, 2015 0
Adobe Employee ,
Apr 07, 2015

Copy link to clipboard

Copied

Can you share the URL, you are trying?

Regards,

Anit Kumar

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Apr 07, 2015 0
Explorer ,
Apr 07, 2015

Copy link to clipboard

Copied

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Apr 07, 2015 0
Adobe Employee ,
Apr 07, 2015

Copy link to clipboard

Copied

So, you have got two options from here.

Navigate to the webroot for http://pactnew.tarleton.edu/ and rename the web.config to web.config_old and restart IIS. Check your CF Admin.

OR


Enable internal/built port for ColdFusion and then try http://localhost:8500/CFIDE/administrator/index.cfm, where 8500 is the internal port for ColdFusion. Check your CF Admin.


Note:- Enabling internal/built port would require a ColdFusion Application Server restart.

Regards,

Anit Kumar

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Apr 07, 2015 0
Explorer ,
Apr 07, 2015

Copy link to clipboard

Copied

For the first option, I went to C/inetpub/wwwroot and I don't see a web.config file. Is this the correct location to find this file. If not, could you tell me where it is at?

As for the second option. I don't know how to enable it. I went to c/coldfusion11/cfusion/runtime/conf/server.xml. I opened the server.xml file with notepad. What do I change here?

<!-- internal webserver start
    <Connector port="8500" protocol="HTTP/1.1"
               connectionTimeout="20000"
               redirectPort="8447" />
    internal webserver end -->

    <!-- A "Connector" using the shared thread pool-->
    <!--
    <Connector executor="tomcatThreadPool"
               port="8500" protocol="HTTP/1.1"
               connectionTimeout="20000"
               redirectPort="8447" />
    -->

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Apr 07, 2015 0
Adobe Employee ,
Apr 07, 2015

Copy link to clipboard

Copied

For the first option, launch IIS and expand your Sites. Then right click on that particular site and select "explore". This will open your webroot for that particular website. Check for the existence of web.config and rename it.

For the second one, take a back of your server.xml and then replace the above segment (posted by you), by the below segment.

<!-- internal webserver start internal webserver end -->

    <Connector port="8500" protocol="HTTP/1.1"
               connectionTimeout="20000"
               redirectPort="8447" />
   

    <!-- A "Connector" using the shared thread pool-->
    <!--
    <Connector executor="tomcatThreadPool"
               port="8500" protocol="HTTP/1.1"
               connectionTimeout="20000"
               redirectPort="8447" />
    -->

Note:- Changes made to web.config would need IIS restart and changes made to server.xml would require ColdFusion Application Server restart.

Regards,

Anit Kumar

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Apr 07, 2015 0
Explorer ,
Apr 07, 2015

Copy link to clipboard

Copied

That did the trick!!! I am able to log in and all the images are there. Is there anything else I need to do in order to complete the install?

I am so thankful for your help! Thank you so much.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Apr 07, 2015 0
Explorer ,
Apr 07, 2015

Copy link to clipboard

Copied

It says there is an update available. Should I do this?...

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Apr 07, 2015 0
Adobe Employee ,
Apr 07, 2015

Copy link to clipboard

Copied

Which option did work for you? if its the first one, then you are all set.

Dawn Green wrote:

It says there is an update available. Should I do this?...

Yes, you can apply the updates. All are cumulative. So, you can apply the most recent one.

Regards,

Anit Kumar

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Apr 07, 2015 0
Explorer ,
Apr 07, 2015

Copy link to clipboard

Copied

It was the second option. I looked for the  web.config file, but I could not find it. Instead I changed the server.xml file by uncommenting the section of code you suggested. That worked.

Is there anything else I need to do since I went with that option?

Thank you again for your time and help.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Apr 07, 2015 0
Adobe Employee ,
Apr 07, 2015

Copy link to clipboard

Copied

You should follow the http://www.adobe.com/content/dam/Adobe/en/products/coldfusion/pdfs/cf11/cf11-lockdown-guide.pdf to make your server secure and protected.

Regards,

Anit Kumar

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Apr 07, 2015 0