Highlighted

CF 2016, Apache 2.4 on Win10 CFImage error

Explorer ,
May 20, 2016

Copy link to clipboard

Copied

I have a Windows 10 system with Apache 2.4 where I do ColdFusion development for a client who is considering an upgrade to ColdFusion 2016.   I installed a trial CF (planning to use it as a development after 30 days) and it works so far except for scripts with CFIMAGE with WritetoBrowser.

The browser debug tools in Firefox show an error: "NetworkError: 403 Forbidden - http://{vhostname}/CFFileServlet/_cf_image/_cfimg2.....jpg".

The Apache {vhostname}-error.log shows the following: "AH01630: client denied by server configuration: C:/CFusion2016 ...."

I earlier tried CF2016 on an older Windows 10 system with Apache2.2 and the applications using CFImage all seem to work fine there.   I understand there were numerous security changes from Apache2.2 to 2.4.   I suspect the mapping of CCFileServlet is behind the problem but nothing I have tried seems to make it work.  I am looking for ideas before I ditch the Apache2.4 - I would rather not go backwards with versions.  

It was the changes from Apache 2.2 to 2.4 that tripped me up.  Got it working now having fixed the aliases and permissions.

Views

480

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

CF 2016, Apache 2.4 on Win10 CFImage error

Explorer ,
May 20, 2016

Copy link to clipboard

Copied

I have a Windows 10 system with Apache 2.4 where I do ColdFusion development for a client who is considering an upgrade to ColdFusion 2016.   I installed a trial CF (planning to use it as a development after 30 days) and it works so far except for scripts with CFIMAGE with WritetoBrowser.

The browser debug tools in Firefox show an error: "NetworkError: 403 Forbidden - http://{vhostname}/CFFileServlet/_cf_image/_cfimg2.....jpg".

The Apache {vhostname}-error.log shows the following: "AH01630: client denied by server configuration: C:/CFusion2016 ...."

I earlier tried CF2016 on an older Windows 10 system with Apache2.2 and the applications using CFImage all seem to work fine there.   I understand there were numerous security changes from Apache2.2 to 2.4.   I suspect the mapping of CCFileServlet is behind the problem but nothing I have tried seems to make it work.  I am looking for ideas before I ditch the Apache2.4 - I would rather not go backwards with versions.  

It was the changes from Apache 2.2 to 2.4 that tripped me up.  Got it working now having fixed the aliases and permissions.

Views

481

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
May 20, 2016 0
Explorer ,
May 24, 2016

Copy link to clipboard

Copied

It was the changes from Apache 2.2 to 2.4 that tripped me up.  Got it working now having fixed the aliases and permissions.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
May 24, 2016 1