Highlighted

CF 2016 IIS Site Administrator Returns Blank Page

New Here ,
Jun 19, 2017

Copy link to clipboard

Copied

The core server localhost:8500/CFIDE/administrator brings up a page just fine.

localhost:8250/CFIDE/ brings up a directory search, but adding administrator to the end produces a blank page with no HTML at all. administrator/index.cfm does the same. However, putting an index.cfm in the root of the IIS site directory and navigating to localhost:8250/ opens that cfm file just fine. I must be missing some property setting/permission, but I've followed the two following guides to the letter.

http://wwwimages.adobe.com/content/dam/acom/en/products/coldfusion/pdfs/coldfusion-2016-lockdown-gui...

ColdFusion Help | Web Server Management

Environment: Windows Server 2012 R2. The only installs on it are IIS and CF 2016, all developer settings, using coldfusion internal server..

What are my likely failure points?

Views

1.6K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

CF 2016 IIS Site Administrator Returns Blank Page

New Here ,
Jun 19, 2017

Copy link to clipboard

Copied

The core server localhost:8500/CFIDE/administrator brings up a page just fine.

localhost:8250/CFIDE/ brings up a directory search, but adding administrator to the end produces a blank page with no HTML at all. administrator/index.cfm does the same. However, putting an index.cfm in the root of the IIS site directory and navigating to localhost:8250/ opens that cfm file just fine. I must be missing some property setting/permission, but I've followed the two following guides to the letter.

http://wwwimages.adobe.com/content/dam/acom/en/products/coldfusion/pdfs/coldfusion-2016-lockdown-gui...

ColdFusion Help | Web Server Management

Environment: Windows Server 2012 R2. The only installs on it are IIS and CF 2016, all developer settings, using coldfusion internal server..

What are my likely failure points?

Views

1.6K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Jun 19, 2017 0
Adobe Employee ,
Jun 20, 2017

Copy link to clipboard

Copied

Hi,

Are these new instances or you are running web server8250 port from the web server. Please share these details.

Thanks,

Priyank

Thanks,
Priyank Shrivastava

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 20, 2017 0
New Here ,
Jun 20, 2017

Copy link to clipboard

Copied

Hello Priyank,

In the Enterprise Manager we have the cfusion instance running on 8499 (the guides prescribed not using the default 8500 anymore). Then we have "ServerRemReview" running on 8500.

In IIS, "RemReview" is bound to port 8250. I ran wsconfig and set the connector with the following settings:

AppServer Host: localhost

AppServer Instance: ServerRemReview

Web Server: IIS

IIS Website: RemReview

Everything else was left in its defaults.

I apologize if I missed something basic. I'm the newbie in the team trying to wrap my head around this. We're trying to migrate from CF 9 to CF 2016, so I've gotten a lot of conflicting information on how it should be set up.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 20, 2017 0
Adobe Employee ,
Jun 21, 2017

Copy link to clipboard

Copied

Hi,

Seems like ColdFusion 9 and ColdFusion 2016 connectors are mixed in IIS. First, remove the ColdFusion 2016 connector and then remove the ColdFusion 9 connector.

Once you remove the connector, please check the Handler Mappings for the individual website and make sure there are no leftover handlers for ColdFusion. Then create the connector with ColdFusion 2016.

Please check this blog. Removing Corrupt Connector Dependencies from IIS | Adobe ColdFusion Blog

Thanks,

Priyank

Thanks,
Priyank Shrivastava

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 21, 2017 0
New Here ,
Jun 21, 2017

Copy link to clipboard

Copied

Hello Priyank,

This server has no CF 9 installation. I'm only setting up the CF 2016 environment on this server. The core server instance for the administrator works fine, but the instance for the IIS website isn't.

I've removed and remade the connectors through the wsconfig, but I can't reach http://localhost:8250/CDIFE/administrator.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 21, 2017 0
Adobe Community Professional ,
Jun 22, 2017

Copy link to clipboard

Copied

patrickp41016649  wrote

The core server instance for the administrator works fine, but the instance for the IIS website isn't.

Since you can get into the Administrator page of the main instance, you may then try the following. Navigate, in that page, to:

Enterprise Manager => Instance Manager.

Locate the row that corresponds to the new instance, and click on its home icon. The icon looks like this:

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 22, 2017 0
Adobe Employee ,
Jun 22, 2017

Copy link to clipboard

Copied

Hi,

Please share this info.

Go to IIS Manager>Expand your website which is running through this instance. Check, if you have CFIDE virtual directory or not, if you don't see the directory, then you have to add a virtual directory and give the path for CFIDE folder for that instance.

Now, come to ColdFusion2016 folder, navigate to \ColdFusion2016\config\wsconfig\{magic folder}, if you have multiple, then you should which one belongs to that instance. Go inside that folder and open the "uriworkermap.properties" and uncomment this "!/CFIDE/* = cfusion"  to "/CFIDE/* = cfusion".

Restart IIS and try again.

Thanks,

Priyank

Thanks,
Priyank Shrivastava

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 22, 2017 1
New Here ,
Mar 01, 2018

Copy link to clipboard

Copied

I am having the same issue but I am running Unbuntu...Any assitance is appreciated

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Mar 01, 2018 0