Highlighted

CF 2016 (Update 5 install) stops flash graphs displaying but no error?

New Here ,
Sep 15, 2017

Copy link to clipboard

Copied

Hi,

I had to install update 5 for CF2016 however it has stopped all out flah graphs from displaying. There is no error message just a blank page. If i cahnge this graphs to png or jpg format the do display however out whole app uses flash graphs...any idea how i fix this? Update 5 has to be installed on our server due to teh requirements of an internal pen test!

Views

1.2K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

CF 2016 (Update 5 install) stops flash graphs displaying but no error?

New Here ,
Sep 15, 2017

Copy link to clipboard

Copied

Hi,

I had to install update 5 for CF2016 however it has stopped all out flah graphs from displaying. There is no error message just a blank page. If i cahnge this graphs to png or jpg format the do display however out whole app uses flash graphs...any idea how i fix this? Update 5 has to be installed on our server due to teh requirements of an internal pen test!

Views

1.2K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Sep 15, 2017 0
Advocate ,
Sep 15, 2017

Copy link to clipboard

Copied

As per the cfchart docs:

FORMAT="flash" HAS BEEN DEPRECATED in Adobe ColdFusion (2016 release).

Normally they leave it in a bit longer but as updates happen things just suddenly disappear.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 15, 2017 0
New Here ,
Sep 15, 2017

Copy link to clipboard

Copied

Hi,

           We have tried pointing CF to jdk 1.8.0_112 and 1.8.0_144, it worked fine for us. Code which we used is as below

<cfchart format="flash" chartHeight="400" chartWidth="600" showLegend="no" title="chart" >

       <cfchartseries type="pie">

<cfchartdata item="Day 1" value="19.2"/>

<cfchartdata item="Day 2" value="15.2"/>

<cfchartdata item="Day 3" value="15.1"/>

       </cfchartseries>

</cfchart>

Please share the repro code with us, so that we can investigate on this. If you still face this issue please log a bug.

Thanks,

Dattanand Bhat

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 15, 2017 0
New Here ,
Sep 15, 2017

Copy link to clipboard

Copied

I have JDK 1.8.0_144 installed on the windows 2012 R2 server. I have tried the code above and its still does not work just a blank page when flash is set as the char format. Again when i set this to jpg or png the graph displays perfectly.

Do i need to point CF to use JDK 1.8.0_144?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 15, 2017 0
Advocate ,
Sep 15, 2017

Copy link to clipboard

Copied

You have to configure CF to use the different version of Java. Log into the CF Admin and use the Java and JVM settings. Change the path here.

How to change/upgrade JDK version of ColdFusion server | Adobe ColdFusion Blog

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 15, 2017 0
New Here ,
Sep 15, 2017

Copy link to clipboard

Copied

Can you please share the logs that you get when generating the chart. Also let us know form which update level you have moved to HF5. Please mail me the details at dabhat@adobe.com

Thanks,

Dattanand Bhat

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 15, 2017 0
New Here ,
Sep 15, 2017

Copy link to clipboard

Copied

Guys hold on; I was accessing the Charts using IE11; when i try Chrome and Edge the flash chart works; its just IE11 that the update seems to have effected! So it must be an group policy/setting within IE11!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 15, 2017 0
New Here ,
Sep 15, 2017

Copy link to clipboard

Copied

But it is working fine for me in IE 11 as well. Which update of IE11 are you on ?

chart.png

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 15, 2017 0
New Here ,
Sep 18, 2017

Copy link to clipboard

Copied

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 18, 2017 0
New Here ,
Sep 18, 2017

Copy link to clipboard

Copied

Could this setting be the issue? The IT admin in my work have disabled it?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 18, 2017 0
New Here ,
Sep 18, 2017

Copy link to clipboard

Copied

OK i have got a little further the document mode for IE11 for the site is set by default to IE7!!! When i change this to IE11 in developer tool bar the graphs works. So i need so find out why the site is using IE7 mode as default within IE11!

Could this be a group policy setting? OR is it my Webserver setup?

I have the below line of code which i can add to each of the CF pages wot work around this. 

<META http-equiv="X-UA-Compatible" content="IE=11">

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 18, 2017 0
NeilBell LATEST
New Here ,
Sep 18, 2017

Copy link to clipboard

Copied

Does CF Hotfix 5 update need IE11 in IE11 document mode? The intranet site in my work is set to Document mode 5 in IE11 which is IE5!!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 18, 2017 0
New Here ,
Sep 15, 2017

Copy link to clipboard

Copied

Why does CF Flash not work in IE11 now when it did before the CF hot fix 5 update?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 15, 2017 0