CF 2021 Server Update 1 - Git/Sourcetree

New Here ,
May 17, 2021 May 17, 2021

Copy link to clipboard

Copied

Have sourcetree open and functioning. Open CF Admin to download and install Server Update 1. As soon as I begin the update process, I noticed my sourcetree is now reporting an issue.

 

CF2021_Git_SourcetreeError.jpg

Everything is still there. The folder, files, and .git file. I tried restarting both Sourcetree and my system.

Any input would be greatly appreciated...

TOPICS
Getting started, Security, Server administration

Views

66

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
May 17, 2021 May 17, 2021

Copy link to clipboard

Copied

John, there's no connection between the CF 2021 Admin and any file in your IIS site webroot (that inetpub\wwwroot you show). So I really don't see how simply "starting a CF update" this way could lead to that. FWIW, starting a CF update (from the CF Admin) launches a java.exe process that runs the hotfix jar (downloaded in the admin).

 

I will say that the CF2021 update 1 is different from previous ones in that now CF2021 has the many different "modules" (now also listed in the CF Admin server updates page), and the "core" updater will by default also update all 25 modules. I really don't see how any of those modules could have an impact on your IIS site webroot.

 

(FWIW, since CF2016, the cf web server configuration tool, wsconfig, no longer even puts a CFIDE virtual directory into any sites--and if you add one manually or have one from before, you will find that CF pages served that way fail due to a protection added to the connector's uriworkermap.properties, blocking CFIDE access.)

 

So bottom line (for you): you feel that this CF update is somehow breaking your use of sourcetree, such that restarting it doesn't help? Does restarting your box? Again, I really can't see how there could be a connection between the two processes (the cf update, and your sourcetree watching your webroot), let alone how anything about the update would hamper your sourcetree this way.

 

It will be very interesting to hear if you or anyone else finds more about this behavior you are observing.


/Charlie (server troubleshooter, carehart.org)

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
May 17, 2021 May 17, 2021

Copy link to clipboard

Copied

Charlie -

Thank you for the reply. I am going to give it another try this evening. I have replicated the issue twice now and that has included a restart of the Sourcetree application and my system as well.  In this third attempt I will capture every bit of data that I can think of along with more screen shots. If there is anything that would be of use to you please let me know and I will get it.

Again thanks for the input...

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
May 18, 2021 May 18, 2021

Copy link to clipboard

Copied

LATEST

@johnw18670011 , what is your Operating System?

 

I ask for the following reason. Some developers have solved similar problems on Windows 10.

What they did was:

 

  1. Install the latest Windows update.
  2. Restart Windows.
  3. Attempt the ColdFusion update once again.
  4. Successful? Then we're done.

 

If the fatal: open /dev/null problem persists, then continue as follows:

 

  1. Open the registry editor (Start command: regedit);
  2. Go to HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Services;
  3. Does it contain a folder called Null? If not, create it.
  4. Ensure that the folder Null contains keys that have values as shown in the picture. In particular, ensure that the value of Start is 1.
  5. If you made any changes, restart Windows.

BKBK_0-1621325254358.png

 

 

 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines