Highlighted

CF 8 to 11 default.html and login.cfm stuck in endless loop.

New Here ,
Aug 14, 2015

Copy link to clipboard

Copied

I have a ColdFusion 8 site that runs fine on an old Windows 2003 server that needs to be decommissioned. I’ve been able to test the site on a VMware Windows 2003 server image and that works well. I just install IIS, move the site folder into “C:\inetpub\wwwroot\” then install ColdFusion 8 and add one ColdFusion data source to an MDB file.

I need to move it to a new 2012 Server and when I do the same as above on a Windows 7 32-bit or Windows 2012 Server 64-bit with ColdFusion 11 the default.html page that just opens the login.cfm page get stuck in a loop with the URLs flashing back and forth with an empty webpage.

I know there are some issues with 32 vs 64-bit but I have the same issue in Windows 7 Windows 7 32-bit or Windows 2012 Server 64-bit but I think I'll have more issues if I can get passed this first one as the data source on Windows 2012 Server 64-bit fails the verify:

Connection verification failed for data source: OMS-HAYWARD

java.sql.SQLException: [Macromedia][SequeLink JDBC Driver][ODBC Socket]internal error: The specified DSN contains an architecture mismatch between the Driver and Application

The root cause was that: java.sql.SQLException: [Macromedia][SequeLink JDBC Driver][ODBC Socket]internal error: The specified DSN contains an architecture mismatch between the Driver and Application

Help!

Views

332

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

CF 8 to 11 default.html and login.cfm stuck in endless loop.

New Here ,
Aug 14, 2015

Copy link to clipboard

Copied

I have a ColdFusion 8 site that runs fine on an old Windows 2003 server that needs to be decommissioned. I’ve been able to test the site on a VMware Windows 2003 server image and that works well. I just install IIS, move the site folder into “C:\inetpub\wwwroot\” then install ColdFusion 8 and add one ColdFusion data source to an MDB file.

I need to move it to a new 2012 Server and when I do the same as above on a Windows 7 32-bit or Windows 2012 Server 64-bit with ColdFusion 11 the default.html page that just opens the login.cfm page get stuck in a loop with the URLs flashing back and forth with an empty webpage.

I know there are some issues with 32 vs 64-bit but I have the same issue in Windows 7 Windows 7 32-bit or Windows 2012 Server 64-bit but I think I'll have more issues if I can get passed this first one as the data source on Windows 2012 Server 64-bit fails the verify:

Connection verification failed for data source: OMS-HAYWARD

java.sql.SQLException: [Macromedia][SequeLink JDBC Driver][ODBC Socket]internal error: The specified DSN contains an architecture mismatch between the Driver and Application

The root cause was that: java.sql.SQLException: [Macromedia][SequeLink JDBC Driver][ODBC Socket]internal error: The specified DSN contains an architecture mismatch between the Driver and Application

Help!

Views

333

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Aug 14, 2015 0
New Here ,
Aug 14, 2015

Copy link to clipboard

Copied

I still can't get the login.cfm to open but I was able to get the data source on Windows 2012 Server 64-bit to verify with this info:

ColdFusion-10 64bit and MSAccess — Adobe ColdFusion Blog

Don't know if it works yet but...

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Aug 14, 2015 0
New Here ,
Aug 14, 2015

Copy link to clipboard

Copied

This is the login.cfm file if that helps:

<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.0 Transitional//EN">

<cfquery datasource="#session.dsn#" name="admin">

SELECT

  FirstName,

  LastName,

  Email

FROM

  omsUserAccounts

WHERE

  UserName = 'admin'

</cfquery>

<html>

<head>

  <title>Login</title>

  <link rel="stylesheet" href="oms/styles/login.css">

  <script language="Javascript" src="oms/scripts/frameBuster.js"></script>

  <script language="JavaScript">

  function login(myform) {

  if (! window.focus) return true;

  var d = new Date();

  windowname=d.getTime();

  window.open("loginaction.cfm",windowname,"width=1012,height=678,top=0,left=0,toolbars=no,status=yes,scrollbars=yes,resizable=yes");

  myform.target=windowname;

  window.opener = top;

  top.close();

  return true;

  }

  </script>

  </head>

<body class="tmplogin" onLoad="checkStatus();">

<br><br><br><br><br>

<div align="center">

<form method="post" name="loginform" action="loginAction.cfm" <cfoutput><cfif #oms.application.disablebrowsertoolbar#>ONSUBMIT="login(this)"</cfif></cfoutput>>

<table cellspacing="0" cellpadding="2" style="background-color:white;border:1px solid black;">

<tr>

  <td>

  <table cellspacing="0" cellpadding="0" style="background-color:ffffff;border:1px solid black;">

<tr>

  <td>

  <img src="oms/images/loginbanner.gif" style="border-bottom:2px solid #ff8040;">

  </td>

</tr>

<tr>

  <td style="border-bottom:2px solid #ff8040;padding-bottom:3px;" width="300">

  <table cellspacing="0" cellpadding="0">

  <tr>

  <td class="message" valign="top"> Client:</td>

  <td class="message"><cfoutput>#oms.application.customer.name#</cfoutput></td>

  </tr>

  <tr>

  <td class="message" valign="top"> Application: </td>

  <td class="message"><cfoutput>#oms.application.name#</cfoutput></td>

  </tr>

  <tr>

  <td class="message" valign="top"> Support:</td>

  <td class="message"><cfoutput><a href="mailto:#admin.Email#">#admin.FirstName# #admin.LastName#</a></cfoutput></td>

  </tr>

</table>

  </td>

</tr>

<tr>

  <td class="container" align="center" height="100%">

  <table cellspacing="6" cellpadding="0">

  <tr>

     <td class="txt" align="right">User Name:</td>

     <td class="txt"><input type="Text" name="username" required="Yes" size="24" class="inputtxt"></td>

  </tr>

  <tr>

     <td class="txt" align="right">Password:</td>

     <td class="txt"><input type="Password" name="password" required="Yes" size="24" class="inputtxt"></td>

  </tr>

  <tr>

  <td></td>

  <td class="txt" align="right">

  <input type="submit" name="submit" value="Log On">

  </td>

  </tr>

  </table>

  </td>

</tr>

<tr>

  <td class="copy" align="center">[<cfoutput>v#oms.application.version#</cfoutput> CF]</td>

</tr>

<tr>

  <td class="copy" align="center">&copy 2000-2008  All rights reserved.</td>

</tr>

</table>

  </td>

</tr>

</table>

</form>

</div>

</body>

</html>

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Aug 14, 2015 0
New Here ,
Aug 19, 2015

Copy link to clipboard

Copied

Is there something, anything I can try?

I found and set the web service version to 1 but that did not help.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Aug 19, 2015 0
New Here ,
Aug 20, 2015

Copy link to clipboard

Copied

I’ve been testing various VMware installs with Windows 7, Server 2003 and 2012. I was finally able to install and run ColdFusion 8 on Windows 7 64-bit and run the OMS site. The trick was (along with installing the IIS 6 Management Compatibility and ISAPI Extensions and filters) to install the 32-bit version of ColdFusion 8 and set the IIS application pool to run 32-bit applications.

I still can’t get the site to run on Server 2012 with ColdFusion 11 and the ColdFusion 8 Web Server Configuration will not run when installed on Server 2012. Even installing the 32-bit version of ColdFusion 11 and setting IIS up the same as the working Windows 7 64-bit install, I still get the endless loop.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Aug 20, 2015 0