Highlighted

CF10 Java 7.51 - "Missing required permissions manifest attribute"

New Here ,
Mar 21, 2014

Copy link to clipboard

Copied

Our clients are reporting that after they update to Java 7.51 they are now getting the following error:

"Missing required permissions manifest attribute in main jar: CFIDE/classes/cfapplets.jar"

Is this something Adobe is supposed to fix? 

Having my users add an exception to their browsers is NOT an option for us.

thanks!

Views

2.7K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

CF10 Java 7.51 - "Missing required permissions manifest attribute"

New Here ,
Mar 21, 2014

Copy link to clipboard

Copied

Our clients are reporting that after they update to Java 7.51 they are now getting the following error:

"Missing required permissions manifest attribute in main jar: CFIDE/classes/cfapplets.jar"

Is this something Adobe is supposed to fix? 

Having my users add an exception to their browsers is NOT an option for us.

thanks!

Views

2.7K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Mar 21, 2014 0
Mar 24, 2014

Copy link to clipboard

Copied

I am also using JDK1.7.0_51 with my CF 10 instances and not getting this error.

Is there any specific CF page throwing this error?

Which CF 10 updates being used there?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Mar 24, 2014 0
New Here ,
Mar 24, 2014

Copy link to clipboard

Copied

This was an upgrade from CF8 to CF10, is there a way for me to tell if I have the wrong version of cfapplets.jar?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Mar 24, 2014 0
Mar 26, 2014

Copy link to clipboard

Copied

We are further researching for it and would update you in a few days..

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Mar 26, 2014 0
Explorer ,
Sep 24, 2014

Copy link to clipboard

Copied

Is there an answer to the problems with CFGRID and Java?  My CF 10 is asking for user/pass and it really doesn't seem to matter what is entered.  Then, users are just cancelling but then get locked out of the network when they do that multiple times.

This is a real issue and need help!

Pete

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 24, 2014 0
Most Valuable Participant ,
Sep 24, 2014

Copy link to clipboard

Copied

At this point, it is totally on Adobe to fix this.  I just did a quick check of the bug tracker, and I don't see this issue logged in there.  There is one other bug related to JDK 7.51+ which apparently has already been fixed (update release pending).  Maybe one of you can file a bug report on this specific issue?

-Carl V.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 24, 2014 0
Adobe Employee ,
Sep 24, 2014

Copy link to clipboard

Copied

Carl,

I am checking this once again and will let you all know about this. Here is the bug details.

Bug#3705406 - Java Script Security Exception CFGrid

Thanks,

Priyank

Thanks,
Priyank Shrivastava

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 24, 2014 1
Most Valuable Participant ,
Sep 25, 2014

Copy link to clipboard

Copied

Priyank,

That's why I couldn't find it in the Bug Tracker: it was reported under CF 9, not CF10 (I should have checked there too).  I'm going to point other forum threads related to the "manifest" issue to this thread so others can chime in or follow.

-Carl V.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 25, 2014 0
Adobe Employee ,
Sep 25, 2014

Copy link to clipboard

Copied

Thanks Carl,

I shared one jar file with above user and waiting for his response. If it won't work for him then I have to ask him to work with me on a repro case.

-Priyank

Thanks,
Priyank Shrivastava

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 25, 2014 0
Most Valuable Participant ,
Sep 25, 2014

Copy link to clipboard

Copied

Thank you Priyank!

-Carl V.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 25, 2014 0
New Here ,
Mar 28, 2014

Copy link to clipboard

Copied

The same issue is occuring with Coldfusion 8,0,1,195765

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Mar 28, 2014 0
New Here ,
Mar 28, 2014

Copy link to clipboard

Copied

My issue became apparent when people attempted to use CFGRID.

For a temporary workaround, I was able to go into the java settings from control panel and under the 'Security' tab edit the Exception Site List click the 'Edit Site List...' button.

On the next screen,  click 'Add' and enter the url including the http:// for the root of the site.  Click ok and ok out of the java properties panel.

Re-open the browser and the applet works again.  The thing that stinks is I have to do this for all users with Java version 7.51 and above.  Users on versions of Java prior to 7.51 have no problem.

Something about the way Colfusion runs with the applets has to change in order for this to be fixed with versions of java 7.51 and newer:

http://java.com/en/download/help/java_blocked.xml

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Mar 28, 2014 0
Adobe Employee ,
Oct 06, 2014

Copy link to clipboard

Copied

Hi,

I shared the fix with a user on this forum link Issue with Java 7.51 update for Licensed CF 10 applications and he confirmed that the fix worked.

Thanks,

Priyank

Thanks,
Priyank Shrivastava

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 06, 2014 0
Explorer ,
Oct 07, 2014

Copy link to clipboard

Copied

That link seems to go to another thread that points back here.  I didn't see a fix in either.  Can you simply post the fix here?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 07, 2014 0
New Here ,
Nov 12, 2014

Copy link to clipboard

Copied

@Priyank: It's been a number of weeks since any update on this. The forum link you provided on Oct 6th does not contain the fix you reference. Can you please post that fix to this thread? Thanks!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 12, 2014 0
New Here ,
Dec 07, 2014

Copy link to clipboard

Copied

Priyank Srivastava It's still been a number of weeks since any update on this. The forum link you provided on Oct 6th does not contain the fix you reference. Can you please post that fix to this thread? Thanks!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Dec 07, 2014 0