Highlighted

CF11 Enterprise: Double "HTTP 100" Continue causing file uploads to fail

Explorer ,
Aug 31, 2016

Copy link to clipboard

Copied

For some odd reason, when our users try to upload files to our site running on Cold Fusion 11 through a Big IP F5 set up as a reverse web proxy, the F5 logs are showing a double "HTTP 100 CONTINUE" response which causes the connection to drop.

We are running on a Windows 2008 R2 x64 OS with Cold Fusion 11 Enterprise update 9.

There are 2 clusters one with 5 instances in it which houses the website and a backend single instance that runs our scheduled jobs.

I've tried a whole slew of different things on the OS side and some stuff on the CF side including some connector parameters, none of which has worked at all.

Does anyone have any suggestions?

Ok,

I went into IIS and then into HTTP Response Headers and turned off HTTP keep-alive under "Set common headers" and it looks like i was able to upload a file.  I am having the field do the test now in hopes of them being successful.

Views

285

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

CF11 Enterprise: Double "HTTP 100" Continue causing file uploads to fail

Explorer ,
Aug 31, 2016

Copy link to clipboard

Copied

For some odd reason, when our users try to upload files to our site running on Cold Fusion 11 through a Big IP F5 set up as a reverse web proxy, the F5 logs are showing a double "HTTP 100 CONTINUE" response which causes the connection to drop.

We are running on a Windows 2008 R2 x64 OS with Cold Fusion 11 Enterprise update 9.

There are 2 clusters one with 5 instances in it which houses the website and a backend single instance that runs our scheduled jobs.

I've tried a whole slew of different things on the OS side and some stuff on the CF side including some connector parameters, none of which has worked at all.

Does anyone have any suggestions?

Ok,

I went into IIS and then into HTTP Response Headers and turned off HTTP keep-alive under "Set common headers" and it looks like i was able to upload a file.  I am having the field do the test now in hopes of them being successful.

Views

286

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Aug 31, 2016 0
New Here ,
Sep 04, 2016

Copy link to clipboard

Copied

Try setting the directory where you are trying to upload the files to 775(Apache/Linux) On IIS make sure the directory file permissions are correct.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 04, 2016 0
Explorer ,
Sep 06, 2016

Copy link to clipboard

Copied

The permissions are correct and there are no event viewer security logs showing access denial to the folder.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 06, 2016 0
Adobe Community Professional ,
Sep 04, 2016

Copy link to clipboard

Copied

jmaitino wrote:

the F5 logs are showing a double "HTTP 100 CONTINUE" response which causes the connection to drop.

What do the Coldfusion logs show? The issue might have to do with how you integrate Coldfusion and Big IP F5.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 04, 2016 0
Explorer ,
Sep 06, 2016

Copy link to clipboard

Copied

I just replicated the issue and checked the logs and there are no log entries within cold fusion what so ever.for the instance that the action was performed on.  The last log entry was from 10 minutes before the action took place.

Also the file I attempted to upload is not in the upload directory at all.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 06, 2016 0
Explorer ,
Sep 06, 2016

Copy link to clipboard

Copied

Ok,

I went into IIS and then into HTTP Response Headers and turned off HTTP keep-alive under "Set common headers" and it looks like i was able to upload a file.  I am having the field do the test now in hopes of them being successful.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 06, 2016 0