Highlighted

CF11 error when viewing server updates

New Here ,
Sep 14, 2016

Copy link to clipboard

Copied

I am running two servers, one on CF11 Hotfix 10 and one on CF11 Hotfix 7.  After being up for some period of time I get this error when going to Server Update / Updates.

The selected type [CFContainerID] was not set via the ESAPI validation configuration

The error occurred in index.cfm: line 170

Called from index.cfm: line 164

Called from index.cfm: line 52

Called from index.cfm: line 51

Called from index.cfm: line 1

-1 : Unable to display error's location in a CFML template.

Restarting the application server fixes the problem, but it returns after the server has been running for a while.  Any ideas what causes this and if there is a fix?

Thanks,

  Michael

Views

589

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

CF11 error when viewing server updates

New Here ,
Sep 14, 2016

Copy link to clipboard

Copied

I am running two servers, one on CF11 Hotfix 10 and one on CF11 Hotfix 7.  After being up for some period of time I get this error when going to Server Update / Updates.

The selected type [CFContainerID] was not set via the ESAPI validation configuration

The error occurred in index.cfm: line 170

Called from index.cfm: line 164

Called from index.cfm: line 52

Called from index.cfm: line 51

Called from index.cfm: line 1

-1 : Unable to display error's location in a CFML template.

Restarting the application server fixes the problem, but it returns after the server has been running for a while.  Any ideas what causes this and if there is a fix?

Thanks,

  Michael

Views

590

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Sep 14, 2016 0
Adobe Employee ,
Sep 14, 2016

Copy link to clipboard

Copied

Hi Michael,

Can you please clear the classes.

{cf_home}\cfusion\wwwroot\WEB-INF\cfclasses\

Restart ColdFusion service and check if that helps.

Thanks,

Priyank

Thanks,
Priyank Shrivastava

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 14, 2016 0
New Here ,
Sep 15, 2016

Copy link to clipboard

Copied

On our development server, which has caching disabled,  there was only 1 class file in the folder. I removed it and restarted the service but still got the error.  It was only when I cleared the component cache using the Admin UI that the error went away and I was able to view the Updates page.   I will try again every few days to see if the error returns.

Michael

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 15, 2016 0
New Here ,
Sep 15, 2016

Copy link to clipboard

Copied

Well, it's been less than a day and the error has returned.   The cfclasses folder is empty and clearing all caches in the Admin UI does not eliminate the error.  The only way I'll be able to fix it is to restart the ColdFusion service. 

  Michael

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 15, 2016 0
Adobe Employee ,
Sep 15, 2016

Copy link to clipboard

Copied

Are you facing this problem after applying the update or it is an issue since you install the server?

Thanks,

Priyank

Thanks,
Priyank Shrivastava

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 15, 2016 0
New Here ,
Sep 15, 2016

Copy link to clipboard

Copied

These servers have been running since Nov 2015 and this has been a problem for about the past 3-4 months. Until now I have just been restarting the service whenever I need to apply an update.  That got annoying so I decided to post here to see if there is a fix.

Michael

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 15, 2016 0
Adobe Employee ,
Sep 15, 2016

Copy link to clipboard

Copied

It appears that last update which you were done was not applied properly. Is it a Dev server or Production?

Thanks,

Priyank

Thanks,
Priyank Shrivastava

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 15, 2016 0
New Here ,
Sep 16, 2016

Copy link to clipboard

Copied

This has been happening for a while, after multiple updates.  I hear that a new update is available so I go to the Updates panel in the Admin UI and get the error.  I restart the ColdFusion service and then I am able to apply the update.  The error continued to occur after HF7, HF10, and HF11 were all applied.  It has nothing to do with the most recent update applied.

I have two servers, Development and Production, so I can test on the Dev server.

Michael

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 16, 2016 0
Adobe Community Professional ,
Sep 17, 2016

Copy link to clipboard

Copied

It seems to be a bug arising from a Coldfusion-update file of type .profile (if your Coldfusion installation is on Unix) or of type .properties (if your Coldfusion installation is on Windows). See, for more details,

Updates for ColdFusion 2016, ColdFusion Builder 2016, ColdFusion 11 and ColdFusion 10 released » Ado...

(in particular, reponses to the comment by a certain Michael Mongeau; I presume this is you.)

Command line installation of ColdFusion 11 hotfix 9 fails

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 17, 2016 0
New Here ,
Sep 20, 2016

Copy link to clipboard

Copied

I did post that comment the first time I encountered the error but there is nothing in any of the replies that suggests a fix.

The problem still exists with no resolution so far.  Here is the entire error from the log file.  Surely someone on the ColdFusion team should be able figure out what is going on here and provide a fix.

"Error","ajp-bio-8014-exec-6","09/20/16","09:13:04","cfadmin","The selected type [CFContainerID] was not set via the ESAPI validation configuration The specific sequence of files included or processed is: E:\Apps\ColdFusion11\cfusion\wwwroot\CFIDE\administrator\updates\index.cfm, line: 170 "

java.lang.IllegalArgumentException: The selected type [CFContainerID] was not set via the ESAPI validation configuration

at org.owasp.esapi.reference.DefaultValidator.getValidInput(DefaultValidator.java:209)

at org.owasp.esapi.reference.DefaultValidator.getValidInput(DefaultValidator.java:251)

at org.owasp.esapi.reference.DefaultValidator.getValidInput(DefaultValidator.java:232)

at coldfusion.security.ESAPIUtils.getValidateInput(ESAPIUtils.java:443)

at coldfusion.tagext.html.ajax.HtmlAssembler.setContainerId(HtmlAssembler.java:591)

at coldfusion.tagext.html.ajax.LayoutAreaTag.doStartTag(LayoutAreaTag.java:580)

at cfindex2ecfm567798672._factor0(/CFIDE/administrator/updates/index.cfm:170)

at cfindex2ecfm567798672._factor6(/CFIDE/administrator/updates/index.cfm:164)

at cfindex2ecfm567798672._factor8(/CFIDE/administrator/updates/index.cfm:52)

at cfindex2ecfm567798672._factor9(/CFIDE/administrator/updates/index.cfm:51)

at cfindex2ecfm567798672.runPage(/CFIDE/administrator/updates/index.cfm:1)

at coldfusion.runtime.CfJspPage.invoke(CfJspPage.java:246)

at coldfusion.tagext.lang.IncludeTag.handlePageInvoke(IncludeTag.java:736)

at coldfusion.tagext.lang.IncludeTag.doStartTag(IncludeTag.java:572)

at coldfusion.filter.CfincludeFilter.invoke(CfincludeFilter.java:65)

at coldfusion.filter.IpFilter.invoke(IpFilter.java:45)

at coldfusion.filter.ApplicationFilter.invoke(ApplicationFilter.java:487)

at coldfusion.filter.RequestMonitorFilter.invoke(RequestMonitorFilter.java:42)

at coldfusion.filter.MonitoringFilter.invoke(MonitoringFilter.java:40)

at coldfusion.filter.PathFilter.invoke(PathFilter.java:142)

at coldfusion.filter.ExceptionFilter.invoke(ExceptionFilter.java:94)

at coldfusion.filter.BrowserDebugFilter.invoke(BrowserDebugFilter.java:78)

at coldfusion.filter.ClientScopePersistenceFilter.invoke(ClientScopePersistenceFilter.java:28)

at coldfusion.filter.BrowserFilter.invoke(BrowserFilter.java:38)

at coldfusion.filter.NoCacheFilter.invoke(NoCacheFilter.java:58)

at coldfusion.filter.GlobalsFilter.invoke(GlobalsFilter.java:38)

at coldfusion.filter.DatasourceFilter.invoke(DatasourceFilter.java:22)

at coldfusion.filter.CachingFilter.invoke(CachingFilter.java:62)

Michael

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 20, 2016 0
Adobe Community Professional ,
Sep 20, 2016

Copy link to clipboard

Copied

MichaelXMongeau wrote:

I did post that comment the first time I encountered the error but there is nothing in any of the replies that suggests a fix.

There was a suggestion for a fix in the replies, which I have repeated. It involves modifying Coldfusion update files of type .profile (if your Coldfusion installation is on Unix) or of type .properties (if your Coldfusion installation is on Windows).

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 20, 2016 0
New Here ,
Sep 20, 2016

Copy link to clipboard

Copied

It's a completely different problem.  User Joe Rybacek replied in that thread with a different error when trying to install the update via the command line.  His own answer was that he had a corrupt .profile file that he fixed manually.

I am not having problems installing updates. I get an error just when trying to view the Updates page in the UI.  Restarting the server makes the error go away temporarily but it returns.

Michael

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 20, 2016 0
BKBK LATEST
Adobe Community Professional ,
Sep 20, 2016

Copy link to clipboard

Copied

My suggestion is only to help rule out the options and find workarounds. The connection to Coldfusion updates is clear.

In fact, in your experience, from one of the links referenced:

"When I log into my CF11 Administrator and go to Server Update / Updates I get an exception."

The exception message was:

"The selected type [CFContainerID] was not set via the ESAPI validation configuration".

This involves the Coldfusion system file, \CFIDE\administrator\updates\index.cfm. So, it is likely a bug. You should report it.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 20, 2016 0