Highlighted

CF11 install problem on WIndows server 2012 R2

Community Beginner ,
Mar 24, 2015

Copy link to clipboard

Copied

We have a new install windows server 2012 R2 with a new install CF11 standard installed on C drive. Everything is 64bit. The CF administrator site and login works fine.  cfm files will not serve up in the default directory, but IIS shows htm files fine.  CF administrator runs fine.

Web Server Config tool will only show "None" in the IIS Web Site box.  The usual CGI, APS, etc have been installed on IIS.  In fact IIS and CF11 have been reinstalled.  wsconfig.exe manual run shows no errors.

The problem is that any call to a cfm template results in an error (html pages serve fine):

HTTP Error 500.0 - Internal Server Error

The page cannot be displayed because an internal server error has occurred.

Detailed Error Information:

Module       IsapiModule

Notification       ExecuteRequestHandler

Handler       cfmHandler

Error Code       0x8007007f

Requested URL       http://localhost:80/default.cfm

Physical Path       C:\inetpub\wwwroot\default.cfm

Can anybody give any suggestions for troubleshooting?  No logs seem to show any information that helps.

Correct answer by rg25654200 | Community Beginner

Fixed the problem......... it is not a CF problem alone but and mostly an IIS problem ....

1) remove IIS completely...... including the inetpub directory..... remove .NET Extensibility from server manager under Application Development if inetpub in use error is present... inetpub has to be deleted.

2) reboot

3) reinstall IIS and enable all the usual stuff, ie, CGI, ISAPI, .NET, ASP , WebSocket Protocol, etc under Application Development

4) restart IIS and CF

5) Set Web Server Config to  "All"

60 restart IIS and CF

The trick to completely reinstall IIS and that is only done if you can delete the inetpub folder under root drive.

Views

1.4K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

CF11 install problem on WIndows server 2012 R2

Community Beginner ,
Mar 24, 2015

Copy link to clipboard

Copied

We have a new install windows server 2012 R2 with a new install CF11 standard installed on C drive. Everything is 64bit. The CF administrator site and login works fine.  cfm files will not serve up in the default directory, but IIS shows htm files fine.  CF administrator runs fine.

Web Server Config tool will only show "None" in the IIS Web Site box.  The usual CGI, APS, etc have been installed on IIS.  In fact IIS and CF11 have been reinstalled.  wsconfig.exe manual run shows no errors.

The problem is that any call to a cfm template results in an error (html pages serve fine):

HTTP Error 500.0 - Internal Server Error

The page cannot be displayed because an internal server error has occurred.

Detailed Error Information:

Module       IsapiModule

Notification       ExecuteRequestHandler

Handler       cfmHandler

Error Code       0x8007007f

Requested URL       http://localhost:80/default.cfm

Physical Path       C:\inetpub\wwwroot\default.cfm

Can anybody give any suggestions for troubleshooting?  No logs seem to show any information that helps.

Correct answer by rg25654200 | Community Beginner

Fixed the problem......... it is not a CF problem alone but and mostly an IIS problem ....

1) remove IIS completely...... including the inetpub directory..... remove .NET Extensibility from server manager under Application Development if inetpub in use error is present... inetpub has to be deleted.

2) reboot

3) reinstall IIS and enable all the usual stuff, ie, CGI, ISAPI, .NET, ASP , WebSocket Protocol, etc under Application Development

4) restart IIS and CF

5) Set Web Server Config to  "All"

60 restart IIS and CF

The trick to completely reinstall IIS and that is only done if you can delete the inetpub folder under root drive.

Views

1.4K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Mar 24, 2015 0
Guide ,
Mar 24, 2015

Copy link to clipboard

Copied

Perhaps run WSCONFIG as administrator?


Is there a ColdFusion11\config\wsconfig\1 folder present with a DLL log and properties files?

HTH, Carl.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Mar 24, 2015 0
Community Beginner ,
Mar 25, 2015

Copy link to clipboard

Copied

Thank you for your response.

I had tried running wsconfig as admin as suggested elsewhere and it makes no difference.  The WSCONFIG GUI "IIS Web Site" box only shows "None" and no other selection.  There is no "1" subdirectory of wsconfig.  wsconfig folder contains two files...... cfwin32.dll  and wsconfig.log    .  If I temporarily remove those two files, running WSCONFIG does put them back in.

Also:

Running

PS C:\coldfusion11\cfusion\bin\connectors> ./IIS_ConnectorList.bat

This lists all configured connectors.  For IIS, it lists configured and unconfigured connectors.

Press Control+C to abort.

Press any key to continue . . .

There are no configured web servers

Running

PS C:\coldfusion11\cfusion\bin\connectors> ./IIS_connector.bat

WARNING!  This will install the ColdFusion IIS Connector at the global level.

Press Control+C to abort.

Press any key to continue . . .

1

there is no wsconfig\1 folder created if that is what the return of number "1" means

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Mar 25, 2015 0
Community Beginner ,
Mar 25, 2015

Copy link to clipboard

Copied

Fixed the problem......... it is not a CF problem alone but and mostly an IIS problem ....

1) remove IIS completely...... including the inetpub directory..... remove .NET Extensibility from server manager under Application Development if inetpub in use error is present... inetpub has to be deleted.

2) reboot

3) reinstall IIS and enable all the usual stuff, ie, CGI, ISAPI, .NET, ASP , WebSocket Protocol, etc under Application Development

4) restart IIS and CF

5) Set Web Server Config to  "All"

60 restart IIS and CF

The trick to completely reinstall IIS and that is only done if you can delete the inetpub folder under root drive.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Mar 25, 2015 0