Highlighted

CF11 instance only works when I start it via console

Explorer ,
Oct 08, 2014

Copy link to clipboard

Copied

In WIndows Services, my cfintra instance is running. In CF Instance Manager, my cfintra instance is stopped, and I can't started via this page. In CF instance logs I get this: 2014-10-08 10_43_13-webin2 - Remote Desktop Connection.png

And visiting my website simply returns a 500 error. So I started the CF instance via CMD with: coldfusion.exe -start -console and now my website is running. However, the status of the instance in Windows Services is 'stopped' and if I close the CMD window it shuts down the CF instance. I have 4 CF instance that I'm managing via the instance manager and CFINTRA is the only one I can't start and stop successfully from the manager. So, how do I debug this issue?

2014-10-08 10_39_57-webin2 - Remote Desktop Connection.png

We have tested creating multiple instances at our end. Once we apply the hotfix to the main instances, it gets applied to rest of all. It seems like that the issue is with one of your instance -CFUSIONINTRA. Can you remove it and recreate it.

Regards,

Anit Kumar

Views

422

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

CF11 instance only works when I start it via console

Explorer ,
Oct 08, 2014

Copy link to clipboard

Copied

In WIndows Services, my cfintra instance is running. In CF Instance Manager, my cfintra instance is stopped, and I can't started via this page. In CF instance logs I get this: 2014-10-08 10_43_13-webin2 - Remote Desktop Connection.png

And visiting my website simply returns a 500 error. So I started the CF instance via CMD with: coldfusion.exe -start -console and now my website is running. However, the status of the instance in Windows Services is 'stopped' and if I close the CMD window it shuts down the CF instance. I have 4 CF instance that I'm managing via the instance manager and CFINTRA is the only one I can't start and stop successfully from the manager. So, how do I debug this issue?

2014-10-08 10_39_57-webin2 - Remote Desktop Connection.png

We have tested creating multiple instances at our end. Once we apply the hotfix to the main instances, it gets applied to rest of all. It seems like that the issue is with one of your instance -CFUSIONINTRA. Can you remove it and recreate it.

Regards,

Anit Kumar

Views

423

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Oct 08, 2014 0
Adobe Employee ,
Oct 08, 2014

Copy link to clipboard

Copied

Please apply ColdFusion 11 Update 1. The issue is fixed in that update.

Regards,

Anit Kumar

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 08, 2014 0
Explorer ,
Oct 08, 2014

Copy link to clipboard

Copied

Ha, I actually applied the update to all instances, but the hf-11-0001.properties and hotfix_001.jar files are not located in the update folders of my instance, only in the main cfusion instance folder. Plus the issue went unresolved. After I restarted the operating system this is what I got:

2014-10-08 14_17_11-webin2 - Remote Desktop Connection.png

2014-10-08 14_17_27-webin2 - Remote Desktop Connection.png

As you can see in the instance manager, CFUSIONINTRA has "started", but in windows services it says its "running". Website:

2014-10-08 14_20_45-Program Manager.png

My installed updates:

2014-10-08 14_23_55-webin2 - Remote Desktop Connection.png

2014-10-08 14_29_00-webin2 - Remote Desktop Connection.png

The update wasn't applied to all instance eventhough I checked the option for all.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 08, 2014 0
Explorer ,
Oct 08, 2014

Copy link to clipboard

Copied

Here is my CFUSIONINTRA instance folder compared to the main cf instance folder:

2014-10-08 14_33_15-webin2 - Remote Desktop Connection.png

2014-10-08 14_32_51-webin2 - Remote Desktop Connection.png

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 08, 2014 0
Explorer ,
Oct 08, 2014

Copy link to clipboard

Copied

I did find the chf1000001.jar file in ../lib/updates folder for each instance. So I'm not sure what the hf-updates folder is for, except that it does contain the backup.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 08, 2014 0
Explorer ,
Oct 08, 2014

Copy link to clipboard

Copied

oh, right. the HF-UPDATES folder contains the backup, uninstaller and install logs. So I have to assume that the update was applied successfully to all my instances except that CFUSIONINTRA is not starting up correctly because the Monitoring Service not being able to bind to the port or something. Again, I can manually start the instance via CMD. Any other thoughts?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 08, 2014 0
Explorer ,
Oct 08, 2014

Copy link to clipboard

Copied

C'mon now. I restarted my OS for windows updates and I can't even start my instance via CMD:

---

Either the server is already running or some other application is using the HTTP port 8501.

---

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 08, 2014 0
Adobe Employee ,
Oct 09, 2014

Copy link to clipboard

Copied

We have tested creating multiple instances at our end. Once we apply the hotfix to the main instances, it gets applied to rest of all. It seems like that the issue is with one of your instance -CFUSIONINTRA. Can you remove it and recreate it.

Regards,

Anit Kumar

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 09, 2014 0
Explorer ,
Oct 09, 2014

Copy link to clipboard

Copied

Thank you that did it.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 09, 2014 0