CF11 on Windows 2012 Multiple Domains Issue - will load directory, but not direct CFMs

Explorer ,
Feb 18, 2016 Feb 18, 2016

Copy link to clipboard

Copied

I have a strange issue where I have two web sites:

D:\inetpub\wwwroot\

and

D:\inetpub\webapps\

which are bound to different domains.

Everything on the default (wwwroot) works fine with ColdFusion.

However, on the "webapps" site it will ONLY load CFM files if I call them implicitly as a directory.

For example:

http://my.site.com/

loads the index.cfm just fine, however:

http://my.site.com/index.cfm

always returns a 404 error.  Is there some sort of mapping or permission I need to set to make this work?

I checked wsconfig and it is set for All IIS websites.  I also made sure the IIS_IUSRS permission is set on it.

Anyone seen this?  I appreciate any advice.

Thanks!

Dan

Views

329

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct Answer

Advocate , Feb 22, 2016 Feb 22, 2016
Have you actually tried re-running wsconfig? Even though it is set to all sites, if you add a new one it doesn't get included in this. You would have to rerun the the connector again.

Likes

Translate

Translate
Guide ,
Feb 19, 2016 Feb 19, 2016

Copy link to clipboard

Copied

Have you made sure that index.cfm is set in the IIS default documents for the second web site?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Feb 21, 2016 Feb 21, 2016

Copy link to clipboard

Copied

Yes, it's the default.  Handlers appear to be set correctly too.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Guide ,
Feb 22, 2016 Feb 22, 2016

Copy link to clipboard

Copied

Do you have a "jakarta" virtual directory on the second site? If not (and sometimes using the "all sites" option in WSConfig doesn't do it properly), then create a virtual directory pointing to C:\Coldfusion11\config\wsconfig\{instance id} where {instance id} is the numbered subfolder created by wsconfig for your site(s).

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Advocate ,
Feb 22, 2016 Feb 22, 2016

Copy link to clipboard

Copied

Have you actually tried re-running wsconfig? Even though it is set to all sites, if you add a new one it doesn't get included in this. You would have to rerun the the connector again.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Feb 24, 2016 Feb 24, 2016

Copy link to clipboard

Copied

Thank you!  I didn't realize that I needed to run wsconfig again, and add this new server, even though it says "All" IIS Websites.  I added my other site and "poof!" working as expected.  Thanks all!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Guide ,
Feb 24, 2016 Feb 24, 2016

Copy link to clipboard

Copied

Just to clarify, when you select "All" sites, it sets some things globally for all (present and future) IIS sites, but some things only for existing sites.  The handlers (cfc/cfm/etc. file handlers and similar settings) are added to the global IIS config.  The "jakarta" subdirectory is only set on existing sites.  So if you add additional sites later, you need to run the WSCONFIG process twice - once, to remove "All" sites; then again to reinstall to "All" sites so the new sites get setup correctly.

Alternatively, you can use WSCONFIG to connect to each site individually - then if you add new sites, you only have to connect the new ones as needed.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Feb 28, 2016 Feb 28, 2016

Copy link to clipboard

Copied

LATEST

Thanks Carl! I really appreciate you following up with more detailed information on how all this works.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines