Highlighted

CF2016 install fail

Explorer ,
Jul 18, 2016

Copy link to clipboard

Copied

I have previously succeeded in installing CF2016 on a Win10 Apache24 setup but had to refresh Win10 after a disk failure & replacement.  Now when I go through the CF install process I get a message that there were errors, a number of which show up in the coldfusion-error.log.  My Apache server still runs .html files but the browser hangs on .cfm and produces a message "The connection was reset". 

The coldfusion-error.log shows a number of entries as follows:

Jul 17, 2016 9:08:46 PM org.apache.coyote.ajp.AjpMessage processHeader

SEVERE: Invalid message received with signature 18245

Followed later by multiple entries:

Jul 17, 2016 10:24:06 PM org.apache.catalina.loader.WebappClassLoaderBase checkThreadLocalMapForLeaks

SEVERE: The web application [ROOT] created a ThreadLocal with key of type [coldfusion.runtime.Cast$1] (value [coldfusion.runtime.Cast$1@27902ba2]) and a value of type [java.lang.Boolean] (value [true]) but failed to remove it when the web application was stopped. Threads are going to be renewed over time to try and avoid a probable memory leak.

The Apache log shows the following error messages when the .cfm page is accessed which implies a memory issue:

[Mon Jul 18 10:08:43.623178 2016] [mpm_winnt:notice] [pid 9972:tid 620] AH00428: Parent: child process 13016 exited with status 3221225477 -- Restarting.

The Apache config files look OK (i.e. similar to what was working before).  Not sure where else to look for clues??

I checked the configuration several times and could not find any then wrong there.   I finally figured out that the problem was that httpd.exe was not running as 'administrator'.   When I stopped Apache and restarted it as admin then CF ran.   That was an ugly problem and consumed way too much effort to resolve.  Better error messages could have saved me a lot of time.

Views

504

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

CF2016 install fail

Explorer ,
Jul 18, 2016

Copy link to clipboard

Copied

I have previously succeeded in installing CF2016 on a Win10 Apache24 setup but had to refresh Win10 after a disk failure & replacement.  Now when I go through the CF install process I get a message that there were errors, a number of which show up in the coldfusion-error.log.  My Apache server still runs .html files but the browser hangs on .cfm and produces a message "The connection was reset". 

The coldfusion-error.log shows a number of entries as follows:

Jul 17, 2016 9:08:46 PM org.apache.coyote.ajp.AjpMessage processHeader

SEVERE: Invalid message received with signature 18245

Followed later by multiple entries:

Jul 17, 2016 10:24:06 PM org.apache.catalina.loader.WebappClassLoaderBase checkThreadLocalMapForLeaks

SEVERE: The web application [ROOT] created a ThreadLocal with key of type [coldfusion.runtime.Cast$1] (value [coldfusion.runtime.Cast$1@27902ba2]) and a value of type [java.lang.Boolean] (value [true]) but failed to remove it when the web application was stopped. Threads are going to be renewed over time to try and avoid a probable memory leak.

The Apache log shows the following error messages when the .cfm page is accessed which implies a memory issue:

[Mon Jul 18 10:08:43.623178 2016] [mpm_winnt:notice] [pid 9972:tid 620] AH00428: Parent: child process 13016 exited with status 3221225477 -- Restarting.

The Apache config files look OK (i.e. similar to what was working before).  Not sure where else to look for clues??

I checked the configuration several times and could not find any then wrong there.   I finally figured out that the problem was that httpd.exe was not running as 'administrator'.   When I stopped Apache and restarted it as admin then CF ran.   That was an ugly problem and consumed way too much effort to resolve.  Better error messages could have saved me a lot of time.

Views

505

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Jul 18, 2016 0
Adobe Employee ,
Jul 18, 2016

Copy link to clipboard

Copied

Hi Dale,

Could you please recreate the connector using the ColdFusion2016\cfusion\runtime\bin\wsconfig.exe utility as administrator.

Also, are you able to access the CF Admin page via apache?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jul 18, 2016 0
Explorer ,
Jul 18, 2016

Copy link to clipboard

Copied

Thanks for the ideas.  I had run the connector before but I did run the connector again and it shows that the web server is already configured for ColdFusion.

I  cannot get to the CF admin page via Apache - not sure how I would do that in CF2016.  Is it not set up specifically to use the internal CF server code?   I can get to the admin page that way - the top line shows "Server: cfusion"

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jul 18, 2016 0
Adobe Employee ,
Aug 04, 2016

Copy link to clipboard

Copied

Hi Dale,

If the connector shows that the web server is already configured for ColdFusion, then you would have to remove the files manually or reinstall apache. You could also look for manual connector creation here

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Aug 04, 2016 0
Explorer ,
Aug 16, 2016

Copy link to clipboard

Copied

I checked the configuration several times and could not find any then wrong there.   I finally figured out that the problem was that httpd.exe was not running as 'administrator'.   When I stopped Apache and restarted it as admin then CF ran.   That was an ugly problem and consumed way too much effort to resolve.  Better error messages could have saved me a lot of time.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Aug 16, 2016 0