Highlighted

CF2016 new install - Service unavailable

Community Beginner ,
Mar 07, 2017

Copy link to clipboard

Copied

Just installed 2016 on a test server ... it had 10 before.

After install, brought up Admin panel ... it did its thing.

But all I get is an error below.

Checked for CFIDE and jakarta ... usual mapping.  They were gone.

Added their directories in Windows IIS.

Made sure CF10 shut down, 2016 running. yes.

Ok, what am I missing?

The service is unavailable.

Service Temporary Unavailable!

The server is temporarily unable to service your request due to maintenance downtime or capacity problems. Please try again later.





  Jakarta/ISAPI/isapi_redirector/1.2.32 ()


Copyright © 1999-2011 Apache Software Foundation
All Rights Reserved

TOPICS
Server administration

Views

1.9K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

CF2016 new install - Service unavailable

Community Beginner ,
Mar 07, 2017

Copy link to clipboard

Copied

Just installed 2016 on a test server ... it had 10 before.

After install, brought up Admin panel ... it did its thing.

But all I get is an error below.

Checked for CFIDE and jakarta ... usual mapping.  They were gone.

Added their directories in Windows IIS.

Made sure CF10 shut down, 2016 running. yes.

Ok, what am I missing?

The service is unavailable.

Service Temporary Unavailable!

The server is temporarily unable to service your request due to maintenance downtime or capacity problems. Please try again later.





  Jakarta/ISAPI/isapi_redirector/1.2.32 ()


Copyright © 1999-2011 Apache Software Foundation
All Rights Reserved

TOPICS
Server administration

Views

1.9K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Mar 07, 2017 0
Guide ,
Mar 07, 2017

Copy link to clipboard

Copied

Hi,

Perhaps check IIS web site ISAPI filter setting for where tomcat is being directed.

EG

Capture.JPG

HTH, Carl.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Mar 07, 2017 0
Community Beginner ,
Mar 07, 2017

Copy link to clipboard

Copied

Ha ... hah!

That fixed that error ... now I just get a 500 Error.

Course it could be related ... I pointed Tomcat to

/coldfusion2016/config/wsconfig/cfwin32.dll

So close?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Mar 07, 2017 0
Guide ,
Mar 07, 2017

Copy link to clipboard

Copied

So close yet far.

Perhaps with ISAPI tomcat setting pointing to correct DLL restart IIS since it was pointing to wrong DLL.

Details in ColdFusion2016\config\wsconfig\1\isapi_redirect.log might be interesting to diagnose further.

Regards, Carl.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Mar 07, 2017 0
Community Beginner ,
Mar 07, 2017

Copy link to clipboard

Copied

This does not exist

ColdFusion2016\config\wsconfig\1\isapi_redirect.log

specifically under CF10/cf11 where there is a /1/  in the path, there isn't in 2016.

And the only log files that DO exist under "16"/wsconfig/ are

wsconfig.log

Which contains

# Created by ColdFusion on 03/07 11:31:18

03/07 11:31:18 info Tomcat Connector

03/07 11:31:20 debug command line: -ws IIS -site 0 -enableBuffering -connectionPoolSize 500 -connectionPoolTimeout 60 -reuseConnectionCount 250 -v

03/07 11:31:22 error This web server is already configured by some other version of ColdFusion.

com.adobe.coldfusion.connector.connectorinstaller.ConnectorInstallerException: This web server is already configured by some other version of ColdFusion.

  at com.adobe.coldfusion.connector.connectorinstaller.IISInstaller.installConnector(IISInstaller.java:219)

  at com.adobe.coldfusion.connector.connectorinstaller.ConnectorInstaller.installConnector(ConnectorInstaller.java:432)

  at com.adobe.coldfusion.connector.connectorinstaller.ConnectorInstaller.doIt(ConnectorInstaller.java:372)

  at com.adobe.coldfusion.connector.connectorinstaller.ConnectorInstaller.main(ConnectorInstaller.java:887)

03/07 13:41:43 info Tomcat Connector

03/07 13:42:14 info Tomcat Connector

But that was hours ago ... the timestamp is CT.

===================

Then I created a simple.html file which has only a table and td and hello world.

It just stayed at 500 Internal Error.

Renamed application.cfm to application_iis.cfm

Still the same.

Every time I upgrade CF (like every 2 years) I get this; why cannot Adobe do a BETTER job at making the installer a little smarter?

It saw CF10 in there ... so work with it and it migrated all those settings.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Mar 07, 2017 0
Guide ,
Mar 07, 2017

Copy link to clipboard

Copied

Perhaps run ColdFusion2016\cfusion\runtime\bin\wsconfig as administrator.

Should look like tho "All" may differ to an IIS site EG:

Capture.JPG

I am not an Adobe CF staffer so not my place to comment on BETTER.

Regards, Carl.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Mar 07, 2017 0
Community Beginner ,
Mar 07, 2017

Copy link to clipboard

Copied

Thanks.   That was the first thing I did.

Besides, they could've made 2016 WSC look different! 

Tried that AGAIn and it did add a cf_script to something but still nada,

May have to call "support"

Thanks for your efforts.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Mar 07, 2017 0