Highlighted

CF2016 Update 10 completes and shows wrong version

Explorer ,
Mar 05, 2019

Copy link to clipboard

Copied

Hey Everyone!

This is what I hope will be helpful information to anyone pulling out their hair on why the hell the Patch 10 for CF2016 is showing Patch 8 or 9 as the major version on the CFIDE Info page.

After patching our Test environment with Update 10 we noticed that there were some errors reported but that the patch install was complete.

Our test environment can throw errors for non existent instances in our instances.xml - anyways, we didn't think much of it until we noticed the version was off in the CFIDE information page (2010.0.08.314028 instead of 2010.0.10.314028).  What was alarming - was that if we didn't notice that version and relied only on the Update Level (chf20160010.jar) - we would have thought our patch was successful.

After reviewing the patch log we noticed a fatal error that was not brought up during the patching - (why on earth wouldn't a patch roll back automagically if there was a fatal error??)  To make matters worse, we were not allowed to run the uninstaller.jar (because it didn't think we had that version installed)!!!

Thank goodness for snapshots!!

We did some digging based on the Fatal error and sure enough that lib folder existed on our test cluster under cfusion/jetty , so we deleted it to see how that would fly.

Re-ran Update 10 - now successful with no fatal errors.

The correct Version now shows in CFIDE Information

Now our production environment doesn't appear to have the cfusion/jetty/lib directory at all after Update 8 - so this may just be an edge case, but it was annoying as hell and I would like to encourage Adobe to either change how the Updates handle Fatal errors OR fix whatever the holdup is with that jetty/lib directory for Update 10 and later - I could manually move that damn directory just fine as root, fatal error my digital rear end...

I believe the whole moving of the jetty/lib directory is a vestige from the pre Jetty update in Update 8 and 9.  But what do I know.

Have an awesome day!

Views

369

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

CF2016 Update 10 completes and shows wrong version

Explorer ,
Mar 05, 2019

Copy link to clipboard

Copied

Hey Everyone!

This is what I hope will be helpful information to anyone pulling out their hair on why the hell the Patch 10 for CF2016 is showing Patch 8 or 9 as the major version on the CFIDE Info page.

After patching our Test environment with Update 10 we noticed that there were some errors reported but that the patch install was complete.

Our test environment can throw errors for non existent instances in our instances.xml - anyways, we didn't think much of it until we noticed the version was off in the CFIDE information page (2010.0.08.314028 instead of 2010.0.10.314028).  What was alarming - was that if we didn't notice that version and relied only on the Update Level (chf20160010.jar) - we would have thought our patch was successful.

After reviewing the patch log we noticed a fatal error that was not brought up during the patching - (why on earth wouldn't a patch roll back automagically if there was a fatal error??)  To make matters worse, we were not allowed to run the uninstaller.jar (because it didn't think we had that version installed)!!!

Thank goodness for snapshots!!

We did some digging based on the Fatal error and sure enough that lib folder existed on our test cluster under cfusion/jetty , so we deleted it to see how that would fly.

Re-ran Update 10 - now successful with no fatal errors.

The correct Version now shows in CFIDE Information

Now our production environment doesn't appear to have the cfusion/jetty/lib directory at all after Update 8 - so this may just be an edge case, but it was annoying as hell and I would like to encourage Adobe to either change how the Updates handle Fatal errors OR fix whatever the holdup is with that jetty/lib directory for Update 10 and later - I could manually move that damn directory just fine as root, fatal error my digital rear end...

I believe the whole moving of the jetty/lib directory is a vestige from the pre Jetty update in Update 8 and 9.  But what do I know.

Have an awesome day!

Views

370

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Mar 05, 2019 2
New Here ,
Apr 05, 2019

Copy link to clipboard

Copied

wow you saved my day!   i thought i was seeing things...   i now have the correct update level showing in the admin console.   I went looking in that cfusion/jetty/lib directory to see what it looks like now and find its empty except for an empty 'ext' directory.    Do you know if that is the expectation?   I do see a 'jetty/lib' directory with files but it lives in the 'cfusion/hf-updates/hf-2016-00010-314028' directory...  

thanks

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Apr 05, 2019 0
BKBK LATEST
Adobe Community Professional ,
Apr 06, 2019

Copy link to clipboard

Copied

jbrock777​, thanks for sharing your installation experiences!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Apr 06, 2019 0