Highlighted

CF2016 upgrade issue

New Here ,
May 02, 2018

Copy link to clipboard

Copied

We are upgrading a server from CF11 to CF2016.  The server runs fine all day up until we do some night database processing.  When this occurs we start getting errors like this:

Table foreign_address_formats defined for cfc hrPortal.foreign_address_formats does not exist

I have confirmed these tables do not get dropped.  Once the DB nightly processing is completed the cf server recovers and the errors go away.

In our old CF11 instance we never encountered any issue like this at all.  This is an orm enabled datasource.  And the configuration between cf11 and cf2016 is exactly the same.

Any ideas on this would be appreciated.

- Alex

Views

172

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

CF2016 upgrade issue

New Here ,
May 02, 2018

Copy link to clipboard

Copied

We are upgrading a server from CF11 to CF2016.  The server runs fine all day up until we do some night database processing.  When this occurs we start getting errors like this:

Table foreign_address_formats defined for cfc hrPortal.foreign_address_formats does not exist

I have confirmed these tables do not get dropped.  Once the DB nightly processing is completed the cf server recovers and the errors go away.

In our old CF11 instance we never encountered any issue like this at all.  This is an orm enabled datasource.  And the configuration between cf11 and cf2016 is exactly the same.

Any ideas on this would be appreciated.

- Alex

Views

173

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
May 02, 2018 0
Adobe Employee ,
May 03, 2018

Copy link to clipboard

Copied

Please see the below link:

ColdFusion Help | ORM settings

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
May 03, 2018 0
demarcao LATEST
New Here ,
May 03, 2018

Copy link to clipboard

Copied

I have looked at this many times.  We have the same settings that we had in CF11 and it works fine there.  Are there changes in  CF2016 that could be causing this?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
May 03, 2018 0