Highlighted

CF9.0.2 gets a startup error "Unable to initialize Client Storage service" using Java 1.7.0_151

New Here ,
Sep 05, 2017

Copy link to clipboard

Copied

We applied the APSB14-23_FIX, which contains the hf902-00007.jar, and appears to be the latest CF9.0.2 update from Adobe.

The CF server runs with that update under Java 1.7.0_55, but when we try to repoint to using Java 1.7.0_151, we get the Client Storage error, and even though the server does start, any request fails due to lack of availability of client scope variables.

Our Version: 9,0,2,282541

Server.log:

"Information","main","08/28/17","08:41:52",,"Starting client..." "Error","main","08/28/17","08:41:53",,"Unable to initialize Client Storage service:
java.lang.ExceptionInInitializerError"

My suspicion is that CF9 is not compatible with the java 155 release, but since it is in the '1.7. series, that ought not to be the case.

Has anyone else seen this error, and were they able to resolve it?

Thanks,

Ian

[Moved from the non-technical Lounge Forum to the specific Program forum... Mod]
[Here is the list of all Adobe forums... https://forums.adobe.com/welcome]

Views

225

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

CF9.0.2 gets a startup error "Unable to initialize Client Storage service" using Java 1.7.0_151

New Here ,
Sep 05, 2017

Copy link to clipboard

Copied

We applied the APSB14-23_FIX, which contains the hf902-00007.jar, and appears to be the latest CF9.0.2 update from Adobe.

The CF server runs with that update under Java 1.7.0_55, but when we try to repoint to using Java 1.7.0_151, we get the Client Storage error, and even though the server does start, any request fails due to lack of availability of client scope variables.

Our Version: 9,0,2,282541

Server.log:

"Information","main","08/28/17","08:41:52",,"Starting client..." "Error","main","08/28/17","08:41:53",,"Unable to initialize Client Storage service:
java.lang.ExceptionInInitializerError"

My suspicion is that CF9 is not compatible with the java 155 release, but since it is in the '1.7. series, that ought not to be the case.

Has anyone else seen this error, and were they able to resolve it?

Thanks,

Ian

[Moved from the non-technical Lounge Forum to the specific Program forum... Mod]
[Here is the list of all Adobe forums... https://forums.adobe.com/welcome]

Views

226

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Sep 05, 2017 0
BKBK LATEST
Adobe Community Professional ,
Sep 14, 2017

Copy link to clipboard

Copied

The documentation for the ColdFusion 9.0.2 release mentions the level of Java support as JDK 1.7 Update .... In my opinion, it is risky to apply any version of Java more recent than JDK 1.7 Update 15 on ColdFusion 9.0.2.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 14, 2017 0