Highlighted

CF9 Standard / iis 7.5. Process .jsp file like a .cfm

New Here ,
Dec 02, 2015

Copy link to clipboard

Copied

I inheirited links ending with .jsp.  The domain is now pointing to my cf9 standard / iis7.5 web server.

When I tried to open the my version of the .jsp file or perform a url rewrite, I recevied an error that JSP is not licenced on Standard edition.

However, I don't want to run a jsp as a jsp template.  I would like it to run as a .cfm file.  Or ignore the file completely so I can use a url rewrite to point to my cfm file.

I tried to disable JSP from the default-web.xml files.  I am now getting an error 403:Forbidden.

What else needs to be done to stop Coldfusion from recognizing jsp files?

Thanks,

Gary

The issue has been resolved.

The first step was to disable *.jsp references from all the default-web.xml files.

Then apply a url rewrite. ^(.*)jsp$ which redirects to {R:1}cfm{R:2}

Thanks.

Views

156

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

CF9 Standard / iis 7.5. Process .jsp file like a .cfm

New Here ,
Dec 02, 2015

Copy link to clipboard

Copied

I inheirited links ending with .jsp.  The domain is now pointing to my cf9 standard / iis7.5 web server.

When I tried to open the my version of the .jsp file or perform a url rewrite, I recevied an error that JSP is not licenced on Standard edition.

However, I don't want to run a jsp as a jsp template.  I would like it to run as a .cfm file.  Or ignore the file completely so I can use a url rewrite to point to my cfm file.

I tried to disable JSP from the default-web.xml files.  I am now getting an error 403:Forbidden.

What else needs to be done to stop Coldfusion from recognizing jsp files?

Thanks,

Gary

The issue has been resolved.

The first step was to disable *.jsp references from all the default-web.xml files.

Then apply a url rewrite. ^(.*)jsp$ which redirects to {R:1}cfm{R:2}

Thanks.

Views

157

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Dec 02, 2015 0
New Here ,
Dec 02, 2015

Copy link to clipboard

Copied

The issue has been resolved.

The first step was to disable *.jsp references from all the default-web.xml files.

Then apply a url rewrite. ^(.*)jsp$ which redirects to {R:1}cfm{R:2}

Thanks.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Dec 02, 2015 0