Highlighted

CFBuilder 2018 MSAccess datasource

New Here ,
Mar 05, 2020

Copy link to clipboard

Copied

Hi,

Just installed CFBuilder 2018 on Windows 10 64bit. install correctly, builtin Coldfusion 2018 also installed correctly. the problem is when goto Data Source in CFAdmin, it does not let me configure MSAccess datasource. Microsoft Access is visiable in dropdown, when I press Add then it gives me this error line.

 

"The ColdFusion ODBC Server service is not running or has not been installed. You may also use the "MS Access with Unicode" driver to connect to MS Access datasources."

 

it saying "ODBC Service is not running". when i goto windows services list there is not coldfusion services are available. not even ColdFusion Application.

 

what should I do?

TOPICS
Builder, Connector, Database access

Views

532

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

CFBuilder 2018 MSAccess datasource

New Here ,
Mar 05, 2020

Copy link to clipboard

Copied

Hi,

Just installed CFBuilder 2018 on Windows 10 64bit. install correctly, builtin Coldfusion 2018 also installed correctly. the problem is when goto Data Source in CFAdmin, it does not let me configure MSAccess datasource. Microsoft Access is visiable in dropdown, when I press Add then it gives me this error line.

 

"The ColdFusion ODBC Server service is not running or has not been installed. You may also use the "MS Access with Unicode" driver to connect to MS Access datasources."

 

it saying "ODBC Service is not running". when i goto windows services list there is not coldfusion services are available. not even ColdFusion Application.

 

what should I do?

TOPICS
Builder, Connector, Database access

Views

533

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Mar 05, 2020 0
LEGEND ,
Mar 05, 2020

Copy link to clipboard

Copied

If you installed CF but are not seeing the CF running in Services, then the install most likely did not complete.  Were you logged on as an Admin when you installed CF?

 

V/r,

 

^ _ ^

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Mar 05, 2020 0
Adobe Community Professional ,
Mar 05, 2020

Copy link to clipboard

Copied

In my opinion, what you should do is:

1) Uninstall CFBuilder 2018 and ColdFusion 2018;

2) Reinstall CFBuilder 2018 without choosing the option to install ColdFusion 2018;

3) Download and install ColdFusion 2018 64Bit separately.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Mar 05, 2020 0
Adobe Community Professional ,
Mar 06, 2020

Copy link to clipboard

Copied

Folks, hold on. No need to uninstall cfb and the cf it istallef.

 

So here's the deal: if one DOES choose the option (in cfb 2016 and above) to have it install its own cf, that cf (called cf express) does NOT implement or even offer to implement the other cf services (odbc, add-on or. net).

 

So first, if one WANTED those, they can be installed separately as offered on the Adobe cf "downloads" page. But getting those setup with an existing cf install can be a challenge, relative to ports used and more.

 

Second, one could instead just install cf itself separately. They could just ignore the cf installed within cfbuilder, though this would require changing cfb features that connect it to a server (adding it the servers view, adding that server to any cfb projects, setting up an rds connection to the new server, if desired). And of course it would require setting up the cf admin in that new cf implementation. 

 

But finally third, I don't think that cf2018 supports access at all anymore, so I don't think one will find they can setup an access dsn even in such a complete cf install. I realize that you're seeing the option to select it, but if it can't work then of course it should be removed.

 

Would be great to hear from someone at Adobe, but I doubt we will. You could send an email asking that specific question to cfinstal@adobe.com. If you do, let us know the answer. 

/Charlie (server troubleshooter, carehart.org)

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Mar 06, 2020 1