Highlighted

CFCONTENT not working correctly with CF11 and IE10

Explorer ,
Jul 10, 2015

Copy link to clipboard

Copied

I have a very simple which is working in CF8 using IE10

<CFHEADER NAME="Content-Disposition" VALUE="inline; filename=sammy.jpg">

<CFCONTENT TYPE="application/unknown"

    DELETEFILE="No"

    FILE="c:\inetpub\mysite\sammy.jpg"

  reset="Yes">

I recently upgraded to CF11 and now the same code is not working on IE10, but amusingly it is working in Chrome and Firefox.

Any clue?

Views

510

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

CFCONTENT not working correctly with CF11 and IE10

Explorer ,
Jul 10, 2015

Copy link to clipboard

Copied

I have a very simple which is working in CF8 using IE10

<CFHEADER NAME="Content-Disposition" VALUE="inline; filename=sammy.jpg">

<CFCONTENT TYPE="application/unknown"

    DELETEFILE="No"

    FILE="c:\inetpub\mysite\sammy.jpg"

  reset="Yes">

I recently upgraded to CF11 and now the same code is not working on IE10, but amusingly it is working in Chrome and Firefox.

Any clue?

Views

511

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Jul 10, 2015 0
Engaged ,
Jul 10, 2015

Copy link to clipboard

Copied

Is the file always a JPEG image?  Try changing  the TYPE to: image/jpeg

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jul 10, 2015 0
Explorer ,
Jul 10, 2015

Copy link to clipboard

Copied

sdsinc_pmascari,

I am serving the file from database so it could be anything. The "application/unknown" works perfectly when I use CF8 / IE10

haxtbh,

In Chrome and Firefox the image or any file that is being served shows up on the browser but in IE 10, I get the following promt at the bottom of browser and when I click on open or save it does not do anything .. just hangs. It is same behavior whether I use http or https and the CF11 is updated to hf5

cfcontent.JPG

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jul 10, 2015 0
Engaged ,
Jul 10, 2015

Copy link to clipboard

Copied

I'm still thinking IE is having trouble with the MIME type.  Try your image with a correct MIME type to see if it works in IE.  If it does then that's your answer and you'll need to figure out a way to include proper MIME types going forward.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jul 10, 2015 0
Advocate ,
Jul 10, 2015

Copy link to clipboard

Copied

How is it not working? Does it just not do anything? Do you get an error?

Is your version of Coldfusion 11 fully updated to HF5?

Is this being executed over HTTPS?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jul 10, 2015 0
spradhan LATEST
Explorer ,
Jul 10, 2015

Copy link to clipboard

Copied

haxtbh,

In Chrome and Firefox the image or any file that is being served shows up on the browser but in IE 10, I get the following promt at the bottom of browser and when I click on open or save it does not do anything .. just hangs. It is same behavior whether I use http or https and the CF11 is updated to hf5

cfcontent.JPG

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jul 10, 2015 0