cfdocument broken after java upgrade CF 2016

Community Beginner ,
Sep 20, 2017 Sep 20, 2017

Copy link to clipboard

Copied

I upgraded Java to 1.8.0_144, due to the requirements of Update 5 for CF 2016 (I did not apply Update 5 yet). As a result of this upgrade cfdocument does not work. According to TS there is a known problem, when you get the same error trying to save system settings on Admin page in PDF file, but they did not hear anything about cfdocument.

Below is an error I’m getting:

An exception occurred when performing document processing.
The cause of this exception was that: coldfusion.document.spi.DocumentExportException:java.lang.ArrayIndexOutOfBoundsException: 0

It can be reproduced by simple:


<cfdocument format="PDF">

test

</cfdocument>.

My server is RHEL 7 64 bit.

I will continue to work with TS guys, just wondering if cfdocument works or does not work in similar environment for other people.

Views

784

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct Answer

Community Beginner , Sep 22, 2017 Sep 22, 2017
There is a bug in RHEL 7.4. https://bugzilla.redhat.com/show_bug.cgi?id=1484079  All fonts except one get deleted. CF is using  fonts to generate PDF. After fonts are reinstalled problem is gone.

Likes

Translate

Translate
Engaged ,
Sep 21, 2017 Sep 21, 2017

Copy link to clipboard

Copied

I'm using Windows w/CF2016 Developer 2016.0.05.303689 w/Java 1.8.0_144 and generating PDFs using the sample CFPDF tag works.  Is this bug limited to only the Linux version?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Sep 21, 2017 Sep 21, 2017

Copy link to clipboard

Copied

Have there been any recent changes on the server? 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Sep 22, 2017 Sep 22, 2017

Copy link to clipboard

Copied

LATEST

There is a bug in RHEL 7.4. https://bugzilla.redhat.com/show_bug.cgi?id=1484079  All fonts except one get deleted. CF is using  fonts to generate PDF. After fonts are reinstalled problem is gone.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines