Highlighted

cffile, accept, .docx misreporting as .zip

New Here ,
May 25, 2017

Copy link to clipboard

Copied

Using CF11, MacOS.

I have a file upload which accepts doc, docx, pdf. Doc and pdf behave as expected. However, whenever I try to upload a docx I receive the following error: "The MIME type or the Extension of the uploaded file application/zip was not accepted by the server".

I saw that there was a similar bug that was meant to be fixed in CF11, see this thread: Tracker

My cffile tag looks like this:

<cffile action = "uploadAll"

  fileField = "arguments.stuData.addDocuments"

  destination = "#dirTemp#"

  nameConflict = "MakeUnique"

  result="arrResult"

  accept = "application/pdf,application/msword,application/vnd.openxmlformats-officedocument.wordprocessingml.document,application/x-tika-msoffice"

/>

Can anyone help?

What update level is your CF11? Have you patched it to the latest version that fixes the similar bug?

Views

755

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

cffile, accept, .docx misreporting as .zip

New Here ,
May 25, 2017

Copy link to clipboard

Copied

Using CF11, MacOS.

I have a file upload which accepts doc, docx, pdf. Doc and pdf behave as expected. However, whenever I try to upload a docx I receive the following error: "The MIME type or the Extension of the uploaded file application/zip was not accepted by the server".

I saw that there was a similar bug that was meant to be fixed in CF11, see this thread: Tracker

My cffile tag looks like this:

<cffile action = "uploadAll"

  fileField = "arguments.stuData.addDocuments"

  destination = "#dirTemp#"

  nameConflict = "MakeUnique"

  result="arrResult"

  accept = "application/pdf,application/msword,application/vnd.openxmlformats-officedocument.wordprocessingml.document,application/x-tika-msoffice"

/>

Can anyone help?

What update level is your CF11? Have you patched it to the latest version that fixes the similar bug?

Views

756

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
May 25, 2017 0
Advocate ,
May 25, 2017

Copy link to clipboard

Copied

What update level is your CF11? Have you patched it to the latest version that fixes the similar bug?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
May 25, 2017 1
New Here ,
May 25, 2017

Copy link to clipboard

Copied

Hi

Nice thought!

I was using Version: 11,0,0,289974. The bug claims to have been fixed in update 5. So, I just upgraded to Version: 11,0,12,302575 and now docx is fine!

Thanks for your help.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
May 25, 2017 0