Highlighted

cfgrid html

Participant ,
Mar 13, 2015

Copy link to clipboard

Copied

Anyone able to edit a cfgrid in html format?  It works fine if it's a java applet, but it quits working when I change the format to html.  I submitted the bug to Adobe a few months ago, but I've received no response from them.

The submitted cfgrid form field is corrupt

Views

1.2K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

cfgrid html

Participant ,
Mar 13, 2015

Copy link to clipboard

Copied

Anyone able to edit a cfgrid in html format?  It works fine if it's a java applet, but it quits working when I change the format to html.  I submitted the bug to Adobe a few months ago, but I've received no response from them.

The submitted cfgrid form field is corrupt

Views

1.2K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Mar 13, 2015 0
Advocate ,
Mar 13, 2015

Copy link to clipboard

Copied

What version of ColdFusion are you running? Can you provide some code?

Are you usign this grid in a form with enctype="multipart/form-data"?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Mar 13, 2015 0
Participant ,
Mar 13, 2015

Copy link to clipboard

Copied

It appears to be submitting the form name twice even though there is only one row in the cfgrid. It is also passing two of the cfgridcolumns twice, but the edited value only once.

__CFGRID__CFForm_2__PesticideGrid

<cfform action="grid_act.cfm">

<cfgrid name = "PesticideGrid"

format="html"

striperows = "yes"

width="1200"

query = "getit"

insert = "yes"

delete = "yes"

colHeaderBold = "Yes"

selectMode = "EDIT"

insertButton = "Insert a Row" deleteButton = "Delete selected row" >

<cfgridcolumn name="cppestpesticideID" display="yes">

<cfgridcolumn name="description" header="Description" width="900" display="yes">

<cfgridcolumn name="pesticideid" header="Product"  display="yes" width="250">

</cfgrid>

<cfinput type="submit" name="pesticidesEntered" value="Save Chemical Comments">

</cfform>

The submitted cfgrid form field is corrupt (name: __CFGRID__CFFORM_2__PESTICIDEGRID value: __CFGRID__EDIT__=3�CPPESTPESTICIDEID�Y�DESCRIPTION�Y�PESTICIDEID�Y�1�U�37�37�acephat�508�508)

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Mar 13, 2015 0
Participant ,
Mar 13, 2015

Copy link to clipboard

Copied

ColdFusion 11

no enctype="multipart/form-data"

I added my code for you to view.  I've tried it many different ways, but it only works when format is a java applet and not html.  Unfortunately, there are security issues that are preventing me to use it as a java applet.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Mar 13, 2015 0
Advocate ,
Mar 13, 2015

Copy link to clipboard

Copied

I think this is related to Bug#3842284 - Submitting form with file and CFGRID - Exception in The submitted cfgrid form field is...

Can you check this and see if you get the same results if you use the enctype="multipart/form-data".

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Mar 13, 2015 0
Participant ,
Mar 13, 2015

Copy link to clipboard

Copied

Yes, I receive the error with and without enctype="multipart/form-data"

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Mar 13, 2015 0
Advocate ,
Mar 13, 2015

Copy link to clipboard

Copied

A quick test myself and I get the same behaviour. Unfortunately it is related to the bug mentioned and you may not be able to do much until they resolve it.

Seems to work when the format is set to flash though.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Mar 13, 2015 0
Participant ,
Mar 13, 2015

Copy link to clipboard

Copied

Thank you for helping me.  I appreciate your time.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Mar 13, 2015 0
Adobe Employee ,
Mar 13, 2015

Copy link to clipboard

Copied

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Mar 13, 2015 0