Highlighted

cfimage org.apache.sanselan.ImageWriteException

Community Beginner ,
Oct 07, 2019

Copy link to clipboard

Copied

I loop through a directory and resize images using the cfimage tag.  When I inspect exception.log, I see a bunch of expections.  The tag appears to be working though.

 

 

"Error","ajp-nio-8018-exec-4","10/08/19","05:33:31","","Tag (-1 (0xffffffff: Unknown Tag): ) appears twice in directory."
org.apache.sanselan.ImageWriteException: Tag (-1 (0xffffffff: Unknown Tag): ) appears twice in directory.
at org.apache.sanselan.formats.tiff.write.TiffImageWriterBase.validateDirectories(TiffImageWriterBase.java:135)
at org.apache.sanselan.formats.tiff.write.TiffImageWriterLossless.write(TiffImageWriterLossless.java:237)
at org.apache.sanselan.formats.jpeg.exifRewrite.ExifRewriter.writeExifSegment(ExifRewriter.java:573)
at org.apache.sanselan.formats.jpeg.exifRewrite.ExifRewriter.updateExifMetadataLossless(ExifRewriter.java:382)
at org.apache.sanselan.formats.jpeg.exifRewrite.ExifRewriter.updateExifMetadataLossless(ExifRewriter.java:298)
at coldfusion.image.ExifMetaDataHelper$1.run(ExifMetaDataHelper.java:100)
at coldfusion.image.ExifMetaDataHelper$1.run(ExifMetaDataHelper.java:87)
at java.base/java.security.AccessController.doPrivileged(Native Method)
at coldfusion.image.ExifMetaDataHelper.copyExifMetadata(ExifMetaDataHelper.java:86)
at coldfusion.image.ImageWriter.writeImage(ImageWriter.java:356)
at coldfusion.image.ImageWriter.writeImage(ImageWriter.java:199)
at coldfusion.image.Image.write(Image.java:940)
at coldfusion.tagext.io.ImageTag.performWrite(ImageTag.java:681)
at coldfusion.tagext.io.ImageTag.doStartTag(ImageTag.java:457)
at coldfusion.runtime.CfJspPage._emptyTcfTag(CfJspPage.java:4286)

Views

364

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

cfimage org.apache.sanselan.ImageWriteException

Community Beginner ,
Oct 07, 2019

Copy link to clipboard

Copied

I loop through a directory and resize images using the cfimage tag.  When I inspect exception.log, I see a bunch of expections.  The tag appears to be working though.

 

 

"Error","ajp-nio-8018-exec-4","10/08/19","05:33:31","","Tag (-1 (0xffffffff: Unknown Tag): ) appears twice in directory."
org.apache.sanselan.ImageWriteException: Tag (-1 (0xffffffff: Unknown Tag): ) appears twice in directory.
at org.apache.sanselan.formats.tiff.write.TiffImageWriterBase.validateDirectories(TiffImageWriterBase.java:135)
at org.apache.sanselan.formats.tiff.write.TiffImageWriterLossless.write(TiffImageWriterLossless.java:237)
at org.apache.sanselan.formats.jpeg.exifRewrite.ExifRewriter.writeExifSegment(ExifRewriter.java:573)
at org.apache.sanselan.formats.jpeg.exifRewrite.ExifRewriter.updateExifMetadataLossless(ExifRewriter.java:382)
at org.apache.sanselan.formats.jpeg.exifRewrite.ExifRewriter.updateExifMetadataLossless(ExifRewriter.java:298)
at coldfusion.image.ExifMetaDataHelper$1.run(ExifMetaDataHelper.java:100)
at coldfusion.image.ExifMetaDataHelper$1.run(ExifMetaDataHelper.java:87)
at java.base/java.security.AccessController.doPrivileged(Native Method)
at coldfusion.image.ExifMetaDataHelper.copyExifMetadata(ExifMetaDataHelper.java:86)
at coldfusion.image.ImageWriter.writeImage(ImageWriter.java:356)
at coldfusion.image.ImageWriter.writeImage(ImageWriter.java:199)
at coldfusion.image.Image.write(Image.java:940)
at coldfusion.tagext.io.ImageTag.performWrite(ImageTag.java:681)
at coldfusion.tagext.io.ImageTag.doStartTag(ImageTag.java:457)
at coldfusion.runtime.CfJspPage._emptyTcfTag(CfJspPage.java:4286)

Views

365

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Oct 07, 2019 0
Community Beginner ,
Oct 08, 2019

Copy link to clipboard

Copied

I also see the exact same errors in the exception.log. It appears to have started when we updated from CF2016 Update 7 to Update 9. As you say, the code appears to be working, but these exceptions are worrying.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 08, 2019 0
New Here ,
Oct 28, 2019

Copy link to clipboard

Copied

Same. I've been trying to resolve this with Adobe Support since April. Still a work in progress. Strangely it doesn't happen (anymore) in all of our environments. Sure does dirty up the exception log.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 28, 2019 0
Community Beginner ,
Oct 28, 2019

Copy link to clipboard

Copied

I have a bug filed with Adobe, but I'm not holding my breath for any response:

 

https://tracker.adobe.com/#/view/CF-4205377

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 28, 2019 0
LEGEND ,
Jun 04, 2020

Copy link to clipboard

Copied

Are you sure that the link you provided is the correct one? I clicked on it and it is for a bug related to CFLDAP, not image resizing.

 

V/r,

 

^ _ ^

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 04, 2020 0
Explorer ,
Jun 04, 2020

Copy link to clipboard

Copied

Did you ever resolve the cause of this issue?  I'm currently experiencing it.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 04, 2020 0
New Here ,
Jun 08, 2020

Copy link to clipboard

Copied

No, never did. They sent me a patch that was supposed to fix it, but it didn't. It only happens in certain environments (production!), too, which makes it harder to troubleshoot.

 

I'm hoping when we migrate from CF2016 to 2020 it will be resolved.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 08, 2020 0
New Here ,
Aug 17, 2020

Copy link to clipboard

Copied

I am experiencing this error as well, I check on my server and it doe snot appear that the img is actually being created in the directory. My code workds sometimes but not always I am suspecting that it depends on the specific file or content.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Aug 17, 2020 0