Highlighted

cfmailparam disposition filename does not work in outlook

New Here ,
Feb 08, 2016

Copy link to clipboard

Copied

I have a very simple example for sending an image as an attachment using Coldfusion 11 cfmail tag.

<cfmail to="example@domain.com" from="example@domain.com" subject="Test" type="html">

     <cfmailparam

          file="www.example.com/image.png"

          disposition="attachment; filename=""test.png""">

</cfmail>

I want the attachment to be called "test.png" when it is viewed in the recipients email client.

It works fine when I receive the email in Gmail, however Outlook 2013 (and Office 365 web client) retains the "image.png" attachment name.

Have I correctly made use of the "disposition" attribute?

Views

403

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

cfmailparam disposition filename does not work in outlook

New Here ,
Feb 08, 2016

Copy link to clipboard

Copied

I have a very simple example for sending an image as an attachment using Coldfusion 11 cfmail tag.

<cfmail to="example@domain.com" from="example@domain.com" subject="Test" type="html">

     <cfmailparam

          file="www.example.com/image.png"

          disposition="attachment; filename=""test.png""">

</cfmail>

I want the attachment to be called "test.png" when it is viewed in the recipients email client.

It works fine when I receive the email in Gmail, however Outlook 2013 (and Office 365 web client) retains the "image.png" attachment name.

Have I correctly made use of the "disposition" attribute?

Views

404

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Feb 08, 2016 0
Advocate ,
Feb 09, 2016

Copy link to clipboard

Copied

justinmorre wrote:

Have I correctly made use of the "disposition" attribute?

No, you have too many quotes. Try:

disposition="attachment; filename=test.png"

Cheers

Eddie

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 09, 2016 0
New Here ,
Feb 14, 2016

Copy link to clipboard

Copied

I tried without the double quotes and still have the same problem (Development Server).

However I pushed the code live regardless and found that it works as expected.

I'm going to compare versions and try to figure out what is happening.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 14, 2016 0