Highlighted

cgi.http_url blank output

Explorer ,
May 12, 2016

Copy link to clipboard

Copied

Yesterday morning I updated CF11 to update8, on a windows 2012, iis 8 box.

As I was reviewing one of my application logs, I noticed that from the time the server updated and forward that one of my values went blank.

CGI.http_URL was tracked on session start as part of my marketing logs.  It is no longer tracking as of Update 8.  I have tried to rollback to update 7 but that did not resolve my issue.

Upon googling, I see that this use to be an issue that was fixed and appears to have returned with the new Update.

Bug#3758070 - CGI.HTTP_URL Missing when using IIS

Obviously there must be something else that the CFAdmin rollback feature didn't roll back.

Is there anything that can be manually updated until its fixed again?

Steve

Views

572

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

cgi.http_url blank output

Explorer ,
May 12, 2016

Copy link to clipboard

Copied

Yesterday morning I updated CF11 to update8, on a windows 2012, iis 8 box.

As I was reviewing one of my application logs, I noticed that from the time the server updated and forward that one of my values went blank.

CGI.http_URL was tracked on session start as part of my marketing logs.  It is no longer tracking as of Update 8.  I have tried to rollback to update 7 but that did not resolve my issue.

Upon googling, I see that this use to be an issue that was fixed and appears to have returned with the new Update.

Bug#3758070 - CGI.HTTP_URL Missing when using IIS

Obviously there must be something else that the CFAdmin rollback feature didn't roll back.

Is there anything that can be manually updated until its fixed again?

Steve

Views

573

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
May 12, 2016 0
Adobe Employee ,
May 12, 2016

Copy link to clipboard

Copied

Hi Steven,

This works at my end on update 8.

Try dumping

<cfdump var ="#CGI#">

or

<cfdump var ="#CGI.HTTP_URL#">

Thanks,

Rahul

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
May 12, 2016 0
Explorer ,
May 12, 2016

Copy link to clipboard

Copied

Hi, thanks I have.

on a sample url such as

xyz.com/test/?utm_source=Google&utm_medium=PPC

my <cfdump var="#cgi#">

is showing HTTP_URL: [empty string]

where prior to running the upgrade it was showing

http://xyz.com/tes/?utm_source=Google&utm_medium=PPC

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
May 12, 2016 0
Adobe Employee ,
May 12, 2016

Copy link to clipboard

Copied

Hi Steven,

Looks like update has not been applied properly.

What was your previous update level before applying update 8 ?

Can you please send your CF administrator settings summary and Adobe_ColdFusion_11_Update_8_Install_Date log (location: ColdFusion11\cfusion\hf-updates\hf-11-00008) to cf.install@adobe.com

Thanks,

Rahul

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
May 12, 2016 0
Advocate ,
May 12, 2016

Copy link to clipboard

Copied

I think the issue you are having is actually this bug -Bug#4097008 - [ANeff] Bug for: CGI.HTTP_URL returns [empty string] on IIS when default doc omitted

Can you confirm by using the default doc in the url?

We have this issue as well. I.e. using the following urls give different results

www.mywebsite.com/directory/default.cfm?param=123

This will show the CGI.HTTP_URL correctly.

www.mywebsite.com/directory/?param=123

This will show [empty string]

Easily reproduce this in Update 8 but doesnt seem to be an issue in Update 7

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
May 12, 2016 0
Explorer ,
May 12, 2016

Copy link to clipboard

Copied

ok I'll roll back up to 8 and then send all the details.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
May 12, 2016 0
Explorer ,
May 12, 2016

Copy link to clipboard

Copied

I think you nailed it.  I think its related to that.  The routine in question is also part of my Mura CMS install, a custom plugin.  Nothing in my code base has changed, but the update changed my environment.

steve

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
May 12, 2016 0
Adobe Employee ,
May 12, 2016

Copy link to clipboard

Copied

@steven, Yes, i could reproduce he issue with default document as in Bug#4097008

I saw this behaviour on update 8 as well. Could you please let us know what was your previous update before applying update 8?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
May 12, 2016 0
ifsteve LATEST
Explorer ,
May 12, 2016

Copy link to clipboard

Copied

I was previously running update 7.

I emailed my info info cf.install@adobe.com as requested.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
May 12, 2016 0