Highlighted

Clustered Websockets

Community Beginner ,
Aug 24, 2017

Copy link to clipboard

Copied

we have 2 separate physical servers in a cluster behind a F5 bigip load balancer, with a separate websocket virtual server set up with both nodes.  I can't seem to get a websocket data push to propagate between the two servers.  if i have one node enabled, it works fine, but if i send a wspublish from one server, it doesn't show up on the other server. 

any ideas?

Views

228

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Clustered Websockets

Community Beginner ,
Aug 24, 2017

Copy link to clipboard

Copied

we have 2 separate physical servers in a cluster behind a F5 bigip load balancer, with a separate websocket virtual server set up with both nodes.  I can't seem to get a websocket data push to propagate between the two servers.  if i have one node enabled, it works fine, but if i send a wspublish from one server, it doesn't show up on the other server. 

any ideas?

Views

229

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Aug 24, 2017 0
Adobe Community Professional ,
Aug 25, 2017

Copy link to clipboard

Copied

I have not yet used an infrastructure like yours, but an idea immediately springs to mind. Did you enable Websocket clusters in the ColdFusion Administrator?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Aug 25, 2017 0
Community Beginner ,
Aug 25, 2017

Copy link to clipboard

Copied

absolutely.  i was looking through all of the logs to see if there was some sort of error in regards to websockets, but found nothing in regards to it. 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Aug 25, 2017 0
BKBK LATEST
Adobe Community Professional ,
Aug 29, 2017

Copy link to clipboard

Copied

Open the ColdFusion Administrator. Go to the WebSockets page.

Is the setting "Enable WebSocket cluster" checked?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Aug 29, 2017 0