Cold Fusion 11 refresh page image does not appear

Explorer ,
Nov 12, 2014 Nov 12, 2014

Copy link to clipboard

Copied

Hi,


In Cold Fusion 11, when I first bring up a page the graphic image appears.

When I refresh the page, the graphic image does not appear.

This is not an issue with Cold Fusion 9.

Is there anything in the administration that needs to be configured?

Thanks,

Mike

Views

4.8K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct Answer

Advocate , Dec 05, 2014 Dec 05, 2014
If you open the IIS Management Console and go to the site you want to check, over on the right hand side where the Stop and Restart actions are there is a "Failed request traced" link. Click this to open it and enable it.   Once this is enabled you can go  back to the "Home" part of the site in IIS where all the icons for configuration are. If you have the module installed as part of IIS you will have a Failed Request Tracing Rules icon to open.If its not there then you will need to run the serv...

Likes

Translate

Translate
Guide ,
Nov 12, 2014 Nov 12, 2014

Copy link to clipboard

Copied

What pages are you referring to?  In the Administrator, or your own web site?

-Carl V.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Nov 12, 2014 Nov 12, 2014

Copy link to clipboard

Copied

I am referring to the website I support.

Mike

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Guide ,
Nov 12, 2014 Nov 12, 2014

Copy link to clipboard

Copied

Are you using the built-in web server or fronting your site with IIS or Apache?

Turn on your developer tools in your browser and check the network information.  Are you getting any error codes for the image files?

-Carl V.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Nov 12, 2014 Nov 12, 2014

Copy link to clipboard

Copied

Using IIS 7

When the page initially loads, the result on the page is 200 and 304 for the image.

When the page is refreshed, the page load is 200 and 500 for the image.

Mike

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Guide ,
Nov 12, 2014 Nov 12, 2014

Copy link to clipboard

Copied

Sounds like an IIS problem then, not a ColdFusion one.  What is the specific 500 error code you are getting? You might need to fumble around with the different content on the network information tab to see the detailed response.  What browser are you using?

-Carl V.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Nov 12, 2014 Nov 12, 2014

Copy link to clipboard

Copied

The Type in the debug is image/jpeg on initial load.

When the page is refreshed the Type is text/html

The problem started after Cold Fusion 11 was installed. This was not an issue with Cold Fusion 9.

Using IE8

Mike

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Guide ,
Nov 12, 2014 Nov 12, 2014

Copy link to clipboard

Copied

Have you applied any of the ColdFusion 11 updates?  If so, did you rebuild the web connectors afterward?  You might also try downloading the beta of Update 3 to see if it has any effect.  See the ColdFusion Blog for details.

The mime type changes seem suspicious.  Are the images being loaded using a standard <img> tag or some other way?  If via <img>, ColdFusion shouldn't be touching them unless the filename/path is coming from a ColdFusion variable.  Have you looked at the IIS logs to see what might be happening during the refresh request?

-Carl V.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Nov 12, 2014 Nov 12, 2014

Copy link to clipboard

Copied

I have tried to apply the Cold Fusion 11 updates, but it looks like the updates have not been applied.

I have posted questions under the Cold Fusion 11 updates (Security fixes).


Below is image using the <img> tag.

<img src="/BUSDev/images/headergraphicnewbus.jpg" border="0">

I will look in the IIS logs.

Mike

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Nov 12, 2014 Nov 12, 2014

Copy link to clipboard

Copied

The following in the entry in the IIS log:

2014-11-12 19:34:59 10.29.21.71 GET /BUSDev/images/headergraphicnewbus.jpg - 443 - 10.10.224.114 Mozilla/5.0+(Windows+NT+6.1;+Trident/7.0;+rv:11.0)+like+Gecko 404 2 1260 0

Mike

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Guide ,
Nov 12, 2014 Nov 12, 2014

Copy link to clipboard

Copied

So that looks like a 404.2 error, which is "Not Found" and related to CGI/ISAPI restrictions.  Also looks like the image is being loaded over HTTPS.  When the image first loads fine, is it also being loaded over HTTPS?  When you refresh, is any authentication expired?

In any case, this is definitely an IIS issue.  You might have more luck getting assistance if you jump on Microsoft Technet for IIS support or on ServerFault.

-Carl V.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Nov 17, 2014 Nov 17, 2014

Copy link to clipboard

Copied

The site is using HTTPS. I do not see anything expired.

This issue after installing Cold Fusion 11. When Cold Fusion 9 was installed, the images worked fine.

Thanks

Mike

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Guide ,
Nov 17, 2014 Nov 17, 2014

Copy link to clipboard

Copied

I still don't think this is a ColdFusion issue.  However, you mentioned CF9 - did you install CF11 on the same server CF9 was or is on?  Did you remove the CF9 IIS connectors then add the CF11 connectors?  Have you removed CF9 or just stopped the services?

-Carl V.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Nov 17, 2014 Nov 17, 2014

Copy link to clipboard

Copied

CF 11 is installed on the same server CF9 was installed on.

I stopped the stopped the CF9 services and removed the CF9.

I did not remove the CF9 IIS connectors.

Mike

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Guide ,
Nov 17, 2014 Nov 17, 2014

Copy link to clipboard

Copied

That could be the problem.  The CF9 connectors definitely need to be removed.  You'll have to do it manually in IIS.

-Carl V.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Nov 17, 2014 Nov 17, 2014

Copy link to clipboard

Copied

I could not find any information on to remove the CF9 connectors manually in IIS.

Is there some instructions on how to perform this?

Mike

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Guide ,
Nov 18, 2014 Nov 18, 2014

Copy link to clipboard

Copied

The easiest way is to remove the CF11 connectors temporarily first.  Use the CF11 Web Connection Configuration Tool to remove all the connectors.  Once that's done, open IIS Manager.

In IIS Manager, click on the server at the top of the Connections pane.  In the main pane, open Handler Mappings.  Look for the ColdFusion extensions in the "path" column (*.cfc/*.cfm/*cfml/*.cfr/*.cfswf etc.).  If you see any, delete them.  Then go through each web site configured on that server and check their Handler Mappings.  Again, if you see any mapped to ColdFusion extensions, delete them.  You might want to restart IIS just to be safe.

Now go back into the CF11 Web Connection Configuration Tool and reconnect to IIS.

-Carl V.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Nov 24, 2014 Nov 24, 2014

Copy link to clipboard

Copied

Hi,

I followed the instructions and no .cfc, .cfm, .cfml, .cfr, cfswf appeared in the Handler Mappings.

I restored the environment back to Cold Fusion 9 and started to install the Cold Fusion 11 process again.

The Cold Fusion 9 Handler Mappings were manually deleted after Cold Fusion 9 was deleted prior to installing Cold Fusion 11.

After installing Cold Fusion 11, the website appears with the image the first time the page is loaded but when it is refreshed the image disappears.

I checked to see if the .cfc, .cfm, .cfml, .cfr, cfswf appear in the Handler Mappings. They do not appear.

The Update 2 patch has not been installed.

Thanks,

Mike

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Guide ,
Nov 24, 2014 Nov 24, 2014

Copy link to clipboard

Copied

The fact that you don't see handler mappings after installing ColdFusion 11 indicates that either you didn't run the Web Server Configuration Tool (WSCONFIG), or you didn't run it "As Administrator".  Not only should you have handlers, but you should also have the "Jakarta" and "CFIDE" virtual directories added to your web site(s) in IIS.

I would suggest installing the Update 2 patch before running the WSCONFIG tool so that you won't have to go back and rebuild the web connectors after the update.

-Carl V.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Nov 24, 2014 Nov 24, 2014

Copy link to clipboard

Copied

The installation was run "As Administrator". During the installation, the screen that comes up when manually running WSCONFIG appeared in the "Configure Web Servers/Websites" screen during installation.

I will be installing the Update 2 patch and then executing the WSCONFIG tool manually.

Mike

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Nov 24, 2014 Nov 24, 2014

Copy link to clipboard

Copied

I have installed the Update 2 "As Administrator" and manually executed WSCONFIG.

The Cold Fusion extension still do not show up in the Handlers Mapping.

I opened the webconfig file for the website and for example the .jsp still points to the following:

<add name="jspHandler" path="*.jsp" verb="*" modules="IsapiModule" scriptProcessor="C:\JRun4\lib\wsconfig\jrun_iis6.dll" resourceType="Either" responseBufferLimit="0" />


Where in the Cold Fusion 11 directories would the .cfc, .cfm, .cfml, .cfr, cfswf point to?

Possibly create a manual entry in webconfig file?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Guide ,
Nov 24, 2014 Nov 24, 2014

Copy link to clipboard

Copied

You should not have to manually add entries in webconfig.  Something has gotten borked along the way here.

You should not run the WSCONFIG during ColdFusion installation (you should choose to install the built-in webserver only).  Then once the appropriate updates have been installed, run WSCONFIG "As Administrator".

That "jspHandler" should have been removed when all the other ColdFusion mappings were removed.  Is that entry in the server's config or a specific site's web.config file?

If things are that messed up, you might want to uninstall and reinstall IIS to clean out all of the config settings, then try connection ColdFusion again.

-Carl V.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Nov 24, 2014 Nov 24, 2014

Copy link to clipboard

Copied

The "jspHandler" is in the specifc site's webconfig file.

During Cold Fusion 11 installation, the "Configure Web Servers/Websites" screen shows the following options:

All IIS Websites

Configure specific IIS website or entire web server

Built-in web server (development use only)

Configure WebSocket Proxy to selected web server/websites

The "All IIS Websites" is selected by default.

I only selected the Next button on the "Configure Web Servers/Websites" screen.

I looked in the Release Notes file. It mentions the following:

3676569 - The batch files available in the cfusion/bin/connector directory may not work out of the box. The scripts are provided only for reference.

I will have the admin uninstall IIS and reinstall. Then I will execute the WSCONFIG manually.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Nov 26, 2014 Nov 26, 2014

Copy link to clipboard

Copied

I had IIS 7 uninstalled and reinstalled.

I installed the ASP.Net, .NET, ASP, CGI, ISAPI Extensions and ISAPI Filters in the Select Role Services for IIS.

Now the website returns a 404 File or Directory not found when trying to bring up the web page.

I executed the WSCONFIG.

Also, the Handler Mappings (.cfc, .cfm, .cfml, .cfr, cfswf) still do not show the in the webconfig file for the website or in the Handler Mappings for the website.

Mike

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Guide ,
Nov 26, 2014 Nov 26, 2014

Copy link to clipboard

Copied

Just to confirm, when you run WSCONFIG, you do it with right-click and "Run As Administrator" rather than just clicking the icon from the Start menu?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines