cold fusion 2016 internal server error.

New Here ,
Feb 10, 2020 Feb 10, 2020

Copy link to clipboard

Copied

Hi Team,

 

Fim feed job runs on Coldusion server2016. TheJob is failing from past few months with the error " 500 internal server error ". We have received a confirmation from the team who monitors the Job, that things are fine from their end. Could you please suggest here.

 

Let us know if any other information is required.

 

Kind Regards,

Manasa C

 

TOPICS
Reporting, Server administration

Views

1.0K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Feb 10, 2020 Feb 10, 2020

Copy link to clipboard

Copied

This is really just not enough information for anyone to help you. What's in the log file? What does it mean when the other team says "things are fine from their end"? You have to get some diagnostic information if you want people to help you.

 

Dave Watts, Eidolon LLC

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Feb 19, 2020 Feb 19, 2020

Copy link to clipboard

Copied

Hi Dave,

The basic work flow is we get the data is placed in the share path. This data is coming form a different team. This data file is picket up by one of the scheduled Job known as Fim Feed which proess the file with the help a .cfm file and writes the data to the DB. 

We see the file is getting picked up from the share path but while process the in the Job we are getting  Internal server error in the FIM Feed logs and below is the error seen in the application log.

 

"Error","http-nio-8500-exec-4","02/16/20","16:47:22","","Application could not be found. The specific sequence of files included or processed is: '''' "
"Error","http-nio-8500-exec-2","02/16/20","16:47:22","","Application could not be found. The specific sequence of files included or processed is: '''' "
"Warning","http-nio-8500-exec-6","02/16/20","16:49:14","COMPONENTUTILS","To use Component Browser, enable RDS Service using Administrator. Note: RDS is intended for development use only."
"Warning","http-nio-8500-exec-3","02/16/20","16:49:14","COMPONENTUTILS","To use Component Browser, enable RDS Service using Administrator. Note: RDS is intended for development use only."
"Error","http-nio-8500-exec-7","02/16/20","16:49:59","","Application v1 could not be found. The specific sequence of files included or processed is: '''' "

 

Please let us know if any other information is required from our end.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Feb 22, 2020 Feb 22, 2020

Copy link to clipboard

Copied

Can you enable detailed error messages and debugging for local pages, then log into the console and run the page manually? That should give you more useful information.

 

Dave Watts, Eidolon LLC

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Mar 03, 2020 Mar 03, 2020

Copy link to clipboard

Copied

Hi Team, 

 

we found that FIM_Feed was not run successfully  with an error connection Failure and it was successful  yesterday , attached the log files for your reference. 

could you please check and let me know that was the issues for failing. 

and let us know in case of any further inforamtion required. 

 

 

Thanks 

Hemanth 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Mar 04, 2020 Mar 04, 2020

Copy link to clipboard

Copied

Hemanth, I'm not seeing any logs attached, but perhaps I'm just missing them.

 

Anyway, you say you get a connection error on the scheduled task, and that it "just started happening" some months ago. Is it an https URL that the task calls? That may be where the change happened--in the server that SERVES that URL, and the ssl/tls protocols it may support.

 

I realize that you say the URL in the task "works", but is that when called from a browser? The problem is that a browser may handle such a change in ssl/tls protocol in a way that CF (calling the URL as a scheduled task or CFHTTP call) may not. It is often down to a matter of you running (under CF) an outdated JVM.

 

I discuss this (the problem and solution) in a blog post here:

 

https://coldfusion.adobe.com/2019/06/error-calling-cf-via-https-solved-updating-jvm/

 

And as I offer there, if you may want help implementing the needed solution, I can help with that remotely, likely in less than 15 mins. But let us know if the info here (and in that post) helps.


/Charlie (server troubleshooter, carehart.org)

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Mar 09, 2020 Mar 09, 2020

Copy link to clipboard

Copied

Hi Charlie_Arehart 

Thanks for the above inforamtion on this issue and we would like to take  your remote session help 

could you please share the meeting invite to discuss further 

 

Is it an https URL that the task calls? That may be where the change happened--in the server that SERVES that URL, and the ssl/tls protocols it may support. : No , we are using http prtoocal to call this task . 

 

Thank you 

 

Hemanth 

 

 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Mar 09, 2020 Mar 09, 2020

Copy link to clipboard

Copied

Sure, Hemanth. You can find my rates, approach, satisfaction guarantee, and more (including arranging time and getting a meeting url) at https://www.carehart.org/consulting . We could meet today or any day this week. 


/Charlie (server troubleshooter, carehart.org)

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Mar 11, 2020 Mar 11, 2020

Copy link to clipboard

Copied

Hi Charlie_Arehart,

 

we found that No FIM File Found in FIM feed log , could you please review and suggest the steps to fix this. 

 

please refer the log  below and let us know in case of any further information required 

*******************************************************************************

<!DOCTYPE HTML>
<meta http-equiv="X-UA-Compatible" content="IE=EDGE" />

<meta http-equiv="CACHE-CONTROL" content="NO-CACHE">

<meta http-equiv="CONTENT-LANGUAGE" content="en-US">
<meta http-equiv="CONTENT-TYPE" content="text/html; charset=UTF-8">
<meta name="COPYRIGHT" content="&copy; 2020 LAWTRAC">
<meta name="DESCRIPTION" content="LAWTRAC 4.3.4">
<meta name="KEYWORDS" content="NOARCHIVE">
<meta name="ROBOTS" content="NONE">
<meta name="GOOGLEBOT" content="Disallow">

<link REL="SHORTCUT ICON" HREF="images/favicon.ico" />
<link rel="stylesheet" type="text/css" href="https://lawtrac/lawtrac/4XAssets/CSSA/bootstrap.min.css">
<link rel="stylesheet" type="text/css" href="https://lawtrac/lawtrac/4XAssets/CSSA/font-awesome.css">
<link rel="stylesheet" type="text/css" href="https://lawtrac/lawtrac/4XAssets/CSSA/LAWTRAC40.css">

<script type="text/javascript" src="https://lawtrac/lawtrac/4XAssets/js/jquery.min.js"></script>
<script type="text/javascript" src="https://lawtrac/lawtrac/4XAssets/js/tiny_mce/tiny_mce.js"></script>
<script type="text/javascript" src="https://lawtrac/lawtrac/4XAssets/Trends/TrendsTabbedPanels.js"></script>
<script type="text/javascript" src="https://lawtrac/lawtrac/4XAssets/js/Accordians/Accordians.js"></script>
<script type="text/javascript" src="https://lawtrac/lawtrac/4XAssets/js/bootstrap.min.js"></script>
<script type="text/javascript" src="https://lawtrac/lawtrac/4XAssets/js/cfWindow.js"></script>
<script type="text/javascript" src="https://lawtrac/lawtrac/4XAssets/js/custom/validate.js"></script>
<!-- javascript for persistent menu highlight -->
<script type="text/javascript" src="https://lawtrac/lawtrac/4XAssets/js/menuHighlight.js"></script>

<script type="text/javascript">
window.status=""
</script>

<script type="text/javascript">
_cf_loadingtexthtml="<div align='center'><img src='https://lawtrac/lawtrac//images/loading.gif' width='10' height='10'></div>";
</script>

<p class="body" align="center">
<BR><BR>
No FIM File Found<hr>
</p>
<font class="body">
<p align="center">
Process Complete: Click <A href="../../default.cfm" target="_top" class="body">HERE</A> To Continue
</p>
</font>

 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Apr 02, 2020 Apr 02, 2020

Copy link to clipboard

Copied

Hi Team, 

Thanks forall your support and the issuee stands resolved and working as expecte. 

 

During the Process, the code is return in a such way that based on status. We observed that MailSent.log file empty where as we are receing the emails. The same is happening  when ever an exception is thrown. None of the logs are captured. 

 

Could you please let us know what would be the possible reson , we will be glad to share if more info is requried. 

 

Thanks in advance !

 

-hemanth 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Apr 02, 2020 Apr 02, 2020

Copy link to clipboard

Copied

LATEST

I don't think the contents of email messages are logged by default. There's a checkbox in the CF Administrator for that. But in either case, if an email message isn't sent, there isn't going to be an entry in MailSent.log because the mail wasn't sent.

 

Beyond that - and I know I've brought this up before - you're simply not providing enough information for anyone to answer your questions. You need to either provide a lot more detail, or hire a consultant who can review your systems via web meeting. Charlie does a lot of this kind of work. I can't even tell you what additional detail you need to provide, because you've provided so little to start with. I'm offering this response in good faith, not to be difficult, but you get out what you put in when you're asking these questions.

 

Dave Watts, Eidolon LLC

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines