Highlighted

Coldfusion 10 service won't start at all

Community Beginner ,
Oct 01, 2015

Copy link to clipboard

Copied

We have ColdFusion10 (update 17) Standard Edition installed on a Windows 2008 R2 server. It has been installed and running fine for a couple years, but in the last few weeks we have had trouble starting the service. After reboot it wouldn't start automatically or through a .bat file that checks to make sure it's started every morning. It also would time out starting from the Server Manager console. We were able to start it from the command line using net start "COLDFUSION 10 APPLICATION SERVER", but now it will not work that way either.

image1.jpg

The logs do not appear to show anything unusual as far as I can tell. The only way we have been able to get it started is to run cfstart.bat in the cfusion\bin directory. The websites are available, but the actual service is not running (at least as far as windows monitoring is concerned).

This error is showing up in the server event log when we try to start the service:

image2.jpg

One possibility that we have wondered about is that Microsoft .NET Framework updates could have possibly broken it. That was the only update installed before it was broken this past time. The service has taken a while to start up in the past, but never so long that it times out and we couldn't start it from the Server Manager. And we have never seen it fail to start at all multiple times in a row. To be clear, it fails EVERY time, even if you try 20 times in a row.

We are considering rebuilding the server, but I would really like to just fix this one. Who knows if it could happen again. Thanks for any feedback.

Hi Tracy,

Well that should fix it remove CF10, install CF10, apply any customisations you may need like datasources, JVM parameters, tomcat server.xml or property files. Perhaps some customisation can be put back by

keeping a copy of neo* files from CF10\cfusion\lib\.

 

Beg my pardon to Charlie I repeated something he suggested (tho with a typo he versa hs errors). It was a long weekend for me and I did not read the post well.

Regards, Carl.

Views

1.7K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Coldfusion 10 service won't start at all

Community Beginner ,
Oct 01, 2015

Copy link to clipboard

Copied

We have ColdFusion10 (update 17) Standard Edition installed on a Windows 2008 R2 server. It has been installed and running fine for a couple years, but in the last few weeks we have had trouble starting the service. After reboot it wouldn't start automatically or through a .bat file that checks to make sure it's started every morning. It also would time out starting from the Server Manager console. We were able to start it from the command line using net start "COLDFUSION 10 APPLICATION SERVER", but now it will not work that way either.

image1.jpg

The logs do not appear to show anything unusual as far as I can tell. The only way we have been able to get it started is to run cfstart.bat in the cfusion\bin directory. The websites are available, but the actual service is not running (at least as far as windows monitoring is concerned).

This error is showing up in the server event log when we try to start the service:

image2.jpg

One possibility that we have wondered about is that Microsoft .NET Framework updates could have possibly broken it. That was the only update installed before it was broken this past time. The service has taken a while to start up in the past, but never so long that it times out and we couldn't start it from the Server Manager. And we have never seen it fail to start at all multiple times in a row. To be clear, it fails EVERY time, even if you try 20 times in a row.

We are considering rebuilding the server, but I would really like to just fix this one. Who knows if it could happen again. Thanks for any feedback.

Hi Tracy,

Well that should fix it remove CF10, install CF10, apply any customisations you may need like datasources, JVM parameters, tomcat server.xml or property files. Perhaps some customisation can be put back by

keeping a copy of neo* files from CF10\cfusion\lib\.

 

Beg my pardon to Charlie I repeated something he suggested (tho with a typo he versa hs errors). It was a long weekend for me and I did not read the post well.

Regards, Carl.

Views

1.7K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Oct 01, 2015 0
Guide ,
Oct 01, 2015

Copy link to clipboard

Copied

Hi Tracy,

When CF10 tries to start are any details recorded in ColdFusion10\cfusion\logs coldfusion-error.log or coldfusion-out.log files?

HTH, Carl.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 01, 2015 1
Community Beginner ,
Oct 02, 2015

Copy link to clipboard

Copied


Here are the coldfusion-out.log entries for a few attempts starting:

09/30 08:49:34 INFO License Service: Flex 1.5 CF Edition enabled

09/30 08:49:34 INFO Starting Flex 1.5 CF Edition

Sep 30, 2015 08:49:34 AM Information [localhost-startStop-1] - Starting logging...

Sep 30, 2015 08:49:34 AM Information [localhost-startStop-1] - Starting license...

Sep 30, 2015 08:49:35 AM Information [localhost-startStop-1] - Standard Edition enabled

Sep 30, 2015 08:49:35 AM Information [localhost-startStop-1] - Starting crypto...

Sep 30, 2015 08:49:35 AM Information [localhost-startStop-1] - Starting security...

Sep 30, 2015 08:49:37 AM Information [localhost-startStop-1] - Starting scheduler...

Sep 30, 2015 08:49:37 AM Information [localhost-startStop-1] - Starting WatchService...

Sep 30, 2015 08:49:37 AM Information [localhost-startStop-1] - Starting debugging...

Sep 30, 2015 08:49:37 AM Information [localhost-startStop-1] - Starting sql...

Sep 30, 2015 08:49:37 AM Information [localhost-startStop-1] - Pool Manager Started

Sep 30, 2015 08:49:38 AM Information [localhost-startStop-1] - Starting mail...

Sep 30, 2015 08:49:38 AM Information [localhost-startStop-1] - Starting runtime...

09/30 08:53:39 INFO License Service: Flex 1.5 CF Edition enabled

09/30 08:53:39 INFO Starting Flex 1.5 CF Edition

Sep 30, 2015 08:53:39 AM Information [localhost-startStop-1] - Starting logging...

Sep 30, 2015 08:53:39 AM Information [localhost-startStop-1] - Starting license...

Sep 30, 2015 08:53:40 AM Information [localhost-startStop-1] - Standard Edition enabled

Sep 30, 2015 08:53:40 AM Information [localhost-startStop-1] - Starting crypto...

Sep 30, 2015 08:53:40 AM Information [localhost-startStop-1] - Starting security...

Sep 30, 2015 08:53:41 AM Information [localhost-startStop-1] - Starting scheduler...

Sep 30, 2015 08:53:41 AM Information [localhost-startStop-1] - Starting WatchService...

Sep 30, 2015 08:53:41 AM Information [localhost-startStop-1] - Starting debugging...

Sep 30, 2015 08:53:41 AM Information [localhost-startStop-1] - Starting sql...

Sep 30, 2015 08:53:41 AM Information [localhost-startStop-1] - Pool Manager Started

Sep 30, 2015 08:53:42 AM Information [localhost-startStop-1] - Starting mail...

Sep 30, 2015 08:53:42 AM Information [localhost-startStop-1] - Starting runtime...

09/30 08:57:56 INFO License Service: Flex 1.5 CF Edition enabled

09/30 08:57:56 INFO Starting Flex 1.5 CF Edition

Sep 30, 2015 08:57:56 AM Information [localhost-startStop-1] - Starting logging...

Sep 30, 2015 08:57:56 AM Information [localhost-startStop-1] - Starting license...

Sep 30, 2015 08:57:56 AM Information [localhost-startStop-1] - Standard Edition enabled

Sep 30, 2015 08:57:57 AM Information [localhost-startStop-1] - Starting crypto...

Sep 30, 2015 08:57:57 AM Information [localhost-startStop-1] - Starting security...

Sep 30, 2015 08:57:57 AM Information [localhost-startStop-1] - Starting scheduler...

Sep 30, 2015 08:57:57 AM Information [localhost-startStop-1] - Starting WatchService...

Sep 30, 2015 08:57:57 AM Information [localhost-startStop-1] - Starting debugging...

Sep 30, 2015 08:57:57 AM Information [localhost-startStop-1] - Starting sql...

Sep 30, 2015 08:57:57 AM Information [localhost-startStop-1] - Pool Manager Started

Sep 30, 2015 08:57:58 AM Information [localhost-startStop-1] - Starting mail...

Sep 30, 2015 08:57:58 AM Information [localhost-startStop-1] - Starting runtime...

Sep 30, 2015 08:58:00 AM Information [localhost-startStop-1] - CORBA Configuration not enabled

Sep 30, 2015 08:58:00 AM Information [localhost-startStop-1] - Starting cron...

[listed several scheduled tasks that misfired]

Sep 30, 2015 08:58:02 AM Information [localhost-startStop-1] - Starting client...

Sep 30, 2015 08:58:02 AM Information [localhost-startStop-1] - Starting xmlrpc...

Sep 30, 2015 08:58:02 AM Information [localhost-startStop-1] - Starting jaxrs...

Sep 30, 2015 08:58:02 AM Information [localhost-startStop-1] - Starting graphing...

Sep 30, 2015 08:58:02 AM Information [localhost-startStop-1] - Starting solr...

Sep 30, 2015 08:58:03 AM Information [localhost-startStop-1] - Starting archive...

Sep 30, 2015 08:58:03 AM Information [localhost-startStop-1] - Starting document...

Sep 30, 2015 08:58:03 AM Information [localhost-startStop-1] - Starting eventgateway...

Sep 30, 2015 08:58:03 AM Information [localhost-startStop-1] - Event Gateway Disabled.

Sep 30, 2015 08:58:03 AM Information [localhost-startStop-1] - Starting FlexAssembler...

09/30 09:09:56 INFO License Service: Flex 1.5 CF Edition enabled

09/30 09:09:56 INFO Starting Flex 1.5 CF Edition

Sep 30, 2015 09:09:56 AM Information [localhost-startStop-1] - Starting logging...

Sep 30, 2015 09:09:56 AM Information [localhost-startStop-1] - Starting license...

Sep 30, 2015 09:09:57 AM Information [localhost-startStop-1] - Standard Edition enabled

Sep 30, 2015 09:09:57 AM Information [localhost-startStop-1] - Starting crypto...

Sep 30, 2015 09:09:57 AM Information [localhost-startStop-1] - Starting security...

Sep 30, 2015 09:09:57 AM Information [localhost-startStop-1] - Starting scheduler...

Sep 30, 2015 09:09:57 AM Information [localhost-startStop-1] - Starting WatchService...

Sep 30, 2015 09:09:57 AM Information [localhost-startStop-1] - Starting debugging...

Sep 30, 2015 09:09:57 AM Information [localhost-startStop-1] - Starting sql...

Sep 30, 2015 09:09:57 AM Information [localhost-startStop-1] - Pool Manager Started

Sep 30, 2015 09:09:58 AM Information [localhost-startStop-1] - Starting mail...

Sep 30, 2015 09:09:58 AM Information [localhost-startStop-1] - Starting runtime...

It does not appear to be stopping in the same place every time.

The coldfustion-error.log for the same time period shows the following:

Sep 30, 2015 8:49:34 AM org.apache.catalina.core.ApplicationContext log

INFO: ColdFusionStartUpServlet: ColdFusion: Starting application services

Sep 30, 2015 8:49:34 AM org.apache.catalina.core.ApplicationContext log

INFO: ColdFusionStartUpServlet: ColdFusion: VM version = 24.71-b01

Sep 30, 2015 8:49:46 AM org.apache.catalina.core.AprLifecycleListener init

INFO: The APR based Apache Tomcat Native library which allows optimal performance in production environments was not found on the java.library.path: E:\\ColdFusion10\\cfusion\lib;E:\\ColdFusion10\\cfusion\jintegra\bin;E:\\ColdFusion10\\cfusion\jintegra\bin\international;E:\\ColdFusion10\\cfusion\lib\oosdk\classes\win

Sep 30, 2015 8:49:47 AM org.apache.coyote.AbstractProtocol init

INFO: Initializing ProtocolHandler ["ajp-bio-8012"]

Sep 30, 2015 8:49:47 AM org.apache.catalina.core.StandardService startInternal

INFO: Starting service Catalina

Sep 30, 2015 8:49:47 AM org.apache.catalina.core.StandardEngine startInternal

INFO: Starting Servlet Engine: Apache Tomcat/7.0.54

Sep 30, 2015 8:53:39 AM org.apache.catalina.core.ApplicationContext log

INFO: ColdFusionStartUpServlet: ColdFusion: Starting application services

Sep 30, 2015 8:53:39 AM org.apache.catalina.core.ApplicationContext log

INFO: ColdFusionStartUpServlet: ColdFusion: VM version = 24.71-b01

Sep 30, 2015 8:54:06 AM org.apache.catalina.core.AprLifecycleListener init

INFO: The APR based Apache Tomcat Native library which allows optimal performance in production environments was not found on the java.library.path: E:\\ColdFusion10\\cfusion\lib;E:\\ColdFusion10\\cfusion\jintegra\bin;E:\\ColdFusion10\\cfusion\jintegra\bin\international;E:\\ColdFusion10\\cfusion\lib\oosdk\classes\win

Sep 30, 2015 8:54:07 AM org.apache.coyote.AbstractProtocol init

INFO: Initializing ProtocolHandler ["ajp-bio-8012"]

Sep 30, 2015 8:54:07 AM org.apache.catalina.core.StandardService startInternal

INFO: Starting service Catalina

Sep 30, 2015 8:54:07 AM org.apache.catalina.core.StandardEngine startInternal

INFO: Starting Servlet Engine: Apache Tomcat/7.0.54

Sep 30, 2015 8:57:56 AM org.apache.catalina.core.ApplicationContext log

INFO: ColdFusionStartUpServlet: ColdFusion: Starting application services

Sep 30, 2015 8:57:56 AM org.apache.catalina.core.ApplicationContext log

INFO: ColdFusionStartUpServlet: ColdFusion: VM version = 24.71-b01

java.lang.NullPointerException

at coldfusion.server.jrun4.metrics.SimpleLoadMetric.run(SimpleLoadMetric.java:157)

at coldfusion.scheduling.ThreadPool.run(ThreadPool.java:260)

at coldfusion.scheduling.WorkerThread.run(WorkerThread.java:71)

Sep 30, 2015 9:06:02 AM org.apache.catalina.core.AprLifecycleListener init

INFO: The APR based Apache Tomcat Native library which allows optimal performance in production environments was not found on the java.library.path: E:\\ColdFusion10\\cfusion\lib;E:\\ColdFusion10\\cfusion\jintegra\bin;E:\\ColdFusion10\\cfusion\jintegra\bin\international;E:\\ColdFusion10\\cfusion\lib\oosdk\classes\win

Sep 30, 2015 9:06:02 AM org.apache.coyote.AbstractProtocol init

INFO: Initializing ProtocolHandler ["ajp-bio-8012"]

Sep 30, 2015 9:06:03 AM org.apache.catalina.core.StandardService startInternal

INFO: Starting service Catalina

Sep 30, 2015 9:06:03 AM org.apache.catalina.core.StandardEngine startInternal

INFO: Starting Servlet Engine: Apache Tomcat/7.0.54

Sep 30, 2015 9:09:56 AM org.apache.catalina.core.ApplicationContext log

INFO: ColdFusionStartUpServlet: ColdFusion: Starting application services

Sep 30, 2015 9:09:56 AM org.apache.catalina.core.ApplicationContext log

INFO: ColdFusionStartUpServlet: ColdFusion: VM version = 24.71-b01

The Tomcat error is also showing up in the logs of our development server which is not having this startup problem.

Thanks for taking a look Carl.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 02, 2015 0
Adobe Community Professional ,
Oct 02, 2015

Copy link to clipboard

Copied

I’d say that there’s nothing in those logs to explain what’s happening.

Are you finding that the ColdFusion.exe service IS or IS NOT running (in task manager) when you start it, after these log lines are written? If you wait several minutes? If it is NOT, then look in the coldfusion10\cfusion\bin folder (yes, the bin folder) to see if there are any logs there, starting with he_err_pid*.log. If there are, at the times of these startups, what do they say, in just the first few lines?

If the ColdFusion.exe DOES remain running, but you just find you can’t find that it responds, that’s a separate problem.

I will say that sometimes trying to debug these sort of problems in the forums is difficult. There are just too many variables. If there is a pressing need to get things working again, there are folks (myself included) who provide remote troubleshooting services (even if you can’t “let us remote in”). I list such consultants as a category of the CF411 resource on my site, specifically cf411.com/cfconsult.

But we try to help here on the forums as well, as much as we can.

/charlie

/Charlie (server troubleshooter, carehart.org)

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 02, 2015 1
Guide ,
Oct 03, 2015

Copy link to clipboard

Copied

I understand the issue is not related to CF tomat optimal performance message.

Any "hs" error logs generated in CF10\cfusion\bin ?

Regards, Carl.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 03, 2015 1
Community Beginner ,
Oct 05, 2015

Copy link to clipboard

Copied

No. I am thinking of just uninstalling and reinstalling ColdFusion.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 05, 2015 0
Guide ,
Oct 05, 2015

Copy link to clipboard

Copied

Hi Tracy,

Well that should fix it remove CF10, install CF10, apply any customisations you may need like datasources, JVM parameters, tomcat server.xml or property files. Perhaps some customisation can be put back by

keeping a copy of neo* files from CF10\cfusion\lib\.

 

Beg my pardon to Charlie I repeated something he suggested (tho with a typo he versa hs errors). It was a long weekend for me and I did not read the post well.

Regards, Carl.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 05, 2015 1