Highlighted

ColdFusion 11 new installation; service won't start on 2008 R2

Community Beginner ,
Jul 24, 2014

Copy link to clipboard

Copied

I've just installed ColdFusion 11 on a clean Windows Server 2008 R2 machine and the ColdFusion application service looks like it starts, but then a minute later, shows that it is not running (in the services panel). When I try to restart it, it simply will not start. It comes back with the typical error "This application took too long to respond..." so now it just hangs in a "starting" state. I've rebooted the server several times, there is nothing else running on the server. Any help would be appreciated. Thanks.

Views

2.9K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

ColdFusion 11 new installation; service won't start on 2008 R2

Community Beginner ,
Jul 24, 2014

Copy link to clipboard

Copied

I've just installed ColdFusion 11 on a clean Windows Server 2008 R2 machine and the ColdFusion application service looks like it starts, but then a minute later, shows that it is not running (in the services panel). When I try to restart it, it simply will not start. It comes back with the typical error "This application took too long to respond..." so now it just hangs in a "starting" state. I've rebooted the server several times, there is nothing else running on the server. Any help would be appreciated. Thanks.

Views

2.9K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Jul 24, 2014 0
Explorer ,
Jul 24, 2014

Copy link to clipboard

Copied

Tell us more about your installation. Was is server configuration? embedded? EAR or WAR? Seperate partition? Is the coldfusion service starting up as LOCAL SYSTEM or another user?

I've had CF11 trial for two weeks and I've have not had any easy installation process.

Also, I believe a week ago I had the same problem and I reconfigured (using the WSCONFIG.exe in cfusion/bin) the IIS server to 32 bit eventhough my system is 64 bit and using the 64 bit CF server. It was super easy to get up and running with coldfusion 9, but i don't know what changed, if anything, that makes CF 11 so difficult. The installation by default should just have everything preconfigured. The installation should take care of permissions, users, default passwords, default features, etc. 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jul 24, 2014 0
Explorer ,
Jul 24, 2014

Copy link to clipboard

Copied

Jalmk, let me know if you get to the admin page successfully and successfully login in your first attempt. Because for me the password is not accepted. I have to reset IE, restart system, do the password reset, and restart cf servive.

following something like this guide was also difficult for me. atleast the built-in server works fine, but once you use IIS its get screwed.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jul 24, 2014 0
Community Beginner ,
Jul 24, 2014

Copy link to clipboard

Copied

After reading more on this forum, I saw that there was a hotfix for version 11 that might help me, but I needed to email adobe to get it. So I did. I received the hotfix and it did seem to solve that problem, but now I have another problem. IIS will not serve any .cfm pages. This server has been reconfigured too many times so I am going to start clean. I am currently uninstalling IIS and then I will reinstall it, CF11, and the hotfix and see what happens.

My installation is on a standalone server a VM running Windows Server 2008 R2. I downloaded the installation from Adobe (after paying for it ) and simply ran the install. I used most of the defaults and gave it a password. Then applied the hotfix. At this point still no joy. I'll update if I find a cure after reinstalling everything (again).

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jul 24, 2014 0
Explorer ,
Jul 24, 2014

Copy link to clipboard

Copied

Jalmk, we're going through the exact same thing. Except I'm doing reinstall after reinstall without a hotfix. Emailing now...

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jul 24, 2014 0
Explorer ,
Jul 24, 2014

Copy link to clipboard

Copied

Jalmk, check out my other post on this forum Submitting cfadmin login password I get "an invalid method (http verb) is being used." Have you across this? Why is it that immediately after a fresh install and the install at finish attempts to open the admin page for me I get this error? My 2012 Server is a clean install as well. IIS default website works fine, but not with CF.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jul 24, 2014 0
Community Beginner ,
Jul 25, 2014

Copy link to clipboard

Copied

I finally got this working, although I haven't tested everything yet. but Basically I uninstalled IIS, and CF11, then reinstalled IIS, then reinstalled CF11. The hotfix belongs in a particular directory (C:\coldfusion11\cfusion\lib\updates\) but the installation tries to start the service before the hotfix is applied. So what I did was try to beat the installation by copying the .jar hotfix to the proper folder before the installation tried to start the service. I had about 30 seconds. The folder for the hotfix does not get created right away, so you have to wait and watch for the folder to be created and then as soon as it is, copy the hotfix into it and then about 30 seconds later the installation will try to start the service. By doing this, I was able to get the service started during the installation process so that everything would continue. After the service started I was able to log in and configure the server and finish the process.

One other note, was that I was trying "production + secure" profile during the setup and I could never get this working so I gave up on it and just chose the production profile. I don't know why this never worked. All I would ever get was a blank screen when trying to open .cfm pages after the installation process I described above. The service was started and I would not get an error either on the web page or in the event logs, just a blank web page. So I finally gave up on it. The production profile seems to be working fine so far.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jul 25, 2014 1
New Here ,
Jul 28, 2014

Copy link to clipboard

Copied

Hi, I have a similar trouble so can you tell me the email address from Adobe to ask for the hotfix or can you send me it your hotfix. I want to try your solution.

Thanks.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jul 28, 2014 0
Community Beginner ,
Jul 28, 2014

Copy link to clipboard

Copied

The email address was cfinstal@adobe.com

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jul 28, 2014 1
Explorer ,
Dec 31, 2014

Copy link to clipboard

Copied

jalmk, did you ever find a fix to your error where IIS 7 server would not serve requests made for cfm files.  I usually can work my way though the error messages after my upgrade from CF9 to CF11, but get stuck here.  I was even on the phone with an Adobe representative and we checked the applicationhost.config file, the webconfig file, all the request filtering file name extensions in IIS, but nothing shows why it would deny a cfm file.  everything is set to true for IIS and the config files.  I have the hotfix installed as well.  I'm about to toss this installation and try again, but I never get any further.  I've been working on this for 2 months.  It can't be this difficult.  We have some strange security files that the application.cfc passes to before it will even run the first application page, but I can't even get the webpage to run because of this issue.  Any help will be extremely appreciated.  Thanks!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Dec 31, 2014 0
Enthusiast ,
Jan 01, 2015

Copy link to clipboard

Copied

Enable the internal port (8500) of CF11

Place a test.cfm in wwwroot (in CF 11)

Test, whether CF 11 is able to serve .cfm or not. If yes, then it means CF 11 is able to server .cfm perfectly fine

Now, you need to test CF 11 with IIS

Create a test site in IIS and then place test.cfm in the webroot of this new site

Make sure that the ColdFusion handlers are added in the IIS level/site level depending upon your requirement. You can achieve the same via Web Server Configuration tool

If you receive any error, you need to specify the error that you are getting. Say, you get 500 error, that can be anything like App pool of your site might be in 32 bit where you might have installed CF 11 64 bit and created the connector (via Web Server Configuration tool) as 64 bit.

HTH

Thanks

VJ

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jan 01, 2015 0
Community Beginner ,
Jan 05, 2015

Copy link to clipboard

Copied

Yes, I was able to get it working following the steps I mentioned above. Other than that, I don't know what to tell you about why IIS wouldn't serve the pages in the first place. Good luck.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jan 05, 2015 0
Explorer ,
Jan 06, 2015

Copy link to clipboard

Copied

OK, to confirm:

My ColdFusion Administrator already has an internal webserver, so port 8500 is already enabled.

I placed a silly hello world cfm file at the wwwroot level, and yes, it has some cf code in it.

entered http://localhost:8500/index.cfm and it processed the cfm page just fine.

I already had a test website with this test index.cfm hello world file in it.

It is connected with the wsconfig for coldfusion 11 to IIS 7.5.  cf handlers are there.  cfide and jakarta links are created.

I run the page http://127.0.0.1/index.cfm

get the following error message:

******************************************

HTTP Error 404.7 – Not Found.  The request filtering module is configured to deny the file extension.

Module                RequestFilteringModule                               Requested URL                 http://localhost:80/jakarta/isapi_redirect.dll

Notification        BeginRequest                                                    Physical Path                      D:\ColdFusion11\config\wsconfig\2\isapi_redirect.dll

Handler                ISAPI-dll                                                               LogonMethod                   Not yet determined

Error Code          0x00000000                                                         Logon User                         Not yet determined

Most likely causes:

Request filtering is configured for the Web server and the file extension for this request is explicitly denied.

Things you can try:

Verify the configuration/sustem.webServer/security/requestFiltering/fileExtensions settings in applicationhist.config and web.config.

****************************************

  

If I go to applicationhost.config or web.config everything is set to allow for the coldfusion extensions.  Going to IIS UI,  Request Filtering, the coldfusion extensions are all set to true. If I change the Request Filtering Feature Settings and allow unlisted file name extensions then it will work, but that is not an option for our hyper secure website.

Thanks for your continuted help!

Jennifer

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jan 06, 2015 0
Enthusiast ,
Jan 07, 2015

Copy link to clipboard

Copied

Does the web.config of your site looks like this?

<?xml version="1.0" encoding="UTF-8"?>
<configuration>
  <system.webServer>
  <security>
  <requestFiltering>
  <fileExtensions allowUnlisted="true">
 
  <add fileExtension=".cfm" allowed="true" />
  </fileExtensions>
  </requestFiltering>
  </security>
  </system.webServer>
</configuration>

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jan 07, 2015 0
Adobe Community Professional ,
Jan 08, 2015

Copy link to clipboard

Copied

@Jalmk

Thanks for sharing your experience. As you are happy with the solution you describe in your post of July 25, please mark it as the correct answer.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jan 08, 2015 0
jkcrosby LATEST
Explorer ,
Jan 15, 2015

Copy link to clipboard

Copied

What ended up being my problem is that my virtual jakarta folder in IIS for my website didn't have request filtering allowed for .dll, therefore it kept denying the extension trying to run coldfusion.  Once I added the .dll extension as allowed in Request Filtering it worked. Note my message above actually does say 

Request filtering is configured for the Web server and the file extension for this request is explicitly denied. 

I guess it just took a while for that to sink in for me to understand what I needed to do.

I hope this helps someone.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jan 15, 2015 0