Highlighted

ColdFusion 11 update 13: what JDK version is actually enough?

New Here ,
Oct 03, 2017

Copy link to clipboard

Copied

Hello,

The requirements for update 13 sound not quite clear: At the very top it says "This security update requires ColdFusion to be on JDK 7u131 or higher.". At the same time at the bottom for post installation the document states: "After installation, point the JDK to JDK 7u131 or JDK 8u121 or higher.". So, should it be just JDK 7u131, JDK 8u121 or higher? We are having Java Version 1.8.0_25 . Does it mean we are OK? Or do we have to update?

TIA

TOPICS
Getting started

Views

2.1K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

ColdFusion 11 update 13: what JDK version is actually enough?

New Here ,
Oct 03, 2017

Copy link to clipboard

Copied

Hello,

The requirements for update 13 sound not quite clear: At the very top it says "This security update requires ColdFusion to be on JDK 7u131 or higher.". At the same time at the bottom for post installation the document states: "After installation, point the JDK to JDK 7u131 or JDK 8u121 or higher.". So, should it be just JDK 7u131, JDK 8u121 or higher? We are having Java Version 1.8.0_25 . Does it mean we are OK? Or do we have to update?

TIA

TOPICS
Getting started

Views

2.1K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Oct 03, 2017 0
Community Beginner ,
Oct 03, 2017

Copy link to clipboard

Copied

ColdFusion11 Update13 support Java 1.8 update 25, but they suggested to updated JDK7u131, JDK8u121  or higher for better performance.

I'm running CF11 Update13 with JDK 1.8u25, it works fine.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 03, 2017 0
New Here ,
Oct 03, 2017

Copy link to clipboard

Copied

Thank you. Yes, we updated as well and it works fine. But the doc states:

"Adobe recommends that you must manually update your ColdFusion JDK/JRE to the latest version.

In case you do not update the JDK/JRE, simply applying the update would NOT secure the server."

So, the question is, does the security fixes got applied to 1.8.0_25 or not?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 03, 2017 0
Guide ,
Oct 03, 2017

Copy link to clipboard

Copied

Hello,

>So, the question is, does the security fixes got applied to 1.8.0_25 or not?

You need to install JDK8 1.8.0_121 (aka 8u121) or greater. 1.8.0_144 is latest to use with CF.

Of note Oracle "latest JDK" is 9 as of end of September. So far I have not seen notice that CF supports JDK 9.

This blog reference can be helpful for details on how to change CF Java version.

http://blogs.coldfusion.com/installing-and-troubleshooting-java-updates-in-coldfusion/

Regards, Carl

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 03, 2017 1
Community Beginner ,
Nov 12, 2018

Copy link to clipboard

Copied

Thanks. That's very helpful. Where do I go to find the latest version that's supported. You have mentioned 8u144. Where is this information published? Thanks in advance.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 12, 2018 0
Adobe Community Professional ,
Nov 12, 2018

Copy link to clipboard

Copied

In general, CF supports the latest major version corresponding to the minor version already installed or previously supported. With 8u25, "8" is the major version and "25" is the minor version. So, for example, if 8u25 was supported (or 1.8.0.25, or however else it might be labeled), you would be able to use 8uXXX where XXX is any value greater than 25.

I hope that makes sense!

Dave Watts, Fig Leaf Software

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 12, 2018 0
chkamran LATEST
Community Beginner ,
Nov 12, 2018

Copy link to clipboard

Copied

The latest version is 8u192, so when you mentioned 8u144, I assumed that it was the last updated tested and supported by Adobe for CF 11.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 12, 2018 0